Connection SSH impossible après program_usb_boot_mode=1 [RESOLU]

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Virus
Messages : 8
Enregistré le : dim. 15 oct. 2017 15:57

Connection SSH impossible après program_usb_boot_mode=1 [RESOLU]

Message par Virus » dim. 15 oct. 2017 16:44

Bonjour,

Afin de pouvoir booter directement sur une clé usb j'ai reprogrammé l’OTP de mon nouveau RPI3 en ajoutant program_usb_boot_mode=1. Au reboot suivant j'ai utilisé la commande vcgencmd pour vérifier que la reprogrammation s'était parfaitement déroulée. Mais la commande n'était pas reconnue : je me suis alors rendu compte que je n'avais pas installé Raspbian mais Kali (J'ai glissé chef :mrgreen: )

Résultat, avec Kali sur carte SD j'accède au RPI3 par SSH mais Putty m'insulte si j'utilise Raspbian sur carte SD ou USB :

PuTTY Fatal Error
Network error: Connection refused

Quel que soit l'OS ou la box internet mon RPI3 apparaît sous la page d'admin de ces box donc Raspbian doit bien booter. Mais je n'ai pas d'écran HDMI pour un accès direct.

Quelqu'un sait ce qui s'est passé, et comment je pourrais reprendre la main avec Raspbian ?
Modifié en dernier par Virus le sam. 22 déc. 2018 19:59, modifié 1 fois.

nexen
Raspinaute
Messages : 175
Enregistré le : lun. 29 sept. 2014 13:58

Re: Connection SSH impossible après program_usb_boot_mode=1

Message par nexen » dim. 15 oct. 2017 21:09

Hello

Dans tes actions je ne te vois pas dire à Raspian d'ouvrir le SSH :)

as-tu penser à suivre la procédure ou à faire un raspi-config ? :)

Nexen

Virus
Messages : 8
Enregistré le : dim. 15 oct. 2017 15:57

Re: Connection SSH impossible après program_usb_boot_mode=1

Message par Virus » dim. 15 oct. 2017 22:19

Une procédure pour activer le SSH ? Ok j'ai compris.

Depuis les attaques via des objets connectés en 2016, la Fondation Raspberry Pi a désactivé par défaut le serveur SSH sur ses images Raspbian. Mes premiers pas avec le RPI sont antérieurs à 2016. J'étais passé à côté de cette nouvelle. SSH fonctionne désormais.

Merci de m'avoir mis sur la voie Nexen :)

nexen
Raspinaute
Messages : 175
Enregistré le : lun. 29 sept. 2014 13:58

Re: Connection SSH impossible après program_usb_boot_mode=1

Message par nexen » lun. 16 oct. 2017 10:28

Mais de rien !

j'ai eu le même soucis déjà :)

N'oublie pas de modifié le titre en Résolu :)

Nexen

Virus
Messages : 8
Enregistré le : dim. 15 oct. 2017 15:57

Re: Connection SSH impossible après program_usb_boot_mode=1

Message par Virus » lun. 16 oct. 2017 18:07

J'aimerais bien le passer en résolu mais je n'ai pas trouvé comment faire :oops:

domi
Administrateur
Messages : 2589
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Connection SSH impossible après program_usb_boot_mode=1

Message par domi » mar. 17 oct. 2017 10:01

Si vous estimez que votre problème est résolu, merci d'ajouter [RESOLU] au début du titre du sujet.
Pour ce faire, visualiser le premier Post que vous avez réalisé, cliquez sur "Editer", et ajouter [RESOLU] devant le titre, sans l'effacer.

Cela permet que le message soit tout de suite identifié comme ayant eu une réponse correspondant à la demande.
Ainsi, les visiteurs en sont informés, aussi bien lors d'une recherche sur le forum qu'au travers des moteurs de recherche.

Merci d'avance !
Cordialement.

Répondre

Retourner vers « En panne ? »