433Utils

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
frorgaba
Messages : 10
Enregistré le : mer. 8 nov. 2017 20:39

433Utils

Message par frorgaba » sam. 9 déc. 2017 16:45

Bonjour à tous

j'essaie désespéramment d'installer 433Utils sur mon Pi3
mais à chaque tentative je reçois ce message

"pi@raspberrypi:~ $ git clone git://github.com/ninjablocks/433Utils.git
Clonage dans '433Utils'...
fatal: unable to connect to github.com:
github.com[0: 192.30.253.112]: errno=Connexion terminée par expiration du délai d'attente
github.com[1: 192.30.253.113]: errno=Connexion terminée par expiration du délai d'attente"

quelqu'un pour m'aider?

maxty01
Modérateur
Messages : 729
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: 433Utils

Message par maxty01 » sam. 9 déc. 2017 17:00

Bonsoir,

Vérifiez si vous avez accès à internet sur le RPI.

Pour un bon test, utilisez la commande suivante :
Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

frorgaba
Messages : 10
Enregistré le : mer. 8 nov. 2017 20:39

Re: 433Utils

Message par frorgaba » sam. 9 déc. 2017 22:05

Bonsoir et merci pour l'aide;

pas de soucis de connexion internet

par contre pour le ping, cela ne fonctionne pas sous le phrasé indiqué
en mettant : ping -c 4 http://www.google.com
j'obtiens : ping: unknown host http://www.google.com

par contre en tapant simplement

ping google.com

j'ontiens

--- google.com ping statistics ---
12 packets transmitted, 12 received, 0% packet loss, time 11017ms

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: 433Utils

Message par spourre » dim. 10 déc. 2017 00:33

frorgaba a écrit : ...

en mettant : ping -c 4 http://www.google.com
j'obtiens : ping: unknown host http://www.google.com

par contre en tapant simplement

ping google.com

j'ontiens

--- google.com ping statistics ---
12 packets transmitted, 12 received, 0% packet loss, time 11017ms
Ça c'est normal.
Il y a eu confusion entre une URL et une @IP

Sylvain

maxty01
Modérateur
Messages : 729
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: 433Utils

Message par maxty01 » dim. 10 déc. 2017 00:42

spourre a écrit :
frorgaba a écrit : ...

en mettant : ping -c 4 http://www.google.com
j'obtiens : ping: unknown host http://www.google.com

par contre en tapant simplement

ping google.com

j'ontiens

--- google.com ping statistics ---
12 packets transmitted, 12 received, 0% packet loss, time 11017ms
Ça c'est normal.
Il y a eu confusion entre une URL et une @IP

Sylvain
Non, c'est un malheureux copié/collé que je n'ai pas corrigé ...

Par contre, pour le GIT, n'utilisant que très peu l'outil, je ne peux t'aider plus.

Peut-être pour donner des indications, utilises-tu un firewall sur ton réseau ?

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

frorgaba
Messages : 10
Enregistré le : mer. 8 nov. 2017 20:39

Re: 433Utils

Message par frorgaba » dim. 10 déc. 2017 20:59

j'ai juste le firewall de ma box.
pour d'autres paquets (WiringPi) je n'ai pas eu de soucis.
C'est juste 433Utils qui bloque.

si quelqu'un a le fichier en tar.gz ...

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: 433Utils

Message par spourre » dim. 10 déc. 2017 23:16

frorgaba a écrit : ...
si quelqu'un a le fichier en tar.gz ...
Bonsoir,

J'ai accédé au git, par la commande git, sans problème depuis ma machine de développement.
Je suis aussi allé sur le site de ninjablock.com et je n'ai pas vu de version à télécharger depuis le navigateur.
Je suis retourné sur le git mais en HTTP cette fois ci:
https://github.com/ninjablocks/433Utils/tree/master
en haut, à droite, il y a le bouton pour charger l'archive zip (bouton vert, marqué clone or download )
Ça fonctionne et j'obtiens bien une archive avec les croquis Arduino, les sources Raspberry et les checksums de chacun de ces fichiers.
Par contre, la branche master est peu active et les fichiers ont déjà 1 an (une éternité en informatique).
Dans le README on trouve:
## Requirements

1. An Arduino (two is ideal)
2. A Raspberry Pi
3. The git commandline tool, on both your Arduino IDE machine and your RPi
4. RF 433MHz modules; a transmitter and receiver
5. A Ninja Block and account
Le point 4 m'interpelle. Est-ce à dire qu'il faut un login chez ninja pour utiliser ces outils ?
A titre personnel, je serais très méfiant (en clair, je n'installerai pas du tout) une application domotique qui dépend d'Internet pour fonctionner et avec un produit certes libre mais où la collectivité semble peu active.
J'aurais trop peur de me retrouver, du jour au lendemain, avec un beau matériel inutilisable.

Sylvain

Répondre

Retourner vers « En panne ? »