pihole contre décodeur TV & Livebox (orange)

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
eulalia
Messages : 4
Enregistré le : mer. 3 janv. 2018 21:42

pihole contre décodeur TV & Livebox (orange)

Message par eulalia » mer. 3 janv. 2018 22:08

Bonsoir :P

Mon premier projet "durable" avec ma première framboise (elle a reçu la dernière Raspian), c'est d'y installer pihole (chose faite), le faire tourner et y rajouter d'autres options (comme OpenVPN, OwnCloud, un serveur courriel, ...) par la suite.

A priori, le pihole tourne et après plusieurs jours, les pubs sont effectivement bloquées sur mon téléphone portable et les trois ordis de la famille que j'ai pu tester.

Mais, je rencontre un souci avec le décodeur TV d'orange. Quand pihole tourne, certaines fonctions (dont le replay) sont bloquées avec l'erreur P01 (solution proposée par orange: éteindre et redémarrer tout). Quand j'éteins mon petit trou à pub... toutes les fonctions TV sont rétablies. Quand ma framboise tourne, les enfants se réjouissent de la diminution des publicités à la télé...

Mon réseau :

192.168.1.1 livebox Sagemcom (case DNS grisée), branché directement dessus : le décodeur TV, l'imprimante, le pihole et un CPL pour le reste de la maison (le wifi ne passe pas bien) ; le DHCP est désactivé (l'interface est super poussive, ça prend un temps fou pour saisir des trucs et pour les valider).

192.168.1.2 mon petit framboisier impatient, avec certains des serveurs DNS proposés (pas google, hein, on tiens à sa sphère privée) ;) , aussi comme serveur DHCP. Y sont définis (par plages et par utilisateur) les autres appareils du réseau domestique.

Le décodeur TV y a reçu l'IP 192.168.1.250 (presque tout à la fin, il ne tourne que quand la TV tourne et j'aime bien pouvoir l'identifier " de loin ").

Dans mes listes de blocage, tous les serveurs *.orange.fr brillent par leur absence, dans les logs, toutes les demandes du décodeur TV sont vertes.

De quelles infos supplémentaires auriez-vous besoin pour m'aider à trouver la solution ?

La solution que je vois pour le moment, ce serait d'acheter un 2e router, de le brancher derrière la livebox (serveur DHCP actif) en 192.168.1.10 et d'y attribuer une autre plage d'adresses réseau à mes appareils ? Donc, concrètement, j'ai dans l'idée cette config :

192.168.1.1 livebox (DHCP actif pour 192.168.1.1-255) avec :
192.168.1.250 décodeur TV
192.168.1.10 2e router (DHCP actif pour 192.168.2.1-255)
192.168.2.1 pihole (DHCP inactif)
192.168.2.x autres appareils du réseau

Mais ça me semble coûteux et compliqué. Etant compliquée (je plaide coupable :oops: ), je viens donc ici pour voir s'il y a des âmes éclairées qui peuvent me donner d'autres bonnes idées avant l'achat d'un router... Ou est-ce que je pourrais configurer mon raspi en router avec pihole et tout le reste dessus ? Dans ce cas, comment faire ?

Vous voyez, j'ai plein de questions et ma tête n'arrête pas de fumer :? Alors je vais me calmer et aller dormir, demain, les enfants seront debout tôt ;)

Un grand merci pour toutes idées et un gros bizzz à tous ceux qui m'ont lue et qui se creusent les méninges avec moi.

Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

Re: pihole contre décodeur TV & Livebox (orange)

Message par Korhm » jeu. 4 janv. 2018 09:48

Bonjour,

j'avais tenté pour ma part de remplacer sur DHCP de la Livebox par celui d'un serveur Linux (avec Dnsmasq), et j'avais le même soucis de TV.
A priori, j'avais cru comprendre que c'est parce que la TV ne peut utiliser que les serveurs DNS Orange (ceux rentrés dans la Livebox et qu'on ne peut pas modifier). Il y a peut-être aussi une histoire de VLAN,...
Je sais quepihole utilise aussi dnsmasq pour fonctionner.


Pour ton problème, je vois plusieurs pistes :

1. Garder le DHCP de La livebox avec un range de 1 ou 2 adresses (je crois que 1 ce n'est pas possible), avec celui de pihole en parallèle. Sur pihole (dnsmasq), ignorer les requêtes dhcp venant du décodeur (et d'un autre device puisque le range dhcp contient 2 ip).
Dans ce cas, une fois que la livebox a rempli son pool dhcp, elle ne répondra plus aux requêtes DHCP des autres terminaux.
C'est ce que j'ai mis en place chez moi. C'est du bricolage, mais à cette époque je ne connaissais que cette solution.

2. Configurer pihole pour mettre une adresse DNS différente suivant l'équiepement source des requêtes DHCP.
Je ne sais pas si fonctionne, jamais testé, mais ça peut être fait grâce à des "tags" dans la config dnsmasq (exemple : http://www.linksysinfo.org/index.php?th ... nts.68865/)

3. Configurer les DNS Orange dans pihole, plutôt que le DNS google, ou opendns, ou autre.
Pareil, pas testé.



Si tu testes la solution 2 ou 3, je serais curieux de connaitre le résultat :)

eulalia
Messages : 4
Enregistré le : mer. 3 janv. 2018 21:42

Re: pihole contre décodeur TV & Livebox (orange)

Message par eulalia » jeu. 4 janv. 2018 19:28

Coucou,

Heureuse de savoir que je ne suis pas la seule à avoir ce souci ;)

[quote="Korhm"]
Je sais quepihole utilise aussi dnsmasq pour fonctionner.
[/quote]
Merci, je vais déjà me documenter là-dessus. Ubuntu-fr sera mon point de départ

pour voir laquelle de tes 3 propositions est :
- la plus facile à mettre en place pour une débutante comme moi
- la plus fiable pour garder le replay sur la TV

[quote="Korhm"]
1. Garder le DHCP de La livebox avec un range de 1 ou 2 adresses (je crois que 1 ce n'est pas possible), avec celui de pihole en parallèle. Sur pihole (dnsmasq), ignorer les requêtes dhcp venant du décodeur (et d'un autre device puisque le range dhcp contient 2 ip).
[/quote]
Intéressant. Je reformule :
- la livebox avec DHCP et un range minimal, de préférence en attribuant les IP du range comme IP fixes pour remplir le pool DHCP :mrgreen: donc, le décodeur et le raspi avec pihole.
- comment faire pour que pihole ignore les requêtes DHCP du décodeur ? En le mettant sur la box... élémentaire, mon cher Watson.
- pihole avec DHCP et un range autre que celui de la box qui gère toutes les autres IP du réseau.

ça semble facile et rapide. Si ton idée N° 2 ne donne pas de résultat satisfaisant, je vais tester ça pour voir si j'arrive à biaiser le décodeur 8-)

[quote="Korhm"]
2. Configurer pihole pour mettre une adresse DNS différente suivant l'équiepement source des requêtes DHCP.
grâce à des "tags" dans la config dnsmasq
[/quote]
C'est l'approche qui me plairait le mieux parmi les 3 que tu as proposées, c'est plus "élaboré" :lol: faudra que je bidouille pour trouver et pour faire fonctionner ça. N'est-ce pas le but du raspi ? :mrgreen:
En espérant avoir bien compris l'anglais (euh... :oops: :oops: :oops: ) et ubuntu-fr...

Voilà ce que ça donne après un long moment de lecture et de reflexion :

sur le raspi, je rajoute dans /etc/dnsmasq.conf :

dhcp-host=<MAC du décodeur>,set:red
dhcp-option=tag:red,option:dns-server,<serveur DNS 1 d'orange>,<serveur DNS 2 d'orange>

le tout suivi d'un sudo /etc/init.d/dnsmasq restart

Mais à quoi sert le petit "red" ? Est-ce bien pour relier les deux lignes entre elles ?

Je n'ai pas la paix, ni la tranquillité pour essayer ça tout de suite et pour y mettre tous les bons chiffres, la famille tourbillonne trop autour. Ca semble facile et rapide aussi, et plus "propre" que le bidouillage avec 2 serveurs DHCP. A tester plus tard quand les mômes seront couchés et le mari aussi :D

[b]Edit :[/b] ô miracle, Monsieur a vu une différence au niveau des pubs sur son smartphone avec pihole et il est tout feu tout flamme pour m'aider à essayer :shock:
Donc, j'ai donc mis en place cette solution (et découvert par la même occase le magnifique fichier dnsmasq.conf), redémarré la box et le décodeur et - pour le moment, le replay marche. :)

Par contre, je constate du coup, que le décodeur prend une IP variable dans le pool DHCP du raspi. Je suis en train de bidouiller pour essayer de lui attribuer une IP fixe

Je reste prudemment optimiste, mon expérience m'a montré qu'il fallait observer pendant plusieurs jours de suite avant de pouvoir être certaine d'avoir vraiment trouvé la bonne solution. :oops:
A priori, tu m'as aidée à trouver la solution :!:

[b]fin d'édit[/b]

[quote="Korhm"]
3. Configurer les DNS Orange dans pihole, plutôt que le DNS google, ou opendns, ou autre.
[/quote]
Perso, cette solution me déplaît, je trouverais bête d'utiliser le DNS d'orange alors que je veux justement en utiliser un ouvert et qui ne logue pas ce que je lui demande. Je la garde en dernier recours.

Un grand merci et un gros bizzz, je reviens plus tard avec le résultat de la solution 2...

[quote="Korhm"]
Si tu testes la solution 2 ou 3, je serais curieux de connaitre le résultat :)[/quote]
évidemment ;) Je ne serai pas la dernière ayant la question et il va de soi qu'il faut partager ses connaissances.

Répondre

Retourner vers « En panne ? »