Grosse carte SD et gros ralentissement et panne.

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Avatar du membre
troumad
Messages : 69
Enregistré le : sam. 13 févr. 2016 17:18

Grosse carte SD et gros ralentissement et panne.

Message par troumad » sam. 27 janv. 2018 17:29

Bonjour

J'ai un serveur sur un PI 2. Je viens de changer sa carte mémoire par manque de place : je suis passé de 64 à 128Go. Lors de la mise à jour, je suis aussi passé de la version 8 à la version 9 de debian.
Maintenant, il est lent. Même la complétion (surtout la complétion même) est lente en ligne de commande.

Pour info, voici ma carte : https://www.kubii.fr/fr/carte-sd-et-sto ... &results=1 . Il me semble bien que c'est du matériel rapide...

Code : Tout sélectionner

 $ df
Sys. de fichiers blocs de 1K  Utilisé Disponible Uti% Monté sur
/dev/root            7086396  1618388    5090124  25% /
devtmpfs              470184        0     470184   0% /dev
tmpfs                 474792        0     474792   0% /dev/shm
tmpfs                 474792     6512     468280   2% /run
tmpfs                   5120        4       5116   1% /run/lock
tmpfs                 474792        0     474792   0% /sys/fs/cgroup
/dev/mmcblk0p1         41853    21328      20525  51% /boot
/dev/mmcblk0p5      40050608  3466244   34520152  10% /home
/dev/mmcblk0p6       4969400   223568    4473684   5% /var/lib/mysql
/dev/mmcblk0p7      67895104 47159204   17243936  74% /usr/share/ampache/www/musique
tmpfs                  94956        0      94956   0% /run/user/1000
J'ai lancé une opération "retagage" des morceaux de musique à partir de la base de données d'ampache que j'avais nettoyée (scripts disponibles sur demande).
J'ai donc lancé l'opération sur mes 13000 morceaux. Plantage au bout de plusieurs heures : le raspberry ne répond plus. Si on a une console ouverte dessus, on a se type de réponse :

Code : Tout sélectionner

troumad@raspberrypi:~/sites/Troumad $ ll
-bash: /bin/ls: Aucun fichier ou dossier de ce type
Un appel par ssh, comme par http indique qu'il y a un serveur au bout, mais, il ne répond rien : pas de page web ou de connexion possible. Le PI fonctionne encore comme passerelle.

J'ai "splité" les 13000 lignes en paquet de 100 (l'instruction a été perdue dans les méandre du plantage : plus de trace dans l'historique). Voici une de mes 13000 lignes :

Code : Tout sélectionner

mid3v2 -a "Jacques Offenbach [1819-1880]" -A "Contes d\\\'Hoffmann cd2_2 [Gedda, Schwarzkopf, de los Angeles]" -t "Quatrième acte, Première scène / Entracte" -T 25/28 -g "Opera" -y 1965 "/usr/share/ampache/www/musique/classique/jacques_offenbach/les_contes_dhoffmann_cd22_gedda_schwarzkopf_de_los_angeles/25_quatrime_acte_premire_scne__entracte.ogg"
Et je les lance par paquet de 26 :

Code : Tout sélectionner

for fich in tag1.sql.d*
do
	echo "début $fich"
	date
	sh $fich 2>/dev/null
	rm -f $fich
	sleep 60
	echo "fin $fich"
done
Je rajoute un sleep pour que la carte SD ou le reste du PI se repose un peu et un date pour suivre un peu. Voici la fin du travail d'hier soir et le début de celui de ce matin :

Code : Tout sélectionner

vendredi 26 janvier 2018, 23:07:54 (UTC+0100)
fin tag1.sql.cx
début tag1.sql.cy
vendredi 26 janvier 2018, 23:14:54 (UTC+0100)
fin tag1.sql.cy
début tag1.sql.cz
vendredi 26 janvier 2018, 23:21:04 (UTC+0100)
fin tag1.sql.cz
root@raspberrypi:/home/troumad/sites/Troumad # vi tag1.sh
root@raspberrypi:/home/troumad/sites/Troumad # sh tag1.sh
début tag1.sql.da
samedi 27 janvier 2018, 07:17:27 (UTC+0100)
fin tag1.sql.da
début tag1.sql.db
samedi 27 janvier 2018, 07:25:50 (UTC+0100)
fin tag1.sql.db
début tag1.sql.dc
samedi 27 janvier 2018, 07:33:30 (UTC+0100)
fin tag1.sql.dc
début tag1.sql.dd
samedi 27 janvier 2018, 07:41:25 (UTC+0100)
fin tag1.sql.dd
début tag1.sql.de
samedi 27 janvier 2018, 07:49:35 (UTC+0100)
fin tag1.sql.de
début tag1.sql.df
samedi 27 janvier 2018, 07:56:28 (UTC+0100)
fin tag1.sql.df
début tag1.sql.dg
samedi 27 janvier 2018, 08:02:54 (UTC+0100)
tag1.sh: 6: tag1.sh: rm: not found
tag1.sh: 7: tag1.sh: sleep: not found
fin tag1.sql.dg
début tag1.sql.dh
Ce qui m'inquiète, c'est que le PI est rapidement tombé de matin et il vient de faire pareil cet après-midi ! En moins de 50 min de travail...
Est-ce normal ? Il a des radiateurs collés sur les deux composants de dessus et d'un point de vu ventilation, il est dans la boite officielle du PI.

Il a tourné un an sans problème avec un carte sd 32GO et une clef USB 64GO, un an avec une carte SD 64GO. Et là, le passage à une carte SD 128GO pose problème. La carte pourrait-elle être à l'origine des plantages ? Mais, je ne me souviens pas avoir déjà lancé d'aussi gros travail sur ce PI.
Joueur de jeux de rôles, chercheur en géocaches, utilisateur de Linux

Avatar du membre
troumad
Messages : 69
Enregistré le : sam. 13 févr. 2016 17:18

Re: Grosse carte SD et gros ralentissement et panne.

Message par troumad » mer. 21 févr. 2018 17:02

7 heures pour remplir 47 Go d'une carte dans le pi à la carte que je considère lente dans un adaptateur.
Joueur de jeux de rôles, chercheur en géocaches, utilisateur de Linux

Avatar du membre
troumad
Messages : 69
Enregistré le : sam. 13 févr. 2016 17:18

Re: Grosse carte SD et gros ralentissement et panne.

Message par troumad » mer. 21 févr. 2018 22:00

Dernières informations :

Il m'a fallut 2h20 pour faire le transfert de la micro SD à mon PC.
Autre test, le travail de tag qui prenait 6 min pour 100 lignes avec cette carte en a pris 1h20 avec la carte 64Go en 11000 ligne (80/110*60=44 secondes pour 100 lignes), donc 8 fois plus vite avec la carte 64 bits. Ceci dit, il y a des différences :
- La carte 64Go a une debian 8, le logiciel pour modifier les tags est eye3D
- La carte 128Go a une debian 9, le logiciel pour modifier les tag est mid3v2.
Joueur de jeux de rôles, chercheur en géocaches, utilisateur de Linux

Répondre

Retourner vers « En panne ? »