Problème fonctionnement camera pi

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
benjamin
Messages : 1
Enregistré le : dim. 8 avr. 2018 15:15

Problème fonctionnement camera pi

Message par benjamin » dim. 8 avr. 2018 15:37

Bonjour à tous,

Il y a quelques semaines j'ai acheté une camera pi pour un projet perso.
Pour me familiariser avec mon nouveau jouet, je découvre les lignes de commande à base de raspistill et jusque là tout va bien.

Sauf que du jour au lendemain, lorsque je saisie une simple commande du type "raspstill -t 2000" j'obtiens l'erreur suivante:

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Et là je bloque complètement.
J'ai testé avec une autre caméra, une autre raspberry, une réinstallation de Raspbian, les apt-get update/upgrade, rpi-update, rien à faire.
J'ai même testé la continuité électrique entre le PCB de la caméra et le connecteur sur la raspberry.

J'ai tenté de trouver une solution sur des forums, mais les solutions qui ont pu permettre à certains de refaire fonctionner leur caméra ne fonctionnent pas avec moi...
Ou alors je suis passé à côté de quelque chose...

Si quelqu'un a des idées / conseils, je suis preneur!

D'avance merci

Pour info, si ça peut aider:
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.14.32-v7+ #1107 SMP Fri Apr 6 16:36:46 BST 2018 armv7l GNU/Linux

pi@raspberrypi:~ $ raspistill -v
raspistill Camera App v1.3.11

pi@raspberrypi:~ $ sudo vcgencmd get_camera
supported=1 detected=1

Répondre

Retourner vers « En panne ? »