Mes Raspberry ne sont pas à la bonne date

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
BrunoGee
Messages : 14
Enregistré le : jeu. 15 sept. 2016 12:33

Mes Raspberry ne sont pas à la bonne date

Message par BrunoGee » lun. 4 juin 2018 04:29

Bonjour,
Je viens d'installer la dernière version de Raspbian, c'est à dire Raspbian Stretch with desktop dont la date de realease est le 18 avril 2018 sur la page https://www.raspberrypi.org/downloads/raspbian/

Je l'ai installé sur 2 framboises et lorsque je fait une recherche sur duckduckgo (moteur par défaut) ou google via une connexion https, j'obtiens le message suivant :
Votre horloge est en retard
Impossible d'établir une connexion privée à duckduckgo.com : la date et l'heure de votre ordinateur (mercredi 18 avril 2018 à 16:05:02 sont incorrectes
NET;;ERR_CERT_DATE_INVALID
Ma connexion internet fonctionne pourtant, puisque j'ai accès à http://www.meteo.nc . Bon, ok, c'est pas le site qui vous intéresse ;-)

J'ai parcouru pas mal de pages et j'ai cru comprendre que :
- ntpd est super obsolète
- ntpdate est obsolète
- et que maintenant, c'est timedatectl

Donc, je fait :

Code : Tout sélectionner

sudo vim /etc/systemd/timesyncd.conf
Je dé-commente les lignes :

Code : Tout sélectionner

[Time]
NTP=
FallbackNTP=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
Je fait :

Code : Tout sélectionner

timedatectl set-ntp true
je test

Code : Tout sélectionner

timedatectl 
Et ça marche pas :

Code : Tout sélectionner

pi@raspberrypi:~ $ timedatectl
      Local time: ven. 2018-04-20 10:55:32 +11
  Universal time: jeu. 2018-04-19 23:55:32 UTC
        RTC time: n/a
       Time zone: Pacific/Noumea (+11, +1100)
 Network time on: yes
NTP synchronized: no
 RTC in local TZ: no


Une idée ?
Comment ça se fait que je sois presque le seul à avoir ce problème ?

Merci pour votre aide...
Modifié en dernier par BrunoGee le lun. 4 juin 2018 08:51, modifié 2 fois.

dyox
Raspinaute
Messages : 456
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Mes Raspberry ne sont pas à la bonne date

Message par dyox » lun. 4 juin 2018 08:22

Bonjour,

Pourquoi faites-vous la corrélation entre le manque d'internet et la date ? Je dirai que vous faites fausse route.
Car si on vous suit, personne n'aurait internet lors de sa 1ère connexion.

Donc regardez du côté de votre configuration réseau.
Débutant sous RPi / linux
[Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

BrunoGee
Messages : 14
Enregistré le : jeu. 15 sept. 2016 12:33

Re: Mes Raspberry ne sont pas à la bonne date

Message par BrunoGee » lun. 4 juin 2018 08:47

Bonjour,
Merci pour votre réponse.
Effectivement, je me suis mal exprimé :
Lorsque je fait une recherche sur duckduckgo (moteur par défaut) ou google via une connexion https, j'obtiens le message suivant :
Votre horloge est en retard
Impossible d'établir une connexion privée à duckduckgo.com : la date et l'heure de votre ordinateur (mercredi 18 avril 2018 à 16:05:02 sont incorrectes
NET;;ERR_CERT_DATE_INVALID
Je modifie mon premier post pour clarifier la situation ;-)

dyox
Raspinaute
Messages : 456
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Mes Raspberry ne sont pas à la bonne date

Message par dyox » lun. 4 juin 2018 09:08

Essayez un stop start sur ntp et la commande sudo ntpq -p
Débutant sous RPi / linux
[Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Avatar du membre
zeb
Raspinaute
Messages : 280
Enregistré le : ven. 19 sept. 2014 11:04

Re: Mes Raspberry ne sont pas à la bonne date

Message par zeb » lun. 4 juin 2018 16:46

Plop,
BrunoGee a écrit :
lun. 4 juin 2018 04:29
J'ai parcouru pas mal de pages et j'ai cru comprendre que :
- ntpd est super obsolète ancien
- ntpdate est obsolète ancien
- et que maintenant, c'est timedatectl est récent
Bon, les jeunes ont toujours tendance à pousser les vieux dans les orties !
Mais ntpd fonctionne très bien ;)

Suis donc le conseil de Dyox, puis vérifie que tu es à la bonne heure !
Si tu es à l'heure, DuckDuck devrait fonctionner. :)
Si tu n'es pas à l'heure, il y a un problème réseau qu'il convient de résoudre avant d'incriminer DuckDuck :(
Dans ce dernier cas, on peut enquêter ensemble ;)
Dans mon panier : rpi1A+ : »:: »:: | rpi1B : »:: »:: | rpi1B+ : »:: »:: | rpi2B : »:: »:: | rpi3B : »:: »:: | rpi0 : »::

BrunoGee
Messages : 14
Enregistré le : jeu. 15 sept. 2016 12:33

Re: Mes Raspberry ne sont pas à la bonne date

Message par BrunoGee » lun. 4 juin 2018 23:34

Bonsoir,
Bon, les jeunes ont toujours tendance à pousser les vieux dans les orties !
Mais ntpd fonctionne très bien ;)
Merci pour le "Jeune" ;-)
ntpd et ntpdate ne sont pas installés par défaut...

Puisque maintenant, c'est timedatectl
J'ai tenté
timedatectl set-time '2018:06:05 07:57:00'
Failed to parse time specification
J'ai trouvé une réponse qui ne me convient pas parfaitement, puisque je synchronise pas avec un serveur ntp :
sudo date -s "5 JUN 2018 07:46:00"
Et là, la date est mise à jour

Par ailleur, j'ai trouvé un tuto surConfigurer le client NTP sous Jessie avec Systemd
J'ai modifié /etc/systemd/timesyncd.conf
puis

Code : Tout sélectionner

 sudo systemctl start systemd-timesyncd.service; sudo systemctl enable systemd-timesyncd.service
Mais
pi@raspberrypi:~ $ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
└─disable-with-time-daemon.conf
Active: active (running) since Mon 2018-06-04 21:24:41 +11; 11h ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 287 (systemd-timesyn)
Status: "Idle."
CGroup: /system.slice/systemd-timesyncd.service
└─287 /lib/systemd/systemd-timesyncd

juin 05 08:26:13 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 115.126.160.4:123 (0.deb
juin 05 08:26:24 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 202.22.158.31:123 (1.deb
juin 05 08:26:34 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 202.22.158.30:123 (1.deb
juin 05 08:26:44 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 115.126.160.4:123 (1.deb
juin 05 08:26:54 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 202.22.158.30:123 (2.deb
juin 05 08:27:05 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 202.22.158.31:123 (2.deb
juin 05 08:27:15 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 115.126.160.4:123 (2.deb
juin 05 08:27:25 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 202.22.158.30:123 (3.deb
juin 05 08:27:35 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 202.22.158.31:123 (3.deb
juin 05 08:27:46 raspberrypi systemd-timesyncd[287]: Timed out waiting for reply from 115.126.160.4:123 (3.deb
pi@raspberrypi:~ $

Avatar du membre
zeb
Raspinaute
Messages : 280
Enregistré le : ven. 19 sept. 2014 11:04

Re: Mes Raspberry ne sont pas à la bonne date

Message par zeb » mar. 5 juin 2018 16:52

Dou iou spique angliche ? : https://www.raspberrypi.org/forums/view ... p?t=178763

---------------

Je t'aurais bien demandé le contenu de /etc/systemd/timesyncd.conf, mais à lire le log du systemctl status, ça semble correct.
Mais je n'aime pas le contenu de ce log.

Ptite question quand même : le réseau est-il déjà "up" quand systemd lance timesyncd ?
Dans mon panier : rpi1A+ : »:: »:: | rpi1B : »:: »:: | rpi1B+ : »:: »:: | rpi2B : »:: »:: | rpi3B : »:: »:: | rpi0 : »::

mike913
Raspinaute
Messages : 109
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Mes Raspberry ne sont pas à la bonne date

Message par mike913 » mer. 6 juin 2018 10:39

Bonjour,

Suite au post de BrunoGee j' ai voulu en savoir plus sur systemd-timesyncd.
j' ai donc lancé la ommande: systemctl status systemd-timesyncd
[22:58:10] michel@RASPI-11:~$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendo
Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
└─disable-with-time-daemon.conf
Active: inactive (dead)
Condition: start condition failed at Tue 2018-06-05 13:51:28 CEST; 9h ago
Docs: man:systemd-timesyncd.service(8)
lines 1-7/7 (END)
le lien dans le post de zeb précise qu'il faut désinstaller ntpd, ce que j' ai fait te j'en ai profité pour mettre à jour mon systéme
sudo systemctl stop ntp
sudo systemctl disable ntp
sudo apt-get -y remove ntp
sudo rm -f /etc/init.d/ntp
sudo rm -f /etc/default/ntp
sudo rm -f /etc/rc?.d/{S,K}??ntp
sudo rm -f /etc/ntp.conf
sudo rm -f /etc/cron.daily/ntp
sudo rm -f /var/log/ntpstats
sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y dist-upgrade
sudo rpi-update
sudo reboot
j' ai donc relancé la commande: systemctl status systemd-timesyncd
[23:23:13] michel@RASPI-11:~$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
└─disable-with-time-daemon.conf
Active: active (running) since Tue 2018-06-05 23:19:54 CEST; 3min 22s ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 267 (systemd-timesyn)
Status: "Synchronized to time server 195.85.215.215:123 (2.debian.pool.ntp.org)."
CGroup: /system.slice/systemd-timesyncd.service
└─267 /lib/systemd/systemd-timesyncd
le rpi c'est bien resynchronisé.
j' ai donc modifié le fichier “/etc/systemd/timesyncd.conf” comme suit:
[Time]
NTP=mafreebox.free.fr
FallbackNTP=ntp2.jussieu.fr 0.fr.pool.ntp.org
redémarrage de timesyncd:
sudo systemctl restart systemd-timesyncd et:
[23:32:42] michel@RASPI-11:~$ systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
└─disable-with-time-daemon.conf
Active: active (running) since Tue 2018-06-05 23:31:04 CEST; 1min 46s ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 1204 (systemd-timesyn)
Status: "Synchronized to time server 212.27.38.253:123 (mafreebox.free.fr)."
CGroup: /system.slice/systemd-timesyncd.service
└─1204 /lib/systemd/systemd-timesyncd
Donc le rpi c'est bien synchronisé sur ma freebox

Je pense donc que BrunoGee a un problème de réseau ou les serveurs utilisés sont down
Cordialement
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Répondre

Retourner vers « En panne ? »