Problème lecture téléinformation Raspberry

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Torseur 06
Messages : 24
Enregistré le : dim. 28 janv. 2018 14:19

Problème lecture téléinformation Raspberry

Message par Torseur 06 » ven. 1 févr. 2019 10:25

Bonjour à tous,

je suis novice et j''ai un RASPBERRY PI 3 Model B, qui fonctionne sous Raspbian GNU/Linux 9.3 (Stretch) connecté à mes bornes téléinfo de mon compteur EDF.
J'ai un autre Raspberry que j'utilise comme "Serveur" branché sur ma box sur lequel Domoticz est installé et où je récupère un certain nombre d'info dont ces données téléinfo EDF.
Tout fonctionne bien sur mon "Serveur" les données de téléinfo sont bien remontées.

En revanche sur mon Rasp branché direct en téléinfo j'avais mis en place un lien PHP, accessible depuis l'extérieur, pour suivre ma consommation électrique (grâce à http://www.magdiblog.fr/gpio/teleinfo-e ... lectrique/)
Cela fonctionne depuis plus d'un an mais la semaine dernière suite à de nombreuses coupures électriques chez moi, le lien php ne fonctionne plus.
Le lien affiche une série de points d'interrogations dans un lozange noir ( � ) puis le reste de la page correspond au codage HTML du lien php appelé.
En vérifiant dans mon Rasp le fichier appelé pour pouvoir lire et affiché les consommations d'appelle teleinfo.sqlite lorsque je l'affiche avec DB BROWSER les tableaux de PUISSANCE sont vides et les tableaux de CONSO s'arrêtent jusqu'au Timestamp du 25 Janv 2019.

Je ne sais pas s'il y a un moyen de savoir pourquoi le teleinfo.sqlite ne se met pas à jour et au pire de pouvoir remettre une ancienne sauvegarde de mon raspberry (qui date de Novembre 2018) sans pour autant perdre mes consommations de Novembre Décembre.
Je ne sais pas s'il est possible de faire resusciter mon teleinfo.sqlite ?

Désolé pour mon expression pas très puriste mais je parle avec mes mots ne maitrisant pas toutes les subtilités du raspberry et linux.

Merci à vous de votre aide !

domi
Administrateur
Messages : 2589
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Problème lecture téléinformation Raspberry

Message par domi » ven. 1 févr. 2019 11:23

Bonjour,

Dans un premier temps il faut déjà vérifier si les fichiers incriminés n'ont pas subit de défaillance suite aux coupures de courant alors qu'ils étaient peut-être ouverts ?
Cas assez courant d'un fichier HS lorsqu'il est ouvert et qu'il y a une coupure de courant.

Torseur 06
Messages : 24
Enregistré le : dim. 28 janv. 2018 14:19

Re: Problème lecture téléinformation Raspberry

Message par Torseur 06 » ven. 1 févr. 2019 12:00

Merci domi de votre réponse.

Pouvez vous m'expliquer la démarche afin de savoir si les fichiers incriminés ont subi une défaillance ? Dois-je les tester avec un logiciel particulier ?
Le fichier que je pense est susceptible d'être défaillant est le teleinfo.sqlite mais je ne sais pas comment faire pour savoir s'il est défaillant.

Merci à vous !

Torseur 06
Messages : 24
Enregistré le : dim. 28 janv. 2018 14:19

Re: Problème lecture téléinformation Raspberry

Message par Torseur 06 » sam. 2 févr. 2019 10:21

J'ai finalement résolu mon problème. Le problème venait effectivement de mon fichier teleinfo.sqlite qui était corrompu car seules les tables "Conso" étaient remplies mais les tables "Puissance" étaient vides.
Il a fallu que je face un reset de ma carte SD sur une ancienne sauvegarde RASPBIAN et que je recréé un fichier teleinfo.sqlite avec des anciennes sauvegardes pour qu'il soit lu correctement en ayant quelques pertes au feu de quelques jours de consommation non comptabilisés.
Merci de votre aide en tout cas.

Répondre

Retourner vers « En panne ? »