[Projet] WsPiDroid, un web service pour le Raspberry Pi

Vous souhaitez piloter votre framboise à partir d'une page web ? Ou mieux encore à partir d'un smartphone ou d'une tablette Android ? Venez donc visiter cette rubrique...

Modérateur : Francois

rasduino
Messages : 30
Enregistré le : ven. 10 oct. 2014 07:57

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par rasduino » lun. 12 janv. 2015 15:20

merci pour le retour.
En fait, je travaille sur ce projet en alternance avec d'autres mais j'ai quand même hâte de commander les leds depuis mon smartphone.
La balle est dans mon camp...
;o)

rasduino
Messages : 30
Enregistré le : ven. 10 oct. 2014 07:57

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par rasduino » mar. 20 janv. 2015 17:53

Bonsoir

1) Comme je l’indiquais précédemment, un client http communique correctement avec le serveur RpiDroid sur mon réseau local.
Un client http externe arrive bien sur le message « Rien à voir » (index.php)
Par contre led.php, activé sur ce même client http extérieur, bute sur le message « Pas de retour, soit il n'existe aucun Pin configuré dans le WebService, soit le WebService ne répond pas ».
pourtant le même serveur répond bien à une requete en local… je peux allumer et éteindre des leds
Je soupçonne le pare-feu de ma box.

Question : faut-il ouvrir un port particulier ?

2) Coté apk, c'est la kata: à l'installation il me jette "Erreur d’analyse. Un probleme est survenu lors de l’analyse du kit".
(Htc explorer a310e
Android 2.3.5)
bien entendu, j'ai autorisé l'installation d'applications de sources inconnues.

Une idée?
Merci d'avance.

domi
Administrateur
Messages : 2616
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par domi » mar. 20 janv. 2015 19:48

Bonsoir,

Pour la requête http, l'adresse du web-service via Internet est t'elle bien renseignée dans la page du client ?
Pas de port particulier car c'est le 80 qui est utilisé (port http)
Il faut par contre une redirection du routeur vers la machine du réseau local. Mais si vous accédez à la page index via internet, c'est que le routage est correct.

Pour l'application Android, celle-ci utilisant l'action bar, il faut un terminal avec au minimum une version 3.0 d'Android.

Cordialement,
Domi

rasduino
Messages : 30
Enregistré le : ven. 10 oct. 2014 07:57

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par rasduino » jeu. 22 janv. 2015 12:17

Bonjour,

Toujours pas possible de bouger les leds depuis un client http "extérieur" alors que ça marche sur le réseau interne.
j'ai vérifié 12 fois l'url cible dans led.php... La clé est la même, bien entendu...
Bien entendu aussi, le dossier lib est bien présent dans le répertoire ad hoc.
pourtant, j'accède bien, via cette même url, à index.php sur le Pi.

je constate aussi qu'il n'y a pas de trace de l'accès "par l'extérieur" dans les logs alors que ça trace correctement lorsque je me connecte via le réseau interne.

je fais une redirection de port entrant pour des raisons de sécurité. Je ne pense pas que ce soit la cause car ça ne va pas mieux lorsque je la supprime. ou que je la remplace par 80 => 80...

je suis sec !

une idée?

merci d'avance

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par vague nerd » jeu. 22 janv. 2015 15:16

Bonjour.

Pour ma part, j'ai du désactiver la vérification de la clé secrète... pourtant 'correcte'.

Cdt.
Cordialement,

Vague Nerd

rasduino
Messages : 30
Enregistré le : ven. 10 oct. 2014 07:57

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par rasduino » jeu. 22 janv. 2015 15:58

merci pour l'info.

pourtant, la vérification de la clé secrète fonctionne bien chez moi avec un client http "local".
c'est avec un client http "externe" que j'ai le problème.
je vais faire comme vous, pour voir...

cordialement

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par vague nerd » jeu. 22 janv. 2015 16:37

Oui, j'ai eu le même symptôme. Impossible de comprendre pourquoi.
J'ai même demandé à une autre pair d'yeux de vérifier la clé !
Cordialement,

Vague Nerd

rasduino
Messages : 30
Enregistré le : ven. 10 oct. 2014 07:57

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par rasduino » jeu. 22 janv. 2015 17:22

j'ai mis une clé vide pour commencer: même résultat...
le contrôle est dans la partie obfusquée, non?

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par vague nerd » ven. 23 janv. 2015 18:46

Bonsoir.
Le mieux est d'attendre le retour de domi...
Cdt.
Cordialement,

Vague Nerd

rasduino
Messages : 30
Enregistré le : ven. 10 oct. 2014 07:57

Re: [Projet] RpiDroid, un web service pour le Raspberry Pi

Message par rasduino » sam. 24 janv. 2015 07:13

Ok, merci
j'ai remplacé lighttpd par apache2. même résultat.

Répondre

Retourner vers « Des interfaces pour le Raspberry Pi »