Problème clé 3G Huawei E220 [RESOLU]

Piloter son installation depuis son smartphone, envoyer ou recevoir des SMS d'alerte... C'est ici !

Modérateur : Francois

Répondre
rebeldu31
Raspinaute
Messages : 243
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Problème clé 3G Huawei E220 [RESOLU]

Message par rebeldu31 » dim. 4 févr. 2018 01:03

Bonsoir,

Cela faisait un moment que je n'avais pas rencontré de problème sur 1 de mes framboises !!!
Ça me manquait.... pas du tout !!!
:?

Voilà mon problème...
J'ai donc une clé 3G Huawei E220, avec une carte SIM Freemobile.
Jusqu'à il y a quelques jours, elle fonctionnait à merveille, recevant et envoyant des SMS...Bref elle faisait son job !!!
Puis, du jour au lendemain, sans aucune action, modification ou autres mises à jour, v'la t'y pas qu'elle décide de faire des siennes !!!
Elle ne reçoit plus rien, n'envoie plus rien, clignote sans cesse...
Puis, hier, elle s'est remise à fonctionner, sans rien faire (à part X reboot)... Puis, hop, madame a plus envie, elle ne (re)fonctionne plus !!!
Un pur bonheur !!!

Voilà les messages incessant que j'ai dans ma syslog :

kernel: [ 639.117381] usb 1-1.5: USB disconnect, device number 13
kernel: [ 639.118125] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
kernel: [ 639.118162] option 1-1.5:1.0: device disconnected
kernel: [ 639.118694] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
kernel: [ 639.118749] option 1-1.5:1.1: device disconnected
kernel: [ 656.305143] usb 1-1.5: new full-speed USB device number 14 using dwc_otg
kernel: [ 656.438733] usb 1-1.5: New USB device found, idVendor=12d1, idProduct=1003
kernel: [ 656.438745] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
kernel: [ 656.438753] usb 1-1.5: Product: HUAWEI Mobile
kernel: [ 656.438761] usb 1-1.5: Manufacturer: HUAWEI Technologies
kernel: [ 656.443662] usb-storage 1-1.5:1.0: USB Mass Storage device detected
kernel: [ 656.444160] option 1-1.5:1.0: GSM modem (1-port) converter detected
kernel: [ 656.444557] usb 1-1.5: GSM modem (1-port) converter now attached to ttyUSB0
kernel: [ 656.446240] usb-storage 1-1.5:1.1: USB Mass Storage device detected
kernel: [ 656.447255] option 1-1.5:1.1: GSM modem (1-port) converter detected
kernel: [ 656.447694] usb 1-1.5: GSM modem (1-port) converter now attached to ttyUSB1
kernel: [ 656.448187] usb-storage 1-1.5:1.2: USB Mass Storage device detected
kernel: [ 656.448917] scsi host1: usb-storage 1-1.5:1.2
kernel: [ 765.305150] option1 ttyUSB0: usb_wwan_indat_callback: resubmit read urb failed. (-2)


Un coup attachant ma clé sur ttyUSB0 + ttyUSB1, un coup sur ttyUSB1 + ttyUSB2.

Et ces messages sont en boucle !!!

Un "dmesg | grep usb" me donne ceci :

[ 1279.923938] usb 1-1.5: new full-speed USB device number 23 using dwc_otg
[ 1280.056358] usb 1-1.5: New USB device found, idVendor=12d1, idProduct=1003
[ 1280.056370] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1280.056379] usb 1-1.5: Product: HUAWEI Mobile
[ 1280.056387] usb 1-1.5: Manufacturer: HUAWEI Technologies
[ 1280.060697] usb-storage 1-1.5:1.0: USB Mass Storage device detected
[ 1280.061599] usb 1-1.5: GSM modem (1-port) converter now attached to ttyUSB0
[ 1280.062608] usb-storage 1-1.5:1.1: USB Mass Storage device detected
[ 1280.063368] usb 1-1.5: GSM modem (1-port) converter now attached to ttyUSB1
[ 1280.063822] usb-storage 1-1.5:1.2: USB Mass Storage device detected
[ 1280.065313] scsi host1: usb-storage 1-1.5:1.2
[ 1302.363880] usb 1-1.5: reset full-speed USB device number 23 using dwc_otg
[ 1302.498857] usb-storage 1-1.5:1.0: USB Mass Storage device detected
[ 1302.499752] usb 1-1.5: GSM modem (1-port) converter now attached to ttyUSB0
[ 1302.499856] usb-storage 1-1.5:1.1: USB Mass Storage device detected
[ 1302.500714] usb 1-1.5: GSM modem (1-port) converter now attached to ttyUSB1
[ 1318.797377] usb 1-1.5: USB disconnect, device number 23


Un coup 0+1, un coup 1+2 et le "device number" qui s'incrémente au fur et à mesure... Sans cesse !!!

Avec de temps en temps un "[ 1443.063832] option1 ttyUSB0: usb_wwan_indat_callback: resubmit read urb failed. (-2)" qui apparait !!!

J'ai bien défini un device spécifique pour ma clé, à savoir ttyHUAWEIxx. Voici mon udev rule :

SUBSYSTEM=="tty", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1003", SYMLINK+="ttyHUAWEI%E{ID_USB_INTERFACE_NUM}"
SUBSYSTEM=="tty", ATTRS{idVendor}=="0424", ATTRS{idProduct}=="9514", SYMLINK+="ttyFTDI%s{devpath}"


Lorsque je regarde si mes devices existent, je les vois bien (0+1 ou 1+2)... quand ils sont "connectés" :

ls -al /dev/ttyH*

lrwxrwxrwx 1 root root 7 févr. 4 00:46 /dev/ttyHUAWEI00 -> ttyUSB1
lrwxrwxrwx 1 root root 7 févr. 4 00:46 /dev/ttyHUAWEI01 -> ttyUSB2


Quand les 2 devices sont "visibles", un "gammu identify" me done :

Périphérique : /dev/ttyUSB0
Fabricant : Huawei
Modèle : E220 (E220)
Firmware : 11.110.05.00.00
IMEI : XXXXXXXXXXXXXXX


usb-modeswitch et usb-modeswitch-data sont installés mais j'ai lu un peu partout que cette clé n'en avait pas besoin. J'ai testé en les désinstallant, ça n'a rien changé !!!

Je n'ai pas touché à la config de usb-modeswitch.

Je ne sais vraiment plus dans quelle direction chercher...
:shock: :o
:?
Modifié en dernier par rebeldu31 le mer. 13 juin 2018 08:02, modifié 1 fois.
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : firewall (en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

jelopo
Messages : 95
Enregistré le : mer. 11 oct. 2017 10:23

Re: Problème clé 3G Huawei E220

Message par jelopo » dim. 4 févr. 2018 09:53

Bonjour,
Si rien, mais vraiment rien n'a changé dans la config, elle serait tout simplement pas en train de tomber en panne ?
A+

rebeldu31
Raspinaute
Messages : 243
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Problème clé 3G Huawei E220

Message par rebeldu31 » dim. 4 févr. 2018 10:07

C'est la question que je me pose en effet !!
Mais, comme ça, du jour au lendemain, sans choc ou autre ??
:shock:
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : firewall (en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

Re: Problème clé 3G Huawei E220

Message par Korhm » ven. 9 févr. 2018 15:05

Bonjour,

j'ai eu le même problème, voir : viewtopic.php?f=30&t=1747
C'est "tombé en panne" d'un coup : la clé n'arrêtait pas de se redémarrer.
La solution : trouver un autre modèle.

rebeldu31
Raspinaute
Messages : 243
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Problème clé 3G Huawei E220

Message par rebeldu31 » ven. 9 févr. 2018 17:47

Bon, ben je m'en vais en chercher une autre, compatible avec gammu et le raspberry...
:?
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : firewall (en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

joon
Messages : 5
Enregistré le : mer. 13 juin 2018 01:28

Re: Problème clé 3G Huawei E220

Message par joon » mer. 13 juin 2018 02:13

J'ai lu beaucoup de choses à ce sujet, mais rien ne semble correspondre exactement à ton problème :!:
Modifié en dernier par joon le mer. 13 juin 2018 20:11, modifié 2 fois.

rebeldu31
Raspinaute
Messages : 243
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Problème clé 3G Huawei E220

Message par rebeldu31 » mer. 13 juin 2018 08:02

Nouvelle clé Huawei E220 achetée, tout refonctionne...
C'était donc bien la clé qui a rendu l'âme...
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : firewall (en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

Répondre

Retourner vers « Téléphonie et télécommunication »