probleme "Cannot Resolve Hostname"

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: probleme "Cannot Resolve Hostname"

Message par guillaume9344 » lun. 21 déc. 2015 18:30

Et pour ceux qui sont fan des interfaces graphique , j 'utilise tightvncserver:
http://www.framboise314.fr/prenez-la-ma ... -avec-vnc/

entre le ssh et tightvncserver c'est 100% de mon utilisation du pi . j'utilise seulement un écran lors de réinstallation via noobs (mais je préfere maintenant passer par des images toutes faites).
@+
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

dragonfly281
Messages : 8
Enregistré le : sam. 19 déc. 2015 15:23

Re: probleme "Cannot Resolve Hostname"

Message par dragonfly281 » lun. 21 déc. 2015 19:27

Salut à tous, voici les réponses aux questions :

$ ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
link/ether b8:27:eb:b2:80:14 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether 74:da:38:3a:42:34 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.8/24 brd 192.168.1.255 scope global wlan0
valid_lft forever preferred_lft forever

pi@ludo ~ $ ip route list
192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.8 metric 303

pi@ludo ~ $ cat /etc/resolv.conf
# Generated by resolvconf

pi@ludo ~ $ cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

pi@ludo ~ $ route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0

Merci Guillaume je vais lire ce lien là de suite ;)

maxty01
Modérateur
Messages : 749
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: probleme "Cannot Resolve Hostname"

Message par maxty01 » lun. 21 déc. 2015 23:40

Bonsoir,

Avec les infos que j'ai, il semblerai que le serveur DHCP ne fournis pas de passerelle par défaut.
Autre point, je ne vois pas les serveur DNS.

Il y a clairement un p'tit soucis avec le serveur DHCP.

Il faudrait essayé avec un câbles réseau.

Voici comment opérer :
tu vas utiliser le câbles qui relie le modem au décodeur Belgacom TV,
mais pas n'importe comment, il faut également changer ce câble du coté du modem pour ne pas être sur un port "TV".
Quand cela est fait, refait les même commandes que les précédentes.

Avec cela je souhaites déterminer si on a bien situé le problème.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

domi
Administrateur
Messages : 2870
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: probleme "Cannot Resolve Hostname"

Message par domi » mar. 22 déc. 2015 07:53

Bonjour,

Pour Maxty : tu ne penses pas que l'on devrait modifier le /etc/network/interfaces

Dans la section :

Code : Tout sélectionner

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
Je serai d'avis de remplacer par

Code : Tout sélectionner

auto wlan0
# allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
Ensuite il faut adapter le wpa_supplicant.conf selon le type de clé Wifi en ajoutant SSID et PWD.

Maintenant, c'est juste une piste de recherche. Ne connaissant pas vos Box, je préfère ne pas dérouter "dragonfly281" dans des flux d'informations techniques. Je préfère donner mes idées de recherche à Maxty01, qui guidera "dragonfly281".

Cdt
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

dragonfly281
Messages : 8
Enregistré le : sam. 19 déc. 2015 15:23

Re: probleme "Cannot Resolve Hostname"

Message par dragonfly281 » mar. 22 déc. 2015 18:49

Bonsoir. Alors vu que je ne comprend pas les consignes, et que mon pere est pas super chaud à modifier l'installation sans comprendre voici ce que j'ai, ca sera + simple :)

les images sont ceux de du modem Sagem. ( les ports TV sont deja libre )
https://scontent-bru2-1.xx.fbcdn.net/hp ... e=567B6576

l'autre face :

https://scontent-bru2-1.xx.fbcdn.net/hp ... e=567B3639

au niveau de mon décodeur (Voo corder) c'est exactement comme ca : https://scontent-bru2-1.xx.fbcdn.net/hp ... e=567B7206

il n'y a donc pas de lien direct entre le modem et le décodeur ( à par 1 étage :p )

De ce que je comprend, je devais dire au serveur DHCP qu'il peux aller chercher des IP sur une plus large plage ?
Sinon je peu directement utiliser le câble lan sur le rasp, et refaire les manip ?
ps : mon nom est Ludo, c'est + simple que dragonfly281 ;)

maxty01
Modérateur
Messages : 749
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: probleme "Cannot Resolve Hostname"

Message par maxty01 » mar. 22 déc. 2015 21:58

Bonsoir,

Ok, donc je résume pour savoir si j'ai bien compris.

Tu as internet avec Belgacom/Proximus et tu regarde la télévision avec voo et son voocorder ?

Bon, alors, le but est effectivement de connecter ton RPI sur internet directement sur le modem belgacom.

Si tu peux le faire, et effectuer les commandes que nous t'avons déjà donné.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

dragonfly281
Messages : 8
Enregistré le : sam. 19 déc. 2015 15:23

Re: probleme "Cannot Resolve Hostname"

Message par dragonfly281 » jeu. 24 déc. 2015 11:16

voici ce que j'ai avec le pi directement connecté avec le câble.

ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether b8:27:eb:b2:80:14 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.8/24 brd 192.168.1.255 scope global eth0
valid_lft forever preferred_lft forever

ip route list

192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.8 metric 202


cat /etc/resolv.conf
# Generated by resolvconf


cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

maxty01
Modérateur
Messages : 749
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: probleme "Cannot Resolve Hostname"

Message par maxty01 » jeu. 24 déc. 2015 17:22

Bonsoir,

Je relève Deux points qui m’inquiète un peu ...

Le premier c'est que l'adresse IP de ETH0 est la même que WLAN0 ...

Cette info peux dire plusieurs choses :

La première, le DHCP est configuré pour fournir cette adresse à l'adresse MAC associé, et que tu a changé cette adresse mac dans la configuration du DHCP.
La seconde, un serveur DHCP autre que celui configuré sur le modem est en fonction sur le réseau et que la majorité des configuration ne sont pas effectuée.
La troisième, l'adresses IP n'est pas fournie par le DHCP, cette dernière est mise manuellement sur ETH0 et WLAN0.

En fait, je pencherai pour la troisième option car si un DHCP est configuré, aucun problème réseau ne serai visible car certaines options ne sont pas configurables (DNS, GATEWAY, ...).
Cela expliquerai également le manque de configuration pour que le RPI puisse accéder au WEB, car si la configuration réseau est manuel, il est facile d'oublier certains paramètres, comme c'est le cas actuellement.

Le second point, je pense que cela n'a rien à voir avec notre problème, concerne la configuration de 2 cartes WLAN ... Est-ce normale ?

Avant d'aller plus loin, je souhaiterai que tu réponde à ce message.
Je souhaiterai également savoir comment connectes-tu ton RPI au réseau, et pas uniquement au niveau câblage, mais également toutes les opérations/configurations que tu effectues (sans doute via une interface graphique).
Mieux, si tu utilises un "mode d'emploi" ou un tuto, il serait intéressant de nous le transmettre, pour qu'on y apporte, aux besoins, quelques corrections.

Bonne soirée,
Joyeux noël à tous,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

dragonfly281
Messages : 8
Enregistré le : sam. 19 déc. 2015 15:23

Re: probleme "Cannot Resolve Hostname"

Message par dragonfly281 » lun. 28 déc. 2015 21:36

Bonsoir,

Comme j'ai dis plutôt, je n'ai effectuer aucun changements ou modifications ou paramètre sur le réseau.
Demain je chercherai comment y accéder pour vérifier de mon coté.

2 cartes WLAN ? aucune idée. Est-ce un problème ?
Comme on y jamais eu de problèmes pour connecter d'autre appareils (smartphone, tablette, pc ) au wi-fi, personne ne s'est jamais posé la question...

Pour connecter mon pi au réseau : un dongle WIFI Edimax, l’interface graphique c'est raspbian, et de là, aucune ligne de code, juste rentré le mot de passe du wi-fi.

typiquement comme ca : https://www.youtube.com/watch?v=7cQrNl0QVFA

dragonfly281
Messages : 8
Enregistré le : sam. 19 déc. 2015 15:23

Re: probleme "Cannot Resolve Hostname"

Message par dragonfly281 » mar. 5 janv. 2016 14:20

un petit up :)

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »