moteur et gpio

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Répondre
Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

moteur et gpio

Message par Nanard » mar. 17 janv. 2017 18:28

Bonjour,

Je me posais la question est-ce qu'il est possible de brancher un moteur sur le raspberry et de le contrôler avec un programme ? (Je me doute bien que oui !)

Actuellement j'ai reussi a l'alimenter en direct sur du 3V et la masse.

Ma question étant : Est-ce que si j'alimente le gpio3 (exemple) et le reste brancher à la masse, le moteur peut démarrer durant 10sec puis s'éteindre ?

Alexidreaming
Raspinaute
Messages : 211
Enregistré le : mar. 16 août 2016 20:55
Contact :

Re: moteur et gpio

Message par Alexidreaming » mar. 17 janv. 2017 19:05

Salut,
je ne comprends pas quand tu dis:
Ma question étant : Est-ce que si j'alimente le gpio3 (exemple) et le reste brancher à la masse, le moteur peut démarrer durant 10sec puis s'éteindre ?
En gros tu veux alimenter le moteur est en même temps autre chose?

Cordialement
Le pro du déterrage de topic est là!

Alexidreaming

destroyedlolo
Raspinaute
Messages : 1298
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: moteur et gpio

Message par destroyedlolo » mer. 18 janv. 2017 12:36

Salut,

Ca ne va marcher qu'un temps : tu va finir par griller ton GPIO.

Il faut ajouter un étage de puissance à base de transistor. Je n'en ai pas sous la main, mais google sera ton ami car c'est du classique de chez classique.

A+
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.


Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Re: moteur et gpio

Message par Nanard » mer. 18 janv. 2017 18:37

Merci pour les conseils !
Alors le programme que j'ai taper en python fonctionne bien avec une LED mais ne fonctionne pas avec le moteur.
Cela résulte du manque de courant qui circule dans mon moteur donc impossible à lancer si je ne le pousse pas un peu.

destroyedlolo
Raspinaute
Messages : 1298
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: moteur et gpio

Message par destroyedlolo » mer. 18 janv. 2017 21:13

C'est encore pire que ça :non seulement tu n'as pas assez d'intensité (ce que l'électronique ne va déjà pas aimer) mais les charges inductives telles que les moteurs et autres relais créent des courants induits qui vont encore plus rapidement détruire ton CPU :$

Envoyé de mon E2303 en utilisant Tapatalk
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Répondre

Retourner vers « Débutants »