[RESOLU] Probléme RPI 3b+ et pidesktop elemant14

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » sam. 23 juin 2018 15:05

Salut,

déjà fait le boot_delay=1. Mais le probléme ne viens pas d'un delai quelconque. La commande reboot agit exactement comme la commande shutdown.

Je réexplique la situation.

1) Lorsque l'ont appuis 2 secondes sur le bouton du pi desktop il s'éteint normalement
2) Lorsque l'ont passe par le bureau pour éteindre le PI cela fait clignoter la led bleue du pi desktop et éteint la led rouge pwr elle se rallume briévement quand le PI est complétement éteint.
3) Lorsque l'ont passe par le bureau pour rebooter le PI cela fait clignoter la led bleue du pi desktop et éteint la led rouge pwr elle se rallume briévement quand le PI est complétement éteint.

Donc j'en déduit que le reboot envoi l'information shutdown au systéme. La vrai question est : Pourquoi ???? Et surtout comment remédier à cela.

mike913
Raspinaute
Messages : 102
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par mike913 » sam. 23 juin 2018 15:42

Bonjour

Idem pour moi. J' ai essayé plein de chose dans le config.txt mais cela ne change rien. En fait lors du reboot en l'absence de carte sd le rpi coupe l'alimentation. Donc pas de redémarrage, il faut débrancher et rebrancher pour que le rpi démarre.
J' ai acheté 2 carte d'extension X850 et il se passe la même chose (le reboot s'effectue normalement avec un rpi 3, mais pas avec un rpi 3b+)
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » sam. 23 juin 2018 19:58

Salut,

J'ai résolu en parti notre probléme.

Je suis reparti d'une installation propre avec raspbian stretch 2018-03-13

1) installation de pi desktop avec pidesktop-base-1.1.0.deb (qui biensur ne fonctionne pas ;) )
2) shutdown et redémarrage puisque le reboot n'est toujours pas fonctionnel
3) installation de "pidesktop-base.deb" pris ici https://translate.googleusercontent.com ... 8Xe15FD2dA
4) un petit sudo apt update && sudo apt upgrade
5) cette fois un vrai "reboot" et pour moi cela à fonctionné testé plusieurs fois :D

J'ai quand même ajouter quelques ligne dans config.txt mais j'ai la flemme de tester avec et sans
La fin du config.txt ressemble à ça chez moi

# Enable audio (loads snd_bcm2835)
gpio = 6 = op, pn, dl
gpio = 13 = ip

dtparam=audio=on
gpu_mem=160
max_usb_current=1
boot_delay=1

dtoverlay=i2c-rtc,pcf8563

Conclusion: Ben faut pas mettre à jour la stretch 2018-03-13 avec un rpi-update ni dist-upgrade (c'est un avis perso) Si quelqu'un est chaud pour tenter jj'attend le retour. Merci :mrgreen:

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » dim. 24 juin 2018 19:33

Retour de tests,

Et c'est pas bon. Il s'avére qu'aprés quelques maj ça recommence. Mon speetch du dessus n'a servi à rien.

Mais je suis reparti sur une autre idée que voici :

Passer par le systéme de fichier F2FS a partir d'un Linux raspberrypi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux.

Le résultat est bluffant ça redémarre beaucoup plus vite. Bon en même temps je n'est pas fait de màj :mrgreen: Mais je sent que je vais les faire pour voir.

Je vous tiens au courant :geek:

Artemus24
Raspinaute
Messages : 174
Enregistré le : ven. 15 sept. 2017 19:15

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Artemus24 » dim. 24 juin 2018 21:00

Salut major86.

J'ai trouvé quelques explications sur le Pi Desktop :
--> https://www.elektormagazine.fr/news/Pi- ... les-autres

Le fichier à télécharger Pidesktop V1.1.0 date de l'année dernière (20 juillet 2017), à savoir avant l'arrivé de la Rpi3B+.

On trouve aussi un commentaire concernant le problème lié au reboot :
--> https://github.com/pi-desktop/deb-make/issues/2

Il y a un lien dans ce commentaire qui signale le bon téléchargement :
Il s'agit de la version Pidesktop V1.1.6 ( en espérant qu'il n'y en a pas d'autres ailleurs) :
--> https://github.com/hoopsurfer/pidesktop

Et pour terminer, ce lien :
--> https://github.com/hoopsurfer/pidesktop/releases
où il est dit que cela a été testé avec un Rpi3B+.

@+
--> Rpi2B, Rpi3B+

Avatar du membre
vague nerd
Modérateur
Messages : 1463
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par vague nerd » lun. 25 juin 2018 09:47

Bonjour.
Artemus24 a écrit :
dim. 24 juin 2018 21:00
On trouve aussi un commentaire concernant le problème lié au reboot :
--> https://github.com/pi-desktop/deb-make/issues/2
Intéressant. @major86 : votre boot prend il plus de 30 secondes ?
Artemus24 a écrit :
dim. 24 juin 2018 21:00
Il y a un lien dans ce commentaire qui signale le bon téléchargement :
Il s'agit de la version Pidesktop V1.1.6 ( en espérant qu'il n'y en a pas d'autres ailleurs) :
--> https://github.com/hoopsurfer/pidesktop
Attention, c'est un fork.

Pour ma part, il semble que je sois en version 1.0.0 de pidesktop-base (ce qui me surprend) :

Code : Tout sélectionner

apt-show-versions pidesktop-base
pidesktop-base:all 1.0.0 installed: No available version in archive
Quelqu'un peut confirmer que je ne me suis pas loupé dans la commande ?

Petite précision : les problèmes liés au reboot que j'ai rencontré ne l'on été ni sur un 3b+, ni sur streach...
Rien ne dit qu'il y ai un lien entre ces problèmes et ceux que vous rencontrez... je vais arrêter de me torturer la mémoire !
Cordialement,

Vague Nerd

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » lun. 25 juin 2018 18:11

Salut,

J'ai 14 flashs sur le pi desktop (environs 15/16 secondes) pour le reboot. Mais plus de 30s pour atteindre le bureau.

Qu'entendez-vous par "Attention, c'est un fork." ?

Avatar du membre
vague nerd
Modérateur
Messages : 1463
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par vague nerd » mer. 27 juin 2018 11:19

Salut.
Major86 a écrit :
lun. 25 juin 2018 18:11
J'ai 14 flashs sur le pi desktop (environs 15/16 secondes) pour le reboot. Mais plus de 30s pour atteindre le bureau.
Avez vous lu le post et les liens de Artemus24 ? Il est possible que la durée de boot soit en lien avec le problème.
Major86 a écrit :
lun. 25 juin 2018 18:11
Qu'entendez-vous par "Attention, c'est un fork." ?
Les liens proposés pointent sur des distrib non officielles de la librairie mise à jour. Ce n'est pas grave en soit, mais il faut le savoir.
A vous de voir ensuite si vous faites confiance ou non à l'émetteur de la lib modifiée.
Cordialement,

Vague Nerd

mike913
Raspinaute
Messages : 102
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par mike913 » dim. 1 juil. 2018 22:41

Bonjour,

j'avais le même problème avec la carte d'extension X850 et un MSata Samsung de 850 G, le Boot démarrage normal et Reboot arrêt complet.
Et depuis la mise à jour avec le firmware #1123 du 27 Juin le Reboot fonctionne normalement.
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Résolu-Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » lun. 2 juil. 2018 00:37

Merci mike913 de ton retour. J'ai moi aussi retrouver l'usage normal de mon pidesktop depuis la derniére màj.
Je passe le sujet en résolu.

Merci à tous.

Répondre

Retourner vers « En panne ? »