Windows 10 n'accède plus à mon partage SAMBA sur le Pi  [RESOLU]

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Somath
Messages : 5
Enregistré le : ven. 13 juil. 2018 19:59

Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Somath » ven. 13 juil. 2018 20:26

Bonjour,

J'ai suivi pas mal de tutos ici même et ailleurs pour créer un NAS avec un Raspberry 3.
Ca fait maintenant un petit bout de temps que tout fonctionne pas trop mal (à l'époque j'étais encore en Raspberry Pi 2).

Hélas il y a deux jours j'ai décidé de réinitialiser un de mes deux PC sous windows 10, et depuis ce PC ne veut plus accéder au partage Samba.
Tout fonctionne toujours très bien du coté de l'autre PC qui n'a pas été réinitialisé.

Windows 10 me dit "impossible d'accèder à \\RASPBERRYPI veuillez vérifier le nom..."

J'ai vu qu'il y avait eu des mises à jour Microsoft qui cachaient les serveurs SAMBA, mais même caché, j'y accédais tout de même avec le bon chemin de réseau.

Ma config : RAspberryPi 3 branché en Ethernet avec le serveur Samba (et d'autres choses...), rpi-update, aptitude update et aptitude upgrade effectués.
Un PC portable connecté en wifi (qui accède au partage)
Un PC portable (en fait une Surface pro) connecté en wifi, qui n'arrive pas à accéder au partage depuis sa réinitialisation.

Quelqu'un saurait-il me venir en aide ?
Merci par avance

Bud Spencer
Raspinaute
Messages : 393
Enregistré le : lun. 15 août 2016 21:38

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi  [RESOLU]

Message par Bud Spencer » dim. 15 juil. 2018 12:13

Tu peux essayer ca :

Regardes si la clé de registre HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth existe.

Si elle existe et que la valeur est 0, passe la à 1.
Si la clé n'existe pas, ajoute la (DWORD 32 bits) et donne lui la valeur 1.
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Artemus24 » dim. 15 juil. 2018 13:02

Salut somath.

Autre solution est de ne pas utiliser le HOSTNAME. Mettez plutôt l'adresse IPv4 que votre DHCP attribue à votre raspberry.

Sinon oui, il y a eu des modifications de faites au travers de windows en ce qui concerne le protocole SMB.
Vous vous rendez dans :
--> panneau de configuration
--> activer ou désactiver les fonctionnalités de windows.

Vérifiez si "support de partage de fichier SMB 1.0/CIFS" ne serait pas décoché ?
S'il est décoché, vous pouvez le cocher à nouveau pour utiliser le protocole SMB 1.0.
Je rappelle que le virus wanacrypt utilisait ce protocole pour mettre le bordel sur votre ordinateur.

Sinon à la place, vous pouvez cocher "SMB Direct" que j'utilise sur mon ordinateur et sans problème. En fait, c'est du SMB 3.0.

@+
--> Rpi2B, Rpi3B+

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Artemus24 » dim. 15 juil. 2018 13:07

Salut Bud Spencer.

Comment va Terence Hill ?

Je n'ai pas votre astuce chez moi, dans la base des registres et j'accède bien à ma raspberry depuis "ce pc" dans la partie "emplacement réseau".

Pouvez-vous expliquer à quoi sert cette astuce ? :)

@+
--> Rpi2B, Rpi3B+

Bud Spencer
Raspinaute
Messages : 393
Enregistré le : lun. 15 août 2016 21:38

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Bud Spencer » dim. 15 juil. 2018 16:17

Salut Artemus

La présence et la pertinence de la clé depend de la version et du niveau de mise a jour de Windows 10. Elle permet d'autoriser ou pas la connexion a des partages smb non sécurisés (souvent le cas avec samba et les comptes guest). La modification de cette clé permet d'identifier rapidement et clairement le problème (qui doit bien sur etre corrigé au niveau du serveur Samba si l'on est sur un reseau à risque).

Pour plus d'info :
https://docs.microsoft.com/en-us/window ... eguestauth
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Artemus24 » dim. 15 juil. 2018 20:25

Salut à tous.

Merci Bud Spencer.

Suite à "wannacrypt", j'ai étudié le protocole SMB que je ne connaissais pas.
Ce protocole sert à identifier les périphériques du réseau local (LAN). Il est inutile pour les réseaux WAN.

Par sécurité, dans le pare-feu de windows, j'ai interdit ce protocole (SMB, c'est le port 445) pour le WAN et autorisé pour le LAN.
Comme il est anciennement lié à netbios (ce sont les ports 137, 138 et 139), je les ai aussi interdit pour la WAN et autorisé pour le LAN.
Ce que je ne comprends pas, peut-être un problème avec le pare-feu windows, je ne peux pas désactiver netbios pour le flux sortant WAN.
Logiquement WAN c'est pour internet, c'est-à-dire au delà du routeur. Donc pourquoi ai-je ce besoin pour mon réseau local ?

Donc j'ai désactivé SMB 1.0, en décochant "support de partage de fichier SMB 1.0/CIFS". Et j'ai activé "SMB DIRECT".
Bien sûr, j'accède sans problème au serveur SAMBA de ma raspberry.

@+
--> Rpi2B, Rpi3B+

Somath
Messages : 5
Enregistré le : ven. 13 juil. 2018 19:59

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Somath » lun. 16 juil. 2018 10:38

Bonjour,

Merci pour vos réponses,

"Autre solution est de ne pas utiliser le HOSTNAME. Mettez plutôt l'adresse IPv4 que votre DHCP attribue à votre raspberry."
J'ai également essayé mais ça ne donne rien d'autre que la même erreur qu'avec le hostname.

"Vérifiez si "support de partage de fichier SMB 1.0/CIFS" ne serait pas décoché ?"
Déjà vérifié et réactivé également (pour tester si ça venait bien de ça), d'ailleurs cette fonctionnalité ne m'empêchait pas jusque là d'accéder au partage, simplement que ce dernier était "caché" dans l'onglet réseau de Windows.

SMB Direct est coché par défaut dans les fonctionnalités Windows chez moi, il ne règle donc hélas pas mon problème non plus.

"Regardes si la clé de registre HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth existe."
La clé était effectivement à 0, je la passe à 1 à l'instant et teste ça...
Ca vient en effet de régler mon problème, Windows accède au partage ! Qu'est ce que ça indique du coup ? Qu"il y a une option qui bloque au niveau du samba.conf du Raspberry ?

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Artemus24 » lun. 16 juil. 2018 12:28

Salut Somath.

Vous êtes-vous authentifiés quand vous faites un accès au samba de votre raspberry ?
Le problème vient peut-être de là, si justement vous ne vous identifiez pas.

@+
--> Rpi2B, Rpi3B+

Somath
Messages : 5
Enregistré le : ven. 13 juil. 2018 19:59

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Somath » lun. 16 juil. 2018 13:13

Hello,

Non pas d'identification, aucune fenêtre d'identification ne m'a d'ailleurs été soumise.
Je n'ai, il me semble, jamais eu besoin de la faire car j'avais forcé l'identification dans le samba.conf avec la ligne "guest ok"

Bud Spencer
Raspinaute
Messages : 393
Enregistré le : lun. 15 août 2016 21:38

Re: Windows 10 n'accède plus à mon partage SAMBA sur le Pi

Message par Bud Spencer » mar. 17 juil. 2018 11:17

Somath a écrit :
lun. 16 juil. 2018 10:38
...
La clé était effectivement à 0, je la passe à 1 à l'instant et teste ça...
Ca vient en effet de régler mon problème, Windows accède au partage ! Qu'est ce que ça indique du coup ? Qu"il y a une option qui bloque au niveau du samba.conf du Raspberry ?
Faut prendre l’interprétation de cette clé très simplement :

Est-ce que j’autorise mon Windows à accéder à des partages smb en mode guest sans authentification ? Réponse OUI -> valeur de clé = 1, Réponse NON -> valeur de clé = 0

La bonne pratique est de garder cette clé à 0, de désactiver les accès guest sans authentification au niveau du serveur smb et d’y paramétrer des accès avec authentification. Une bonne configuration des comptes entre windows et samba suffit pour ne pas avoir besoin de s’authentifier systématiquement à chaque connexion (nécéssaire par exemple dans le cas d'un partage smb sur un NAS et qu'un service windows y écrit des sauvegardes).

A noter que cette clé ne concerne pas les accès guest SMB1.

Pour le reste, tout ça est bien passionnant, mais désolé. J'ai lu ici tellement de connerie à chaque fois que Windows a été évoqué et tout particulièrement quand il a été fait état de ses protocoles réseaux que je ne veux pas perdre mon temps à débattre sur ces sujets ici.
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

Répondre

Retourner vers « En panne ? »