Problème d'installation Kallope à partir de l'image

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Barnoch
Messages : 7
Enregistré le : lun. 27 août 2018 21:11

Problème d'installation Kallope à partir de l'image

Message par Barnoch » sam. 1 sept. 2018 18:17

Bonjour,

Premier projet et premier problème, je commence mal :D

J'ai flashé l'image de Kalliope (version 0.5.1) sur ma framboise PI 3 et ça ne marche pas...

à la fin du boot, j'ai :
---[ Kernel end panic - not syncing : VFS : unable to mount root fs on unknow-block(179,2)

Quelqu'un a une idée ?
Je dois tout installer manuellement ?

Merci pour vos réponses.

Artemus24
Raspinaute
Messages : 214
Enregistré le : ven. 15 sept. 2017 19:15

Re: Problème d'installation Kallope à partir de l'image

Message par Artemus24 » sam. 1 sept. 2018 19:20

Salut Barnoch.

Une recherche sur le net peut éventuellement vous donner la solution :
--> https://www.raspberrypi.org/forums/view ... p?t=124458

@+
--> Rpi2B, Rpi3B+

Barnoch
Messages : 7
Enregistré le : lun. 27 août 2018 21:11

Re: Problème d'installation Kallope à partir de l'image

Message par Barnoch » sam. 1 sept. 2018 20:50

Merci pour la réponse rapide :)

Mais je n'ai pas d'ordinateur sous linux :shock:

Par contre, j'ai un collègue qui connais un peu linux...
Je lui demanderai mardi.

Pour info, j'ai essayé d'utiliser une image de raspbian lite avec le même résultat et une recallbox qui a fonctionné...

Il ne faut pas formater la carte SD dans un format spécial ?

Encore merci.

B@rnoch.

Barnoch
Messages : 7
Enregistré le : lun. 27 août 2018 21:11

Re: Problème d'installation Kallope à partir de l'image

Message par Barnoch » dim. 2 sept. 2018 13:04

Bonjour,

J'ai réussi à installer un raspbian lite en formatant ma carte SD, mais pas l'image de Kalliope...
Je vais donc devoir l'installer manuellement et donc apprendre à configurer le wifi, le SSH etc...
Mais bon, c'était le but quand je me suis décidé à acheter une framboise :)

Je vous tiens au jus...

B@rnoch

Artemus24
Raspinaute
Messages : 214
Enregistré le : ven. 15 sept. 2017 19:15

Re: Problème d'installation Kallope à partir de l'image

Message par Artemus24 » dim. 2 sept. 2018 17:08

Salut Barnoch.

Si vous désirez installer une image de raspbian sur une carte Micro SD, depuis votre ordinateur Windows, vous devez passer par l'un de ces utilitaires :
--> etcher
--> Win32DiskImager
Les partitions existent déjà et tout ce dont vous devez faire, c'est les recopier.

Quand vous dites :
Barnoch a écrit :J'ai flashé l'image de Kalliope (version 0.5.1) sur ma framboise PI 3
je ne comprends pas trop ce que vous entendez par "flashé.

Comment avez-vous procéder pour recopier l'image de raspbian (peu importe laquelle) sur votre carte micro SD ?

@+
--> Rpi2B, Rpi3B+

Barnoch
Messages : 7
Enregistré le : lun. 27 août 2018 21:11

Re: Problème d'installation Kallope à partir de l'image

Message par Barnoch » dim. 2 sept. 2018 22:37

Bonsoir,

J'ai utilisé ces 2 utilitaires pour mettre l'image de kalliope sur ma carte SD mais sans succès.
Actuellement j'ai réussi à installer Raspbian Lite et j'installe Kalliope via un script comme décrit ici : https://kalliope-project.github.io/kall ... /raspbian/

Je vous tiens au courant de ma progression ;)

Merci pour la réponse.

B@rnoch

Barnoch
Messages : 7
Enregistré le : lun. 27 août 2018 21:11

Re: Problème d'installation Kallope à partir de l'image

Message par Barnoch » mar. 4 sept. 2018 23:12

Bonsoir,

Je progresse ;)
Raspbian lite est installé
Kalliope est installé manuellement
J'arrive à lancer Kalliope.

Problèmes actuels :
- pas de réaction à une commande vocale (erreur de configuration du micro ?)
- kalliope ne s'est pas installé dans /home/pi/ :shock: mais dans /usr/local/lib/python2.7/dist-packages/

Voilà, dans un premier temps j'aimerai installer kalliope dans le /home/pi.

Bonne soirée.

B@rnoch

stephaneK
Messages : 89
Enregistré le : mar. 13 sept. 2016 10:08

Re: Problème d'installation Kallope à partir de l'image

Message par stephaneK » jeu. 13 sept. 2018 10:02

Bonjour,
Vous avez essayé la commande

$ rec mavoix.wav
Vous dites une phrase et ctrl + c pour arrêter l'enregistrement.

Ensuite pour lire, un $ mplayer mavoix.wav (à condition d'avoir installé mplayer)

Perso, j'ai suivi la procédure d'installation manuelle, avec Raspbian Stretch (version graphique) sur un Pi 3b+.
Mon micro à la taille d'une clé USB, j'ai une enceinte bluetooth classique. Kalliope ne réagie pas à mes ordres. Même pas son "hotword".

Par contre, tout fonctionne sur mon pc équipé d'Ubuntu. La version Française comporte quelques neurones comme l'heure, la date, bonjour ...

Je vais creuser autour du Raspberry, mais je pense que le problème viens du micro.

@++

Barnoch
Messages : 7
Enregistré le : lun. 27 août 2018 21:11

Re: Problème d'installation Kallope à partir de l'image

Message par Barnoch » jeu. 13 sept. 2018 21:03

Bonsoir,

J'ai progressé dans l'installation :)

Tout fonctionne mais le micro ne réagit pas correctement : je dois insister pour déclencher le hotword.

J'ai contrôlé le micro avec les commande arecord test.wav et aplay test.wav
Résultat : beaucoup de bruit parasite.

Matériel de test :
- carte usb Trust pour le micro
- casque sur la prise jack

j'ai aussi testé avec un mini microphone usb avec le même résultat.

Actuellement je cherche à réduire le bruit du micro, des suggestions ?

D'avance merci.

B@rnoch

stephaneK
Messages : 89
Enregistré le : mar. 13 sept. 2016 10:08

Re: Problème d'installation Kallope à partir de l'image

Message par stephaneK » ven. 14 sept. 2018 09:00

Salut,

En tapant :
$ alsamixer
Je crois que vous pouvez accéder aux réglages du micro.

@+

Répondre

Retourner vers « En panne ? »