Raspberry et Teleinfo sur Domoticz

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

domi
Administrateur
Messages : 2260
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Raspberry et Teleinfo sur Domoticz

Message par domi » lun. 5 nov. 2018 07:42

Bonjour,

Puisque l'adresse URL_FREEBOX existe déjà, ce sera la même, il faut simplement créer la redirection de port.
Pas de raison de casser la ou les redirections existante puisse que l'on ne va pas y toucher.

Je vois dans le message précédent que le port 8080 est déjà utilisé, il faut donc entrer par un autre port quelconque, exemple le 8090.
Pour comprendre comment cela fonctionne :
En fait, le routeur est a considérer comme un aiguillage, il reçoit toute les demandes http ou https faites pour l'adresse URL_FREEBOX.
Puis en fonction du port utilisé, il redirige vers une machine interne, ou une autre.

Donc actuellement il reçoit tout ce qui est demandé à URL_FREEBOX, on va maintenant lui dire que si il reçoit une demande sur le port 8090 (http://url_freebox:8090/), il faut qu'il redirige la requête vers le domoticz Maître.

On ajoute donc une redirection, en IP de destination il faut donner celle du domoticz maître, en port d'entrée on met 8090, et en port de sortie en met 8080.

Torseur 06
Messages : 21
Enregistré le : dim. 28 janv. 2018 14:19

Re: Raspberry et Teleinfo sur Domoticz

Message par Torseur 06 » mer. 7 nov. 2018 19:20

Merci pour ces explications domi détaillées.

Maintenant j'arrive à accéder à mes 2 raspberry maitre et esclave depuis l'extérieur grâce à vos conseils.
J'avoue que malgré votre explication très claire les histoires d'ouverture de ports restent très obscures pour moi et j'ai appliqué un peu bêtement ce que vous m'avez indiqué.
Je comprends que j'ai pu ouvrir le port principal 8080 pour accéder à mon FREEBOX OS par le biais de l' URL-FREEBOX depuis l'extérieur.

Ensuite j'ai ouvert le port 80 pour mon Raspberry Teleinformation (Esclave) avec le paramétrage :
Port de début : 80 / Port de fin : 80 / Port de destination : 80
Du coup je peux atteindre ce Raspberry en entrant http://url_freebox:80/

J'ai ouvert le port 8090 pour mon Raspberry Serveur Domoticz (Maitre) avec le paramétrage :
Port de début : 8090 / Port de fin : 8090 / Port de destination : 8080
Du coup je peux atteindre ce Raspberry en entrant http://url_freebox:8090/

Je ne comprends pas déjà la différence entre les 3 ports (Début, Fin et Destination).
Ensuite pourquoi mon port de destination pour mon 1er Raspberry n'est pas 8080 alors qu'il doit être égal à 8080 pour le Raspberry Serveur ? Pour autant j'arrive bien à atteindre mes 2 raspberry avec les URL précédents.

De plus, les numéros de port à affecter me dépassent. Pourquoi utiliser 8080 et 8090 au lieu d'utiliser plus simplement 1 et 2. C'est surement des questions basiques car probablement les ports sont définies sur des plages bien définies mais je n'ai pas trouvé ma réponse sur la toile.

Merci de votre aide !

jelopo
Messages : 95
Enregistré le : mer. 11 oct. 2017 10:23

Re: Raspberry et Teleinfo sur Domoticz

Message par jelopo » mer. 7 nov. 2018 21:31

Bonjour,
De plus, les numéros de port à affecter me dépassent. Pourquoi utiliser 8080 et 8090 au lieu d'utiliser plus simplement 1 et 2. C'est surement des questions basiques car probablement les ports sont définies sur des plages bien définies mais je n'ai pas trouvé ma réponse sur la toile.
Avant d'aller sur la toile, consulter le fichier /etc/services sur le PI pour voir la listes des services et de leurs ports.

A+

domi
Administrateur
Messages : 2260
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Raspberry et Teleinfo sur Domoticz

Message par domi » jeu. 8 nov. 2018 09:18

Bonjour,

Voici un lien internet qui explique assez simplement le principe de redirection IP et Port.

Concernant les ports, on ne peux pas utiliser 1,2,3.... car tous les port inférieurs à 1024 sont des ports système et/ou réservés.

Pourquoi un port d'entrée parfois différent du port de sortie :
Tu peux avoir 2 machine dans ton réseau local qui utilisent le même port (exemple 8080 pour ta box et pour Domoticz). Dans ce cas, il faut faire une différence en entrée de ton adresse IP Public. Un en 8080 qui va vers ta box sur le 8080, et étant déjà utilisé en entrée, on choisi un autre port d'entrée (8090 dans l'exemple), mais ça peut être n'importe qu'elle port que l'on redirige vers le Domoticz vers sont port attendu, le 8080.

Le port 80 est le port par défaut du http, dans ce cas, il faut effectivement une redirection comme tu l'as faite, mais pas besoin de préciser le port http://url_freebox:80/
http://url_freebox/ suffit à lui seul.

Torseur 06
Messages : 21
Enregistré le : dim. 28 janv. 2018 14:19

Re: Raspberry et Teleinfo sur Domoticz

Message par Torseur 06 » ven. 9 nov. 2018 09:03

Merci encore domi et jelopo pour vos explications, je vais aller regarder un peu plus en détails ce site pour mieux comprendre les aspects de directions de port.

Une question complémentaire, je me suis rendu compte que mon script (issu du site Magdiblog) me permet de récupérer les informations de téléinformations toutes les minutes et de les tracer dans l'URLFREEBOX.
Sur DOMOTICZ, je me trouve avec des relevés toutes les 5 minutes, ce qui est problématique pour des équipements comme bouilloires, cafetieres et micro ondes qui n'ont pas vocation à fonctionner au delà de 2, 3 minutes et qui passent à travers les mailles.

Pouvez vous m'indiquer la démarche à adopter pour que DOMOTICZ mette à jour ces données toutes les minutes pour la téléinformation ?


De plus, je remarque que j'ai régulièrement des coupures de courant générales et lorsque c'est le cas mon DOMOTICZ esclave associé à la Teleinfo remonte bien les données. Mais mon DOMOTICZ maitre lui n'arrive plus à faire le lien avec le DOMOTICZ esclave pour remonter les informations de Teleinfo. C'est à dire que la dernière mesure reste celle juste avant la coupure et la remontée teleinfo s'arrête à cette heure là et pour les heures suivantes elle affiche 0W. (alors que le DOMOTICZ maitre remonte les bonnes infos).
C'est comme si la connectivité entre Maitre et Esclave s'était perdue.
Avez vous une idée pour résoudre le problème ?

Merci à vous !

domi
Administrateur
Messages : 2260
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Raspberry et Teleinfo sur Domoticz

Message par domi » ven. 9 nov. 2018 18:19

Bonjour,

Concernant la question de intervalle, je n'ai pas la réponse, mais ce qui m'étonne c'est que de mon coté je n'ai rien fait, mon interface est également le montage qui est donné sur le site Magdiblog, mais l'intervalle de mes relevés est de 30 secondes environs (entre 31 et 32s).

Pour ce qui est de la perte de connexion en cas de reboot suite à coupure de courant, je pense que tu dois être en wifi, car je rencontre également le problème, dans ce cas il faut parfois plusieurs minutes avant qu'il se resynchronise. J'ai cherché mais je n'ai pas trouvé la cause, je pense que cela vient plutôt de mon relais wifi qui raccroche le wifi après le Rpi.

Torseur 06
Messages : 21
Enregistré le : dim. 28 janv. 2018 14:19

Re: Raspberry et Teleinfo sur Domoticz

Message par Torseur 06 » ven. 9 nov. 2018 22:29

Merci encore domi.

Alors je précise ma demande l'actualisation de toutes les 5 minutes c'est sur le graphique (Température, Téléinfo) alors que peut être dans la base de données l'actualisation se fait à des intervalles différents. Mon objectif étant de pouvoir obtenir toutes les minutes l'actualisation sur mon graphique.
Je sais qu'avec mon URLFREEBOX et le script magdiblog j'ai une actualisation toutes les minutes sur mon graphe alors que sur DOMOTICZ c'est toutes les 5 minutes sur les graphes d'où la perte d'information.
J'ai vaguement vu qu'il existait une option appelé "Shortloginterval" dans le SQLserver.cpp que l'on pouvait changer mais je ne sais pas où trouver cette information
(source https://www.domoticz.com/forum/viewtopi ... 855#p73855)
Aussi j'ai testé cette possibilité qui consiste à éditer cet élément de DOMOTICZ www/views/setup.html . Pour y ajouter une commande mais cela n'a pas marché ou alors je l'ai mal rentré.
(source https://www.domoticz.com/forum/viewtopi ... 3&start=20)

Peut être savez vous me diriger vers l'une ou l'autre méthode ?

Concernant la perte de synchro entre les 2 DOMOTICZ effectivement la liaison est WIFI. C'est une plaie et j'envisage d'installer un onduleur du côté MAITRE et une batterie de type POWER BANK du côté ESCLAVE. Pour l'onduleur je me fais pas trop de soucis n'importe lequel fera l'affaire et j'en profiterai pour brancher ma box et les équipements multimedia dessus mais pour le POWER BANK pour le Raspberry Esclave de Teleinfo, savez vous m'indiquer un modèle qui serait capable d'alimenter le Raspberry le temps de coupures d'un maximum de 10 à 20 secondes ?

Merci à vous !

domi
Administrateur
Messages : 2260
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Raspberry et Teleinfo sur Domoticz

Message par domi » sam. 10 nov. 2018 08:45

Bonjour,

Le graphique se dessine par rapport a toutes les données, donc si tu as des relevés, le graphique se crée.
Dans domoticz, tu peux voir le capteur, en plus des infos relevé, tu as a chaque fois l'heure minutes et seconde du dernier relevé, cela te permet de voir l’intervalle.

Tu peux également voir du coté des log de domoticz qui te diront si tout se passe bien, et tu verra également tous les relevés.

Torseur 06
Messages : 21
Enregistré le : dim. 28 janv. 2018 14:19

Re: Raspberry et Teleinfo sur Domoticz

Message par Torseur 06 » mer. 14 nov. 2018 19:14

Merci domi,

Sur mon capteur j'ai bien des relevés toutes les minutes. Mais les courbes de mesure associés au capteur n'utilisent des points de mesure que toutes les 5 minutes entières (05 10 15 ... 50 55 00).
Sur le "log" du capteur dans la date table, les données remontées sont indiqués toutes les 5 minutes.
Je n'arrive pas à comprendre comment actualiser les graphiques chaque minute alors que les données remontent bien toutes les minutes.

Merci à vous !

Répondre

Retourner vers « En panne ? »