SSH qui rame quand deux pi zero sont connectés au même réseau

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
sylvouille
Messages : 12
Enregistré le : sam. 4 mai 2019 09:22

SSH qui rame quand deux pi zero sont connectés au même réseau

Message par sylvouille » ven. 12 juil. 2019 13:15

Bonjour,
je fais face à un problème que je n'arrive pas à expliquer : je dispose de deux RPI0 WH sous raspbian lite, l'un avec un PiTVHat pour faire tourner TVHeadEnd, l'autre avec un miniamp qui me sert de radio intégrée avec mpd. Ils n'ont pas de clavier/écran, aussi je ne les gère que par SSH. Ils sont connectés à mon réseau par ethernet (grâce à un hub usb/ethernet), sur lequel sont aussi reliés 2 RPI3 sous raspbian et d'autres ordis sous linux, tous avec SSH activé. Tous ces appareils sont en IP fixe. Or il se passe quelque-chose de bizarre : lorsqu'un seul de ces pi zero est connecté au réseau (quels que soient les autres ordis connectés) la connexion SSH est très fluide et répond très bien. Mais dès que les deux pi zero sont connectés au réseau simultanément, les connexions SSH sur ceux-ci deviennent extrêmement lentes : passer une commande peut prendre plusieurs secondes voire plus de 10-20 secondes.
Avez-vous une idée d'où peut venir le problème ?
Merci d'avance,
Sylvain.

domi
Administrateur
Messages : 2528
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par domi » ven. 12 juil. 2019 14:23

Bonjour,

Cela ressemble à un paramétrage réseau. Ils n'auraient pas la même IP à tout hasard ?

Avatar du membre
EVOTk
Modérateur
Messages : 838
Enregistré le : sam. 20 sept. 2014 02:36

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par EVOTk » ven. 12 juil. 2019 14:53

Salut,
As tu changer les ports afin de ne pas utilisé le même port ssh sur les deux machines ?
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

sylvouille
Messages : 12
Enregistré le : sam. 4 mai 2019 09:22

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par sylvouille » ven. 12 juil. 2019 14:55

Bonjour,
effectivement ça me faisait initialement penser à un problème de paramétrage du réseau, mais ce n'est pas un problème d'adresse IP, elles sont bien différentes. Et ces lenteurs ne semblent concerner que SSH, et pas les autres protocoles (les interfaces web des deux RPI0 branchés simultanément répondent bien).

sylvouille
Messages : 12
Enregistré le : sam. 4 mai 2019 09:22

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par sylvouille » ven. 12 juil. 2019 14:56

Non, c'est effectivement quelque chose que je n 'ai pas encore tenté. J'essaie ce soir et vous tiens au courant.
EVOTk a écrit :
ven. 12 juil. 2019 14:53
Salut,
As tu changer les ports afin de ne pas utilisé le même port ssh sur les deux machines ?

maxty01
Modérateur
Messages : 725
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par maxty01 » ven. 12 juil. 2019 23:03

Bonsoir,

Effectivement, on peut suspecter un problème réseau, mais pas que ...

Peux-tu nous donner le résultat de la commande uptime afin de voir le loadaverage lors de problème ?

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Artemus24
Raspinaute
Messages : 354
Enregistré le : ven. 15 sept. 2017 19:15

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par Artemus24 » sam. 13 juil. 2019 16:10

Salut à tous.

Je rencontre de temps en temps le même problème, à savoir une lenteur dans la connexion par SSH.
Le responsable est mon routeur SFR, dont je ne sais pas pourquoi, au lieu de me fournir l'adresse IPv6 fixe que je lui demande, me donne une adresse par le DHCP.
Et comme ma raspberry ne trouve pas la bonne adresse, au bout de quelques instants, bascule sur l'adresse IPv4.

Les adresses IPv4 & IPv6 sont sous la forme d'un nom DNS dans mon réseau.
Ils sont correctement référencés dans le routeur SFR NB6v2, mais de temps en temps, l'association adresse IP / adresse MAC ne se fait pas correctement.

Si par contre, je donne les bonnes adresses ip numérique et non les noms DNS, il n'y a plus de lenteur.
Donc oui, c'est bien un problème réseau !

@+
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT, 2xRpi2B, Rpi3A+, Rpi3B+

destroyedlolo
Raspinaute
Messages : 1279
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par destroyedlolo » dim. 14 juil. 2019 11:21

Salut,
EVOTk a écrit :
ven. 12 juil. 2019 14:53
As tu changer les ports afin de ne pas utilisé le même port ssh sur les deux machines ?
Nan :mrgreen: Heureusement que ca ne pose aucun pb d'avoir les mêmes ports sur des machines différentes sinon aucun démon réseau ne fonctionnerait ;)
Artemus24 a écrit :
sam. 13 juil. 2019 16:10
Le responsable est mon routeur SFR, dont je ne sais pas pourquoi, au lieu de me fournir l'adresse IPv6 fixe que je lui demande, me donne une adresse par le DHCP.
Est-ce que tu as forcé aussi l'adresse fix sur le PI ? Si tu veux une IP fixe, il faut soit donner un baud fixe sur le DHCP, soit réserver une plage hors DHCP.
Si le but est simplement d'accéder par DNS a tes machines INTERNE, la solution la plus simple est de passer par avahi / mDNS.
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Artemus24
Raspinaute
Messages : 354
Enregistré le : ven. 15 sept. 2017 19:15

Re: SSH qui rame quand deux pi zero sont connectés au même réseau

Message par Artemus24 » dim. 14 juil. 2019 21:31

Salut destroyedlolo.
destroyedlolo a écrit :Est-ce que tu as forcé aussi l'adresse fix sur le PI ?
Non, je récupère l'adresse IP pour mon Raspberry par ma box SFR.
En fait, le problème se pose avec l'IPv6 et non avec l'IPv4.
destroyedlolo a écrit :Si tu veux une IP fixe, il faut soit donner un baud fixe sur le DHCP, soit réserver une plage hors DHCP.
Je sais faire. Merci pour le conseil.
Le problème que je rencontre est un bug dans ma box sfr que je ne peux pas résoudre par moi-même.
destroyedlolo a écrit :Si le but est simplement d'accéder par DNS a tes machines INTERNE, la solution la plus simple est de passer par avahi / mDNS.
C'est juste avec une seule raspberry que j'ai ce problème.
Je préfère utiliser ma box sfr pour résoudre les adresses DNS.

Si je suis intervenu dans ce sujet, c'est pour signaler mon problème qui est assez similaire mais pas identique à sylvouille.

@+
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT, 2xRpi2B, Rpi3A+, Rpi3B+

Répondre

Retourner vers « En panne ? »