Script pour ventilateur pi4 non compatible manjaro kde

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Script pour ventilateur pi4 non compatible manjaro kde

Message par cbalo » mar. 14 janv. 2020 21:57

Bonjour, oui, le message est très clair : vcgencmd manquant.
Vcgencmd n'empêche pas le ventilateur de tourner, il empêche la mesure de la température. Hors ce service lance le ventilateur en fonction de la température mesurée par vcgencmd.
Les autres erreurs (python) ne sont que les conséquences du fait que vcgencmd n'est pas trouvé.

A la lecture de [url]https://archlinuxarm.org/forum/viewtopi ... =12746/url]
Soit vcgencmd est bien présent mais pas là où on l'attend, soit il est réellement absent.

Que dit :

Code : Tout sélectionner

ls /opt/vc/bin/vcgencmd 
Si trouvé, c'est qu'il est là
Ou (des.fois que ...)

Code : Tout sélectionner

whereis vcgencmd 

Alexandrapi4
Messages : 7
Enregistré le : lun. 6 janv. 2020 18:23

Re: Script pour ventilateur pi4 non compatible manjaro kde

Message par Alexandrapi4 » mer. 15 janv. 2020 18:10

Bonsoir !
Je viens d'essayer les commandes que vous m'avez indiqué plus haut et voici le résultat.
Ben rien lol, il ne retourne rien à part impossible d'accéder à vcgencmd
Il ne semble meme pas avoir de répertoire /vc/bin/ dans la distribution, opt lui existe bien.
J'ai récupérer sur raspian un fichier lui présent vcgencmd et je pensais tout bêtement créer dans /opt les répertoires /vc/bin et y copier ce dernier, mais je ne suis pas parvenue à le faire, impossible d’accéder à root en écrire et je ne pouvais pas modifier les droits, du moins avec l'interface graphique, peut être est ce possible dans le terminal mais pour l'instant je ne sais pas utiliser la commande chmod et chown, no ou vraiment le copier.
Ici https://archlinuxarm.org/forum/viewtopi ... =12746/url il est fait mention du firmware du raspberry pi qui contiendrait ces commandes et qui fait aussi référence aux répertoires /vc/bin.
Je met souvent à jour la liste des paquets avec l'utilitaire fourni mais devrais je faire une update et une upgrade par le terminal pour peut-être obtenir un nouveau firmware ??
Est cohérent et surtout sans danger ??
Pardon pour mes questions peut-être idiotes.

dyox
Raspinaute
Messages : 735
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Script pour ventilateur pi4 non compatible manjaro kde

Message par dyox » mer. 15 janv. 2020 18:27

Pourquoi n'appliquez-vous ma méthode décrite précédemment ?

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Script pour ventilateur pi4 non compatible manjaro kde

Message par cbalo » mer. 15 janv. 2020 20:15

ok alors il n'est pas présent du tout (c'était pour vérifier)
Pour installer vcgencmd (c'est la seule chose qui manque) 2 options :
via apt-get :

Code : Tout sélectionner

sudo apt-get install libraspberrypi-bin
ou
téléchargement du source puis compilation
https://github.com/raspberrypi/userland

Et si ce n'est pas possible alors voir l'autre solution proposée.

Répondre

Retourner vers « Débutants »