232 résultats trouvés

par Korhm
sam. 9 sept. 2017 18:51
Forum : Python
Sujet : comportement incompréhensible GPIO.wait_for_edge()
Réponses : 2
Vues : 712

comportement incompréhensible GPIO.wait_for_edge()

Bonjour à tous, j'ai mis un place un bouton poussoir (un interrupteur en sailli) relié d'un côté sur le PIN 24, et de l'autre sur le GND. Le but est de lancer des actions quand on appuie dessus. Pour cela, j'utilise la fonction GPIO.wait_for_edge(24, GPIO.RISING) qui est censé attendre un changement...
par Korhm
sam. 2 sept. 2017 15:43
Forum : En panne ?
Sujet : [RESOLU] Connexion SSH entre framboises [RESOLU]
Réponses : 9
Vues : 966

Re: Connexion SSH entre framboises [RESOLU]

Si tu as de nouvelles info, n'hésite pas à partager, je suis curieux de comprendre ;)
par Korhm
sam. 2 sept. 2017 09:13
Forum : En panne ?
Sujet : [RESOLU] Connexion SSH entre framboises [RESOLU]
Réponses : 9
Vues : 966

Re: Connexion SSH entre framboises [RESOLU]

C'EST BON !!!! TROUVE !!!! Dans /etc/sudoers, il n'y avait pas la ligne suivante : ALL ALL=(ALL) NOPASSWD:ALL Maintenant c'est OK !!! 8-) :D Sur quel Raspberry il manquait cette configuration ? J'imagine que c'est sur le Rpi3 qui posait problème. Mais dans ce cas, je ne comprend pas pourquoi il fau...
par Korhm
sam. 19 août 2017 11:59
Forum : En panne ?
Sujet : Drivers pour Ltd FT232 USB-Serial (UART) IC
Réponses : 1
Vues : 438

Re: Drivers pour Ltd FT232 USB-Serial (UART) IC

Bon, après plusieurs heures de recherches et lignes de commande, j'ai un problème de kernel... J'ai remarqué que le module "ftdi_sio" n'était pas chargé, mais en tentant de le chargé, il m'indiquait que les libraires du mon kernel n'était pas présente (/lib/modules/4.9.24+ inexistant...) Donc, j'ai ...
par Korhm
ven. 18 août 2017 23:20
Forum : En panne ?
Sujet : Drivers pour Ltd FT232 USB-Serial (UART) IC
Réponses : 1
Vues : 438

Drivers pour Ltd FT232 USB-Serial (UART) IC

Bonsoir, j'ai un Arduino Nano qui tourne avec une puce FT232. Lorsque je le branche sur mon Raspberry Pi, il est bien reconnu : Deuxième ligne : $ lusb Bus 001 Device 057: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter Bus 001 Device 062: ID 0403:6001 Future Technology Devices Internatio...
par Korhm
mer. 2 août 2017 16:02
Forum : Utilisateurs avancés
Sujet : [Résolu] Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]
Réponses : 10
Vues : 1481

Re: Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]

Bon,

en branchement l'Arduino directement sur un port USB du Raspberry Pi, plutôt que via un HUB USB, l'upload se fait correctement à chaque coup.

Merci à tous pour votre aide ;)
par Korhm
mer. 2 août 2017 12:07
Forum : Utilisateurs avancés
Sujet : [Résolu] Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]
Réponses : 10
Vues : 1481

Re: Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]

je vais poser la question idiote ... mais je pense que tu as déjà testé : la vitesse de transfert est-elle la bonne ? PS : tu a renommé ton /dev ? tu lui envois les infos comment ? sérial ou USB ? Oui normalement la vitesse est la bonne. Il faudra que je re-verifie quand même au cas où Le arduino e...
par Korhm
mar. 1 août 2017 21:33
Forum : Utilisateurs avancés
Sujet : [Résolu] Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]
Réponses : 10
Vues : 1481

Re: Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]

Je rajoute des pièges au fur et à mesure :) Bon, j'ai finalement réussi à compiler avec inotool (j'ai laissé tombé le Makefile qui voulait pas compiler les dépendances des dépendances) J'avais cependant un problème dans mon code qui compile très bien avec l'IDE Arduino sous Windows, mais pas sous Li...
par Korhm
mar. 1 août 2017 15:22
Forum : Utilisateurs avancés
Sujet : [Résolu] Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]
Réponses : 10
Vues : 1481

Re: Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]

Merci pour vos retour :) Depuis hier je suis justement en train de regarder ce qui est faisable en ligne de commande, et vos liens mon bien orienté. J'ai tenté l'outil inotool qui permet de compilé puis uploader, sans succès. J'ai une erreur de compilation des librairies complémentaires Je suis donc...
par Korhm
lun. 31 juil. 2017 18:14
Forum : Utilisateurs avancés
Sujet : [Résolu] Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]
Réponses : 10
Vues : 1481

[Résolu] Raspberry en tant que "relai" pour ArduinoIDE [RESOLU]

Bonjour à tous, je me sers de mon Raspberry Pi pour, entre autre, m'interfacer avec un Arduino Nano en USB ; qui lui contrôle en bandeau de LED WS2812B. Tout ça est du bel effet derrière un meuble télé de 4m de long, et le tout bien rangé dans des tiroirs. Mon problème est là. Je programme depuis l'...

Aller à la recherche avancée