GPIO et instabilités électriques ?

Le connecteur GPIO du Raspberry Pi, comment l'utiliser sur les Mode A, B et B+

Modérateur : Francois

Répondre
sylvainpi
Messages : 20
Enregistré le : mer. 27 avr. 2016 21:18

GPIO et instabilités électriques ?

Message par sylvainpi » jeu. 7 mai 2020 11:08

Bonjour à tous,
j'ai créé un jukebox pour mon neveu, basé sur un RPi et des boutons de borne d'arcade. L'alimentation générale est réalisée à base sur uen alimentaiton RD35 de chez Mean Well ( https://www.meanwell.com/productPdf.aspx?i=159 ). Mon frère me signale que tout fonctionne bien mais qu'il a remarqué que lorsque le frigo se déclenche, la chanson change. Le changement de chanson est en théorie déclenché par l'appui sur un bouton lu par un GPIO, le code est disponible ici : https://github.com/symac/jukidbox/blob/ ... box.py#L46 rien de bien exotique.

J'imagine donc que le réseau électrique chez eux est moins stable que là où j'avais fait mes essais (ou que mes essais n'avaient pas été assez poussés), et ma question est donc : avez-vous une idée qui permettrait de résoudre simplement ce problème ? En repensant au problème je me dis que les boutons sont branchés en direct, sans résistance intermédiaire, est-ce que ça pourrait être lié à cela ?

Si en tout cas vous avez une piste pour résoudre ce problème ça m'intéresse !

Merci,
Sylvain
Premier projet : un jukebox pour enfants avec un RPi 1B.

dyox
Raspinaute
Messages : 722
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: GPIO et instabilités électriques ?

Message par dyox » ven. 8 mai 2020 10:44

Bonjour,

Alors je ne suis pas spécialiste mais je dirais comme ça que l'alim ne possède pas de filtre en entrée ou alors elle le fait mal.

Avez-vous essayé de changer d'alim ?
La terre est bonne chez eux ?
Alors je ne sais pas la puissance de l'alim (4A ou 2,2A), mais si vous avez une 4A pour une Pi1 (comsommation de <1A), l'alim est en dessus de 20% est ça c'est très mauvais. Cela stresse les composants.
L'alim est bien isolée ? https://www.youtube.com/watch?v=SidswRpZAG0
En repensant au problème je me dis que les boutons sont branchés en direct, sans résistance intermédiaire, est-ce que ça pourrait être lié à cela ?
Dans votre code Python, vous avez mis du pull-up (50k) donc ce n'est pas la peine.
Pour info, je viens de rechercher, seuls les gpio02 et 03 ont un pull-up "naturel" https://www.raspberrypi.org/documentati ... rypi/gpio/ et https://www.raspberrypi.org/documentati ... /README.md

Bonne recherche

domos
Messages : 55
Enregistré le : lun. 9 mars 2015 19:17

Re: GPIO et instabilités électriques ?

Message par domos » mer. 13 mai 2020 11:44

Bonjour,

Déjà rencontré ce problème avec un pluviomètre relié sur une entrée GPIO avec pull-up et un cable assez long

Je rajoute des condo. de 150nF à 330nF en parallèle des boutons mais au plus prés de la pin du rpi pour éviter des déclenchements par des appareils electriques.

Répondre

Retourner vers « Le GPIO »