Installation d'un écran tactile 3.2" TFT LCD

La vidéo HDMI ou composite et la sortie audio PWM du Raspberry Pi

Modérateur : Francois

Répondre
Vinnoff
Messages : 3
Enregistré le : ven. 26 févr. 2016 15:59

Installation d'un écran tactile 3.2" TFT LCD

Message par Vinnoff » sam. 27 févr. 2016 11:41

Bonjour à tous,

Alors, avant toutes choses, je suis ce que l'on pourrait appeler un "newbie" pour tout ce qui est relatif au Raspberry Pi, du coup je ne vais peut-être pas utiliser les bons termes ^^. Je m'y connais quand-même en informatique.

Cela étant dit, je vous fais part de mon problème.
Je dois créer un programme permettant à une personne de faire différents choix représentés sur un écran tactile. Mais avant toute chose, je dois installer un écran tactile de chez SainSmart sur mon Raspberry modèle B+ V1.2. J'ai donc suivi ce tuto qui avait l'air de plutôt bien expliquer la marche à suivre : http://ouiaremakers.com/ecran-tactile-et-raspberry-pi jusqu'à l'étape 7, mais rien ne marche. L'écran tactile reste blanc... Je pense l'avoir bien branché étant donné qu'il s'incruste parfaitement dans la protection du raspberry.

Merci d'avance pour vos réponses !

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Installation d'un écran tactile 3.2" TFT LCD

Message par vague nerd » lun. 29 févr. 2016 07:06

Bonjour.

Déjà, l'écran blanc, c'est bon signe ! (si, si, je vous promet)

Je viens de survoler votre tuto. A priori, vous n'êtes plus qu'a peu de chose du but.
Pour exécuter les commandes restantes, vous vous connectez en ssh ? Avec un écran HDMI ?

Cdt.
Cordialement,

Vague Nerd

Vinnoff
Messages : 3
Enregistré le : ven. 26 févr. 2016 15:59

Re: Installation d'un écran tactile 3.2" TFT LCD

Message par Vinnoff » mar. 1 mars 2016 12:42

N'ayant qu'un écran (pour ma tour) et qu'un port HDMI sur celui-ci, je me connecte en SSH, sinon je peux utiliser TightVNC, afin d'avoir l'image de mon raspberry sur l'ordinateur.

Je ne l'ai pas dis mais bien évidemment, je suis sous Raspbian

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Installation d'un écran tactile 3.2" TFT LCD

Message par vague nerd » mer. 2 mars 2016 15:40

Bonjour.
Vous avez passé l'étape 6 sans encombre (pas de message d'erreur...) ?
Cdt.
Cordialement,

Vague Nerd

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Installation d'un écran tactile 3.2" TFT LCD

Message par vague nerd » mer. 2 mars 2016 15:42

En particulier ca :
On va envoyer la sortie vidéo sur l’écran tactile. Changez la ligne Option "fbdev" "/dev/fb0" par Option "fbdev" "/dev/fb1" en éditant le fichier par la commande sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf.
Pas de soucis ?
Cordialement,

Vague Nerd

Vinnoff
Messages : 3
Enregistré le : ven. 26 févr. 2016 15:59

Re: Installation d'un écran tactile 3.2" TFT LCD

Message par Vinnoff » jeu. 3 mars 2016 00:35

Non, non, aucun soucis durant toute la configuration. Mais l'écran n'a pas effectué de premier calibrage (vu qu'il est tout blanc ^^).

Voici le fichier de configuration en question:

Code : Tout sélectionner

# This is a minimal sample config file, which can be copied to
# /etc/X11/xorg.conf in order to make the Xorg server pick up
# and load xf86-video-fbturbo driver installed in the system.
#
# When troubleshooting, check /var/log/Xorg.0.log for the debugging
# output and error messages.
#
# Run "man fbturbo" to get additional information about the extra
# configuration options for tuning the driver.

Section "Device"
        Identifier      "Allwinner A10/A13 FBDEV"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb1"

        Option          "SwapbuffersWait" "true"
EndSection
Et voici le fichier config.txt que j'ai modifié:

Code : Tout sélectionner

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=700

start_x=1
gpu_mem=128
core_freq=250
sdram_freq=400
over_voltage=0
dtparam=spi=on
dtparam=i2c_arm=on
dtoverlay=mz61581,fps=50,rotate=180,gpiopin=4,extpullup=1
J'hésite à remettre la valeur par défaut dtoverlay=w1-gpio-pullup à la place de dtoverlay=mz61581, bien que cela n'affecte pas le problème. Les paramètres gpiopin=4,extpullup=1 étaient déjà présents par défaut avant toute modification.

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Installation d'un écran tactile 3.2" TFT LCD

Message par vague nerd » sam. 5 mars 2016 17:55

Bonsoir.

Code : Tout sélectionner

dtoverlay=mz61581,fps=50,rotate=180,gpiopin=4,extpullup=1
J'hésite à remettre la valeur par défaut dtoverlay=w1-gpio-pullup à la place de dtoverlay=mz61581, bien que cela n'affecte pas le problème. Les paramètres gpiopin=4,extpullup=1 étaient déjà présents par défaut avant toute modification.
Moi, j'aurrai assayé le contraire :
remplacer la ligne par

Code : Tout sélectionner

dtoverlay=mz61581
... bref, l'étape 3, sans fioriture.

Sinon, dans le premier fichier, avez vous bien respecté le colonage (utilisation des tabulations ou espaces selon le cas...) ?
Pourquoi y a t il une ligne vide ? (Les fichiers formaté en mode colonnés sont souvent chatouilleux, voir capricieux)

Cdt.
Cordialement,

Vague Nerd

Répondre

Retourner vers « Les sorties Vidéo et Audio du Raspberry Pi »