[RESOLU] pas de son sur raspbian

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Répondre
luigi76
Messages : 3
Enregistré le : jeu. 18 sept. 2014 13:33

[RESOLU] pas de son sur raspbian

Message par luigi76 » jeu. 18 sept. 2014 13:36

Bonjour à tous,

J'ai un petit souci de son sous raspbian.

je voudrais que mon son sort sur mon ecran qui est brancher en hdmi.

quand je lance un mp3 avec vlc pas de son ou quand je lance un jeux sur emulateur non plus mais si je lance un rom depuis retropie sur

emulationstation il ya du son.

Y'a il des paquets a télécharger ou une mise a jour a faire ?

je viens de suivre ce tuto est rien a changer http://www.windtopik.fr/installation-da … pberry-pi/

J'ai bon chercher je vois pas comment faire.

quand raspbian boot je viens de voir il ya 2 [warn] kernel lacks cgroups or memory conttroler not available not starting cgroups.

et l'autre warn c'est pulseaudio configured for per-user serveur: sshd

Pouvez vous m’aider?

Merci d'avance

Luigi
Modifié en dernier par luigi76 le mar. 23 sept. 2014 12:19, modifié 1 fois.

Korhm
Raspinaute
Messages : 232
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Toulouse

Re: pas de son sur raspbian

Message par Korhm » ven. 19 sept. 2014 08:22

Bonjour,

j'avais eu quelques soucis aussi, je vais essayer de t'aider en me rappelant ce que j'avais fais.

1. Vérifie avec alsamixer que tu n'es pas en mute ou avec le son trop bas. A priori non puisque avec certaines appli tu as le son
2. la commande amixer permet de sélectionner la sortie son au niveau du système, si la manière automatique ne fonctionne pas. Pour sélectionner l'HDMI c'est :

Code : Tout sélectionner

amixer cset numid=3 2
3. Il me semble quu tu peux aussi essayer de forcer cela dans le fichier de boot. Après 2/3 recherches, j'ai retrouvé qu'il faut rajouter l'option suivante dans /boot/cmdline.txt (et de reboot après)

Code : Tout sélectionner

hdmi_drive=2
Si ça ne marche pas tel quel, fais quelques recherches sur les commandes ci-dessus pour que ça corresponde à ton environnement. Il me semble que se sont les valeurs par défaut, mais comme j'ai installé un carte son USB, je ne pourrais pas te dire pour l'HDMI.

mick39
Messages : 2
Enregistré le : ven. 19 sept. 2014 00:42

Re: pas de son sur raspbian

Message par mick39 » ven. 19 sept. 2014 14:28

Bonjour,

Il faudrait tout d'abord vérifier si le son sort du port jack du Raspberry Pi quand il n'y a pas de son sur l'écran.
Si oui, il suffit de se rendre dans la configuration du Rasberry Pi (sudo raspi-config), puis "Advanced Options" et "A6 Audio".
Sélectionne "Force HDMI" pour forcer la sortie audio sur le port HDMI.

luigi76
Messages : 3
Enregistré le : jeu. 18 sept. 2014 13:33

Re: pas de son sur raspbian

Message par luigi76 » lun. 22 sept. 2014 18:02

Bonjour,
JE vous remercie de vos réponses.

J'ai résolus le problème grace a mick39 :

Si oui, il suffit de se rendre dans la configuration du Rasberry Pi (sudo raspi-config), puis "Advanced Options" et "A6 Audio".
Sélectionne "Force HDMI" pour forcer la sortie audio sur le port HDMI.

Il étais en auto.

Merci a tous

Luigi

domi
Administrateur
Messages : 2645
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: pas de son sur raspbian

Message par domi » lun. 22 sept. 2014 21:03

Bonsoir,

Et bien parfait, c'est la deuxième résolution, les sujets avances....

Pour la bonne marche du forum, un petit [RESOLU] dans le titre du premier message.
Ce n'est pas grand chose, mais lorsque l'on fait des recherches sur Internet, cela permet d'informer qu'une solution a été concluante dans ce "Post".

Merci pour la communauté.

Répondre

Retourner vers « Débutants »