Tous les capteurs reliés au RPI par Wifi avec module ESP8266

Parce que les applications du Raspberry Pi sont illimités...

Modérateur : Francois

Avatar du membre
Jean-Marie
Raspinaute
Messages : 240
Enregistré le : sam. 24 janv. 2015 18:01
Localisation : Arlon, Belgique
Contact :

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Jean-Marie » mar. 10 mars 2015 16:48

Hello Veloce,

Comment va la grippe ?
J'ai téléchargé ton programme de thermostat mais je suis empêtré dans les flashages d'ESP et je n'ai pas encore eu le temps de l'examiner. Pourtant le sujet m'intéresse. On se verra plus tard sur ton nouveau thread.

___________________________________________________________________________________________________________________________________

Hello smba38,

Je ne suis pas vraiment fier de moi. J'ai téléchargé le nodemcu-flasher, adapté le port COM et ....... cliqué sur Flash!
Du coup, je crois que j'ai chargé LUA et tout ce qui s'en suit avant de me rendre compte que je devais d'abord cliquer sur "Config".
Par après, j'ai essayé de reflasher les commandes AT en modifiant le Config, le Baud Rate,ou en utilisant XTCOM_util.exe
Je n'y suis pas parvenu !

En me résignant, je me dis que ce n'est peut-être pas plus mal de commencer avec Lua. J'ai téléchargé le programme LuaLoader ICI
LuaLoader.jpg
LuaLoader.jpg (130.65 Kio) Vu 3872 fois
Mais je ne sais pas trop quoi faire pour tester que tout fonctionne. Des suggestions ?

smba38
Modérateur
Messages : 193
Enregistré le : mar. 24 févr. 2015 09:28
Localisation : Bourgoin

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par smba38 » mar. 10 mars 2015 18:29

Coucou Jean-Marie

Tu peux revenir facilement sur les commandes AT avec le flasher de nodemcu.
Comme je l’ai indiqué sur mon message précédent, il faut décocher les cases INTERNAL et ajouter une ligne avec le binaire des commandes AT ( offset de 0x00000).

En ce qui concerne Lua, pour charger les programmes dans la mémoire flash j’utilise
« nodemcu studio » à récupérer dans le répertoire tools de
https://drive.google.com/folderview?id= ... sp=sharing

Il existe un site Electrodragon qui cause de nodemcu et de Lua.
http://www.electrodragon.com/w/ESP8266_ ... _Dev_Board

On peut utiliser Lua en ligne de commande ou à partir d’un fichier en mémoire flash.
avec nodemcu studio:
Execute permet d’exécuter le fichier sur lequel le curseur est positionné dans la liste de gauche (il doit au paravent être chargé dans la m mémoire flash avec Download).

Regarde les exemples sur http://nodemcu.com/index_en.html
Essaye dans un premier temps d’afficher par print les valeurs d’un capteur.

Ensuite tu peux essayer les programmes qui dialoguent avec un serveur.
Tu peux utiliser le serveur TCP écrit en python sur raspberry que j’ai posté sur le forum.
Tu peux également essayer le serveur Telnet écrit en Lua pour prendre la main à distance sur l’esp8266 à partir d’un client Telnet s’exécutant sur un PC.

Tu peux également utiliser le serveur TCP en python sur raspberry avec coté client le firmware des commandes AT + Arduino ( pour d’affranchir d’un esp8266 coté serveur).

Bref tu as du pain sur la planche.

N’hésite pas à me demander d’autres informations.

A+
SMBA38.

Veloce
Messages : 79
Enregistré le : sam. 24 janv. 2015 20:12

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Veloce » mar. 10 mars 2015 21:32

Jean-Marie a écrit :Hello Veloce,
Comment va la grippe ?
J'ai téléchargé ton programme de thermostat mais je suis empêtré dans les flashages d'ESP et je n'ai pas encore eu le temps de l'examiner.
Pourtant le sujet m'intéresse. On se verra plus tard sur ton nouveau thread.
C'est sympa, merci. Je me suis bien reposé, mais j'ai encore bien mal au crâne alors je ne suis pas sûr d'aller bosser demain.

Par contre attention c'est toi qui es contagieux: j'ai regardé ta méthode pour faire des circuits imprimés, et
ça ma donné envie de m'y remettre ! :lol:
Je n'en ai pas refait depuis plus de 20 ans, parce qu'on ne trouve plus de machines en libre-service dans les magasins.

Mais allez, trêve de hors-sujet, je vous laisse tranquille :arrow:

Veloce

Avatar du membre
Jean-Marie
Raspinaute
Messages : 240
Enregistré le : sam. 24 janv. 2015 18:01
Localisation : Arlon, Belgique
Contact :

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Jean-Marie » mar. 10 mars 2015 22:02

Hello Veloce,

Si tu as l'envie de te relancer dans les circuits imprimés, j'ai un petit site ICI où j'explique comment je fais (j'avais déjà donné l'adresse ?).
Le plus difficile est de se procurer la lampe UV.
J'ai eu beaucoup de chance avec une lampe à bronzer le visage sur eBay. Il n'y a pas eu d'amateur et je l'ai eue pour 1 €.

Avatar du membre
EVOTk
Modérateur
Messages : 886
Enregistré le : sam. 20 sept. 2014 02:36

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par EVOTk » mar. 10 mars 2015 22:08

Jean-Marie a écrit :Si tu as l'envie de te relancer dans les circuits imprimés, j'ai un petit site ICI où j'explique comment je fais (j'avais déjà donné l'adresse ?).
Salut JM !
Une fois j'ai récupérer une machine a UV qui servait a effacer les EPROMs dans l'optique de m'en servir pour graver mes circuits, pense tu que cela pourrai faire l'affaire ?

Avatar du membre
Jean-Marie
Raspinaute
Messages : 240
Enregistré le : sam. 24 janv. 2015 18:01
Localisation : Arlon, Belgique
Contact :

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Jean-Marie » mar. 10 mars 2015 23:19

Hello EVOTk

Je n'ai jamais eu en main une lampe UV à Eprom, mais l'eprom a une toute petite fenêtre alors que le circuit imprimé peut être large. C'est peut-être la difficulté majeure.

Avatar du membre
Jean-Marie
Raspinaute
Messages : 240
Enregistré le : sam. 24 janv. 2015 18:01
Localisation : Arlon, Belgique
Contact :

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Jean-Marie » mer. 11 mars 2015 20:33

Hello smba38

Hier j'avais essayé de nombreuses fois de repasser en commandes AT, aussi bien avec le NodeMCU Flasher qu'avec XTCOM_util.
Aujourd'hui, en consultant ton lien de NodeMCU_Studio, j'ai vu une version un peu différente du Flasher : le nodemcu_flasher32bit.exe disponible ICI. Je l'ai téléchargée et cette fois j'ai pu repasser sans problème aux commandes AT, version 09.5.
494.jpg
494.jpg (134.16 Kio) Vu 3825 fois
Tant que je ne me sens pas trop à l'étroit avec ces commandes, j'aime autant m'y tenir. Cela m'évite de devoir aborder un langage que je ne connais pas du tout. Il sera toujours temps d'essayer LUA ou MQTT quand je serai plus à l'aise.

En tout cas, merci pour tes précieuses indications.

smba38
Modérateur
Messages : 193
Enregistré le : mar. 24 févr. 2015 09:28
Localisation : Bourgoin

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par smba38 » mer. 11 mars 2015 21:26

Bonsoir Jean-Marie.

Tu dois être soulagé d’être revenu aux commandes AT.

Quel était le symptôme de l’échec du Flashage ?

Il y a toujours des nouvelles versions non officielles des commandes AT.

J’ai vu une version avec la possibilité de récupérer l’heure sur un serveur NTP.

Pour info, tu peux voir les caractères bizarres au reboot en configurant la liaison à 74880 bauds ?.

J’ai commandé sur Ebay des ESP-12
http://www.ebay.fr/itm/171709813851?ssP ... 1497.l2649


Délai de livraison 20 à 40 jours, ils doivent arriver à la nage.
Les modules sont un peu chers, mais ils disposent d’un ADC et ils sont au pas 2.54.
Je ne suis pas comme toi un champion de la soudure.

Ou as-tu acheté tes ESP-XX et à quel prix.

J’ai un peu laissé de coté le développement sur Lua.
Je suis bénévole dans une association sur l’initiation et la formation Informatique.
Dans cette association il y a pas mal de retraités qui ont du mal à maitriser les technologies récentes.
Je prépare actuellement un cours sur les Smartphones.

Je suis tombé par hasard sur cette information.
http://mchobby.be/wiki/index.php?title=ArduPi-I2C

ArduPi permet parait-il d’avoir du code qui tourne sur Arduino et sur Raspberry ?.

Bon courage pour la suite des tes développement.

A+
SMBA38.

Veloce
Messages : 79
Enregistré le : sam. 24 janv. 2015 20:12

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Veloce » mer. 11 mars 2015 22:25

smba38 a écrit : Je suis tombé par hasard sur cette information.
http://mchobby.be/wiki/index.php?title=ArduPi-I2C

ArduPi permet parait-il d’avoir du code qui tourne sur Arduino et sur Raspberry ?.
Heu non, ce n'est pas ce que j'en comprends. On dirait plutôt un modèle où le Raspberry Pi
est relié en réseau par le bus I2C à une batterie d'Arduinos qui commandent chacun des moteurs,
des servos, des capteurs... Plutôt pour les gros projets avec plein d'E/S donc.

Veloce ;)

Avatar du membre
Jean-Marie
Raspinaute
Messages : 240
Enregistré le : sam. 24 janv. 2015 18:01
Localisation : Arlon, Belgique
Contact :

Re: Tous les capteurs reliés au RPI par Wifi avec module ESP

Message par Jean-Marie » mer. 11 mars 2015 23:38

Hello smba38
Tu dois être soulagé d’être revenu aux commandes AT.
Cela fait déjà un bout de temps que je me familiarise avec les commandes AT. Donc, c'est certain que je m'y sens plus à l'aise qu'avec Lua. Le problème est que j'aborde plein de domaines nouveaux en même temps. J'ai démarré le C à l'été dernier. Depuis Noël, je suis confronté au RaspBurry et par la même occasion à Linux et ce n'est pas un mince morceau. Pour compliquer les affaires, je suis tombé il y a un mois sur les ESP. Ceux-ci m'ont embarqué dans le domaine du wifi et du web qui sont des nouveautés pour moi (je veux dire sur le plan de la programmation). Alors, ajouter Lua à tout cela ... il vaudrait mieux attendre et voir si je surnage.
Quel était le symptôme de l’échec du Flashage ?
Normalement, dans le Flasher, après avoir réglé la config, lorsqu'on clique sur "Flash", les adresse AP MAC et STA MAC doivent se remplir et la barre de flashage commence à avancer.
495.jpg
495.jpg (36.26 Kio) Vu 3821 fois
Dans mon cas, les adresses MAC ne se remplissaient pas et la barre de flashage restait noire. La seule chose qui changeait, c'est que le bouton Flash était remplacé par le bouton Stop.
Pour info, tu peux voir les caractères bizarres au reboot en configurant la liaison à 74880 bauds ?.
Voici ce que je vois au reboot à 74880 baud:
496.jpg
496.jpg (29.81 Kio) Vu 3821 fois
Et voici le reboot à 9600 baud:
497.jpg
497.jpg (11.76 Kio) Vu 3821 fois
La suite dans le prochain message car on est limité à 3 photos par message.

Répondre

Retourner vers « Et tout le reste »