Instabilité de mon Wifi !

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
Artemus24
Raspinaute
Messages : 902
Enregistré le : ven. 15 sept. 2017 19:15

Instabilité de mon Wifi !

Message par Artemus24 » sam. 30 avr. 2022 19:08

Salut à tous.

J'utilise Bullseye et depuis que j'ai basculé dans cet OS, je constate que j'ai beaucoup d'instabilité avec mon WIFI.
Cela se traduit par des ralentissements que je trouve pénible, mais aussi des pertes de connexions.

Pour remédier à cela, j'utilise l'astuce suivante.
J'ai mis dans mon fichier "/boot/cmdline.txt", en fin de ligne "ip=169.254.1.1".
Je branche un câble ethernet entre ma Raspberry Pi 4B et mon ordinateur Windows.
J'utilise Putty avec cette adresse IP, et j'ai un très haut niveau de vitesse et de stabilité.
Je peux mettre à jour ma Raspberry car j'ai encore l'accès par le WIFI, même si celle-ci est instable.

Par contre, je n'ai plus le WIFI de mon ordinateur, mais cela ne me dérange pas car je fais du développement.

Voici mes questions :

a) avez-vous des problèmes d'instabilités avec le WIFI ?

b) est-ce avec la version Bullseye ?

c) en avez-vous eu avec les autres version OS de la Raspberry ?

d) avez-vous trouvé la solution pour rendre cette instabilté moins importante ?

J'ai repris la configuration de mon fichier wpa_supplicant.conf que j'ai complété par quelques paramètres qui à mon avis sont sans effet sur la stabilté.
J'envisage de changer le paramétrage de ma box SFR ainsi que celui de mes Raspberry Pi, sauf que je ne sais pas comment procéder.
Je veux dire, comment obtenir une stabilité optimale en foonction de l'un et de l'aute.

Y-a-t-il des lignes à rajouter dans le fichier "/boot/config.txt" pour résoudre, même partiellement, ce problème ?

D'autant que, je me suis aperçu que ces problèmes d'instabilités sont apparus avec un changement de version de ma BOX SFR.
Il se touve que je suis encore en ADSL et que SFR aimerai que je bascule vers la fibre optique (FTTH).
Je ne sais pas si c'est lié, mais en tout cas, je ne dispose plus du bon fonctionnement du serveur DHCPv4.
Je n'arrive plus à obtenur des adresses fixes ipv4 de ma BOX SFR, à partir des adresses MAC que j'ai entrées.
Il semble que cela fonctionne encore avec l'ipv6. Je ne sais pas si c'est un bug de cette mise à jour.
SFR me dit qu'il existe un problème de compatibilité entre ces adresses.
Comme à leur habitude, ils ne savent rien.

Cordialement.
Artemus24.
@+
--> RPI4B/8GB + Argon FanHAt
--> Rpi3A+, Rpi3B+
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT

piper
Raspinaute
Messages : 343
Enregistré le : sam. 5 juin 2021 18:57

Re: Instabilité de mon Wifi !

Message par piper » sam. 30 avr. 2022 19:19

OUi j'ai des instabillité de wifi mais sur tous mes OS : Windows 10 et 11 , Fedora 35, BullsEye et Buster donc ça vient nécessairement de ma box.
Pour BullsEye, pas de soucis ormis que c'est une usine à gaz qui ralentit durement mes Pi dans les étapes qui exigent du CPU et de la mémoire.
1 Pi 4 Emby / Samba
1 Pi4 Librelec
1 Pi3 / Hifiberry OSMC
1 Pi0 : traker GPS et acquisitions de données moteur automobile
1 Pi 2 : pilotage de serrures / RFID
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

Artemus24
Raspinaute
Messages : 902
Enregistré le : ven. 15 sept. 2017 19:15

Re: Instabilité de mon Wifi !

Message par Artemus24 » sam. 30 avr. 2022 19:51

J'ai oublié de préciser que l'instabilité que j'aie, n'apparait que sur mes raspberry Pi, pas sous windows.
--> RPI4B/8GB + Argon FanHAt
--> Rpi3A+, Rpi3B+
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT

Artemus24
Raspinaute
Messages : 902
Enregistré le : ven. 15 sept. 2017 19:15

Re: Instabilité de mon Wifi !

Message par Artemus24 » dim. 1 mai 2022 20:27

Salut à tous.

En cherchant sur le net, il est conseillé en 2,4GHz d'utiliser les canaux 1, 6 et 11.
Comme je n'ai pas le 5GHz, je suis obligé de faire avec. J'ai le canal 7.
J'étais déjà le seul dans mon quartier à utliser le canal 7. Du coup, je passe au canal 6.
J'évite d'utiliser les canaux 1 et 11 car ils sont déjà pris par mes voisins.
Je n'ai plus les ralentissements avec ma Raspberry Pi 4B. C'est un mieux.

Je fais le test avec ma Raspberry Pi 3A+, et j'ai toujours le même problème.
La connexion est tellement longue à arriver qu'elle finit par être coupée.
La led verte clignote normalement, ce qui signifie que qu'elle fonctionne.
Je ne comprends pas pourquoi je n'arrive pas à entrer dans ma Raspberry Pi 3A+.
Je rappelle que j'utilise le même disque USB pour me connecter avec ma RPi AB et ma RPi 3B+.

Cordialement.
Artemus24.
@+
--> RPI4B/8GB + Argon FanHAt
--> Rpi3A+, Rpi3B+
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT

Répondre

Retourner vers « Utilisateurs avancés »