Owncloud

Photographie ultra-rapide, pilotage d'imprimante 3D ou de CNC, fabrication de bière.... Enfin tout ce que le Raspberry peut gérer trouvera sa place dans cette rubrique

Modérateur : Francois

Avatar du membre
Aradia
Messages : 56
Enregistré le : jeu. 18 sept. 2014 10:35
Localisation : Ile de France

Owncloud

Message par Aradia » sam. 18 oct. 2014 23:56

Bonsoir,
j'ouvre ce topic , car suite à ma tentative d'installer Owncloud grâce au tuto de Benjamin ( que je remercie au passage pour nous lavoir fait partager ), j'ai l'erreur suivante quant je tente de créer le compte :

Code : Tout sélectionner

Le répertoire (/storage/mon_disque/owncloud) est invalide

Veuillez vérifier que le répertoire de données contient un fichier ".ocdata" à sa racine.
J'ai refait l'installe 4 fois et toujours cette erreur, et en effet dans le répertoire /storage/mon_disque il n'y a pas de dossier owncloud ni de fichier .ocdata.
J'ai donc créé le dossier owncloud et le fichier .ocdata vide, toujours pas de changement.
voilà si quelqu'un à déjà suivi le tuto et réaliser sont cloud avec succès peux me dire comment résoudre ce problème.
merci d'avance et bon weekend.

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Owncloud

Message par vague nerd » dim. 19 oct. 2014 02:47

Bonsoir.
A l'étape 7 et 8, si vous avez remplacé mon_disque par quelque chose, il faut que ce quelque chose soit identique aux deux endroits.
Avez vous modifié /etc/fstab ? Avez-vous bien remplacé votre_UUID par l'UUID récupéré à l'étape 6 ?
Cdt.
Cordialement,

Vague Nerd

Avatar du membre
Aradia
Messages : 56
Enregistré le : jeu. 18 sept. 2014 10:35
Localisation : Ile de France

Re: Owncloud

Message par Aradia » dim. 19 oct. 2014 17:20

salut,
- l'étape 7 et 8 j'ai laissé "mon_disque" afin de me facilité les chose pour apprendre au mieux l’installation.
- l'étape 8 dans le fichier "nano /etc/fstab" j'ai ajouté la ligne avec l'UUID de ma clef usb qui est 5d18be51-3217-4679-9c72-a54e0fc53d6b ce qui me donne :

Code : Tout sélectionner

5d18be51-3217-4679-9c72-a54e0fc53d6b    /storage/mon_disque    ntfs-3g    suid,dev,auto,async,gid=1004,umask=007    0    2
voilà en espèrent que ces info vous aiderons à m'aider. ^^

domi
Administrateur
Messages : 2733
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Owncloud

Message par domi » dim. 19 oct. 2014 17:34

Bonjour,

Est-ce que le dossier "/storage/mon_disque" existe bien ?
Même sans la clé connectée, le dossier doit exister car c'est le point de montage de la clé.
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

Avatar du membre
Aradia
Messages : 56
Enregistré le : jeu. 18 sept. 2014 10:35
Localisation : Ile de France

Re: Owncloud

Message par Aradia » dim. 19 oct. 2014 17:38

oui j'ai contrôler le dossier "/storage/mon_disque" existe bien, mais dans ce dossier il ni le dossier Owncloud ni le fichier .ocdata

domi
Administrateur
Messages : 2733
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Owncloud

Message par domi » lun. 20 oct. 2014 08:09

Aradia a écrit :oui j'ai contrôler le dossier "/storage/mon_disque" existe bien, mais dans ce dossier il ni le dossier Owncloud ni le fichier .ocdata
"/storage/mon_disque" étant ton point de montage, une fois ton unité disque extérieure de connectée, tu dois créer le dossier "owncloud"

Avant de créer le dossier, vérifie avec la commande "mount" que ton disque externe est bien monté.

Si tout est bon, il faut lancer owncloud, je pense que c'est lui qui va te créer le fichier .ocdata
Attention, vu que le nom du fichier commence par un point, c'est un fichier caché
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

Avatar du membre
Aradia
Messages : 56
Enregistré le : jeu. 18 sept. 2014 10:35
Localisation : Ile de France

Re: Owncloud

Message par Aradia » lun. 20 oct. 2014 20:24

Quant je tape le commande "mount" cela me donne :

Code : Tout sélectionner

/dev/root on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=219764k,nr_inodes=54941,mode=755)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=44788k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=89560k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
à vrais dire je ne comprend pas trop ce resultat, et après tentative de connections j’obtiens :

Code : Tout sélectionner

    Le répertoire (/storage/mon_disque/owncloud) est invalide
    Veuillez vérifier que le répertoire de données contient un fichier ".ocdata" à sa racine.
    Le répertoire (/storage/mon_disque/owncloud) est lisible par les autres utilisateurs
    Veuillez changer les permissions du répertoire en mode 0770 afin que son contenu puisse être listé par les autres utilisateurs.
pourtant j'ai fait :

Code : Tout sélectionner

cd /storage/mon_disque
chmod 777 owncloud
enfin avec la commande "ls" dans le répertoire "/storage/mon_disque/owncloud" je ne vois pas de fichier ".ocdata"
Mais je me pose la question de si quelqu'un à réussi de faire le tuto .

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Owncloud

Message par vague nerd » lun. 20 oct. 2014 21:23

Code : Tout sélectionner

ls -las
permet de visualiser aussi les fichiers cachés (commencant par un ".").

Sinon, à priori, le montage n'a pas fonctionné....
Cordialement,

Vague Nerd

domi
Administrateur
Messages : 2733
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Owncloud

Message par domi » mar. 21 oct. 2014 08:08

Bonjour,

Suivant tes informations, la commande "mount" confirme que le disque externe n'est pas monté.
Il faut commencer déjà par résoudre ce problème, car tu ne peux pas écrire sur un disque qui n'est pas visible.
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

Avatar du membre
Aradia
Messages : 56
Enregistré le : jeu. 18 sept. 2014 10:35
Localisation : Ile de France

Re: Owncloud

Message par Aradia » mar. 21 oct. 2014 09:42

en effet domi, je suis bien d’acore avec toi. Et je pense que le problème de tout ça, viens de la ligne que j'ai rentré dans la table de montage :

Code : Tout sélectionner

5d18be51-3217-4679-9c72-a54e0fc53d6b    /storage/mon_disque    ntfs-3g    suid,dev,auto,async,gid=1004,umask=007    0    2
mais là encore j'ai peux de connaissance sur ce quelle signifie, je suis donc incapable de voir se qui cloche.

Répondre

Retourner vers « Les applications spécialisées du Raspberry Pi »