Accès serveur en IPV6

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Répondre
Thierry71
Messages : 3
Enregistré le : sam. 12 déc. 2015 09:38

Accès serveur en IPV6

Message par Thierry71 » sam. 8 janv. 2022 07:58

Bonjour,

J'avoue ne pas être trop souvent sur le forum mais je sèche en espérant que quelqu'un puisse m'aider.
J'ai monté un serveur web WORDPRESS sur un PI4 sur mon réseau local. Tout va bien. J'ai installé un SSL . Tout va bien.
Tout cela est connecté derrière une Freebox Delta avec utilisation de DNS fournit avec Free. Tout va bien
J'ai routé les ports . Tout va bien.
Vous me direz, alors, il nous veut quoi. ET bien voilà.
L'accès avec un PC depuis l’extérieur fonctionne parfaitement bien aussi bien en HTTP que HTTPS: J'ai d'ailleurs forcé automatiquement la bascule.
MAIS en utilisant une connexion 4G via un téléphone, cela ne fonctionne pas automatiquement en fonction des téléphones et des fournisseurs de téléphonie.
J'ai donc cherché pourquoi et trouvé la réponse :
-Cela dépend de la manière dont le téléphone et aussi le fournisseur se connecte sur le WEB via APN ( IPV4 ou IPV6 ). Bien sur il n'y a rien de standard et certains téléphones
permettent de forcer le mode IPV4 via la configuration APN et d'autres ne le permettent pas ( IPHONE par exemple )

Donc je cherche une solution via probablement une configuration du serveur APACHE ou bien du Raspi OS pour solutionner mon problème .
Voilà, je peux faire des NTATs ou autre print de config si une âme charitable pouvait m'aider car je sèche complètement. J'ai essayé plein de trucs en modifiant les écoutes de ports mais je tourne en rond sans résoudre mon pb.


Merci beaucoup et tous mes voeux

mike913
Raspinaute
Messages : 216
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Accès serveur en IPV6

Message par mike913 » sam. 8 janv. 2022 08:49

Bonjour
pour accéder à ton site tu utilises un nom de domaine ?
Si oui est-ce que tu as un enregistrement AAAA ?
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

piper
Raspinaute
Messages : 240
Enregistré le : sam. 5 juin 2021 18:57

Re: Accès serveur en IPV6

Message par piper » sam. 8 janv. 2022 10:01

Mike a raison.
Il faut que ton nom de domaine ait un enregidtrement de type A pour la liaison vers ton ipv4 et un autre de type AAAA vers ton ipv6

Il faut aussi que ta box accepte l'ipv6

Autre solution : forcer l'usage de l'ipv4 uniquement. (Aucun enregistrement AAAA)
J'utilise les 2 solutions pour 2 usages differents, les 2 fonctionnent.

Tu peux faire de l'exterieur avec un tel (via une appli) des ping ipv4 et ipv6 vers ton nom de domaine pour voir si tu arrives bien vers ton ip publique 4 et 6

Envoyé de mon SM-J710F en utilisant Tapatalk

1 Pi 4 Emby / Samba
1 Pi4 Librelec
1 Pi3 / Hifiberry OSMC
1 Pi0 : traker GPS et acquisitions de données moteur automobile
1 Pi 2 : pilotage de serrures / RFID
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

maxty01
Modérateur
Messages : 769
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Accès serveur en IPV6

Message par maxty01 » sam. 8 janv. 2022 14:16

Bonjour à Tous,

Attention que durant mes labos sur l'IPv6, j'ai remarqué que tous mes Android Samsung (pas testé sur IPhone) ne prenaient pas en compte l'IPv6 correctement et la connectivité reste majoritairement en IPv4.
Bien que les Android aient une IPv6 Local-Link (FE80::/10) lorsque ceux-ci sont connectés à mon réseau, je n'ai jamais vu une seule fois une IPv6 Locale (FC00::/7) sur mes Android, ni sur mon dhcpv6
Aussi, je n'ai jamais vu une seule fois une IPv6 Globale (2001::/16) sur mes téléphones lorsque ceux-ci sont en connecté en 4G (en Belgique).

C'est en tout la constatation que j'ai fait durant mes labos et je ne connais pas la raison de ce comportement car je n'ai pas cherché plus loin (pas pertinent pour mes labos).

J'ai remarqué ce comportement sur des Android vieux et récents, cependant ce sont tous des Samsung (possible liens ?).
Tous mes autres équipements (Linux, Windows) sont bien passé en IPv6 comme prévu.
Aussi, j'utilise des IPv6 locales (FC00::/7) dans mes réseaux, distribuées par un DHCPv6 et RADV gère la partie Gateway, le tout concentré sur mon OPNSense.

Donc, je ne me suis pas concentré sur cette problématique spécifique, il est donc possible que mon constat ne soit totalement correct, cependant, cela reste interpelant.

Bonne journée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

piper
Raspinaute
Messages : 240
Enregistré le : sam. 5 juin 2021 18:57

Re: Accès serveur en IPV6

Message par piper » sam. 8 janv. 2022 14:43

En fait, il s'agit plutôt d'une problématique de fournisseurs d'accès qui sont en retard grave sur la migration vers l'ipv6.
D'après ce qui avait été prévu, nous devrions aujourd'hui être tous en ipv6, à minima pour la connectivité internet

Les soft sont prêts depuis des lustres, l'immense majorité des terminaux aussi, le problème est dans l'architecture des fournisseurs d'accès.

Donc tu prends 2 smartphone identiques avec 2 FAI différents, l'un sera en ipv4, l'autre en ipv6. (Mon samsung est en ipv6 sur Paris et en ipv4 dans le cotentin et il n'était qu'en ipv4 lorsque mon FAI était Syma)

Bref encore aujourd'hui, seul l'ipv4 marche de bout en bout à coup sûr.

Le baromètre de la transition :
https://www.arcep.fr/cartes-et-donnees/ ... rance.html
Modifié en dernier par piper le sam. 8 janv. 2022 14:45, modifié 1 fois.
1 Pi 4 Emby / Samba
1 Pi4 Librelec
1 Pi3 / Hifiberry OSMC
1 Pi0 : traker GPS et acquisitions de données moteur automobile
1 Pi 2 : pilotage de serrures / RFID
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

mike913
Raspinaute
Messages : 216
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Accès serveur en IPV6

Message par mike913 » sam. 8 janv. 2022 14:45

avec un xiaomi et android 11, je me connecte en IPV6 sur mon site.
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Artemus24
Raspinaute
Messages : 865
Enregistré le : ven. 15 sept. 2017 19:15

Re: Accès serveur en IPV6

Message par Artemus24 » sam. 8 janv. 2022 17:19

Salut à tous.
Thierry71 a écrit :J'ai installé un SSL . Tout va bien.
Il faudrait être un peu plus précis. Utilisez-vous un certificat Let's Encrypt ?
Thierry71 a écrit :L'accès avec un PC depuis l’extérieur fonctionne parfaitement bien aussi bien en HTTP que HTTPS: J'ai d'ailleurs forcé automatiquement la bascule.
Si vous pouvez depuis l'internet accéder à votre WordPress aussi bien en IPv4 qu'en IPv6, ainsi qu'en HTTP et en HTTPS depuis un ordinateur, le problème ne vient pas de ce que vous avez configuré.

Vous n'avez pas expliqué comment l'accès se fait à votre site WordPress ?
Par l'adresse IP ou par une url dont vous avez acheté un nom de domaine ?
A priori, le problème ne vient pas de ce que vous avez configuré actuellement.
Thierry71 a écrit :MAIS en utilisant une connexion 4G via un téléphone, cela ne fonctionne pas automatiquement en fonction des téléphones et des fournisseurs de téléphonie.
D'après ce que j'ai compris, votre site WordPress se trouve derrière une Freebox Delta qui est relié à l'internet. Vous ne passez pas par un routeur 4G.
Avez-vous une adresse fixe ou dynamique dans votre FreeBox ?

Depuis votre téléphone, pouvez-vous atteindre votre site WordPress en faisant des ping aussi bien en ipv4 et en ipv6 ?

Comme votre question concerne l'IPv6 depuis un mobile phone, genre androïde, il se peut que le problème réside soit dans la compatibilité des IPv6 ou plus simplement, votre téléphone ne sait pas gérer l'IPv6 natif.

Dans le cas d'une adresse commençant par "2001:", il se peut comme chez Hurricane Electric que l'IPv6 soit encapsulé par de l'IPv4.
Il s'agit du protocole "6in4" et vous devez activer dans votre box, le protocole 41.
Il se peut (à vérifier) que votre freebox ne sache pas gérer ce protocole 41.

Pour que votre téléphone puisse gérer l'IPv4 et l'IPv6, il doit être dual-stack, c'est-à-dire double pile.
--> Comment activer IPv6 sur son mobile ?.

Cordialement.
Artemus24.
@+
--> RPI4B/8GB + Argon FanHAt
--> Rpi3A+, Rpi3B+
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT

piper
Raspinaute
Messages : 240
Enregistré le : sam. 5 juin 2021 18:57

Re: Accès serveur en IPV6

Message par piper » sam. 8 janv. 2022 19:27

A faire à partir d'un terminal dont vous savez qu'il a accès internet via ipv6

Code : Tout sélectionner

ping -6 votrenomdedomaine
Si vous obtenez :
connect: Ne peut attribuer l'adresse demandée
C'est que ce terminal ne peut pas utiliser l'ipv6 pour les connexions à distance (pas équipé ou ipv6 désactivée soit sur le terminal soit sur la box, soit sur l'infrastructure extérieur)

Si vous obtenez :
La requête Ping n’a pas pu trouver l’hôte votrenomdedomaine. Vérifiez le nom et essayez à nouveau.
C'est que nous n'avez pas mis d'enregistrement AAAA dans votre zone DNS qui pointe vers l'ipv6 public de votre serveur wordpress
1 Pi 4 Emby / Samba
1 Pi4 Librelec
1 Pi3 / Hifiberry OSMC
1 Pi0 : traker GPS et acquisitions de données moteur automobile
1 Pi 2 : pilotage de serrures / RFID
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

Artemus24
Raspinaute
Messages : 865
Enregistré le : ven. 15 sept. 2017 19:15

Re: Accès serveur en IPV6

Message par Artemus24 » sam. 8 janv. 2022 19:44

Salut à tous.

Pour tester les accès à votre WordPress, utilisez ceci : "IPv6-test.com".

Cordialement.
Artemus24.
@+
--> RPI4B/8GB + Argon FanHAt
--> Rpi3A+, Rpi3B+
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT

maxty01
Modérateur
Messages : 769
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Accès serveur en IPV6

Message par maxty01 » sam. 8 janv. 2022 23:23

Bonsoir Artemus24, piper,

Dois-je vous rappeler que le user à aider est Thierry71.

De plus, une série de questions et de remarques ont déjà été formulées.

Je vous demanderai donc de ne pas polluer plus ce post et de laisser Thierry71 revenir vers nous avec plus d'informations afin de résoudre son problème.

Si vous souhaitez continuer votre discussion, je vous invite à le faire dans un autre post.

Bonne soirée
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »