problème de démarrage avec un ssd

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

Répondre
jlr91
Messages : 8
Enregistré le : jeu. 14 janv. 2021 14:56

problème de démarrage avec un ssd

Message par jlr91 » mer. 20 janv. 2021 11:54

Bonjour,
Je n'arrive pas à démarrer mon rpi du ssd.
J'ai mis raspberry Pi OS sur le SSD via Raspberry Pi Imager.
J'ai mis le boot sur ssd via raspi-config.
Quand je boote avec la carte SD, il voit bien le ssd. J'ai 2 partitions sur le bureau mais quand je boote directement sur le SSD sans la carte dans le RPI, je n'ai qu'une suite de messages d'erreurs.
J'avais mis à jour l'eeprom.
J'espère que j'ai été assez clair dans l'explication.
Que dois-je faire ?
Merci
Jean-Luc

dyox
Raspinaute
Messages : 864
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: problème de démarrage avec un ssd

Message par dyox » mer. 20 janv. 2021 13:34

Bonjour,
Que dois-je faire ?
Déjà vérifier si l'adaptateur est compatible. Voir dans ma signature.

Et nous préciser le modèle d'adaptateur. Il y a déjà eu des cas sur le forum.

jlr91
Messages : 8
Enregistré le : jeu. 14 janv. 2021 14:56

Re: problème de démarrage avec un ssd

Message par jlr91 » mer. 20 janv. 2021 14:06

J'ai dû rater quelque chose. Je ne comprends pas de quel adaptateur il s'agit. Mon ssd est relié à une entrée usb 3.0 par l'intermédiaire d'un câble avec le ssd dans un boitier.

jlr91
Messages : 8
Enregistré le : jeu. 14 janv. 2021 14:56

Re: problème de démarrage avec un ssd

Message par jlr91 » mer. 20 janv. 2021 14:22

OK. Vu. Toutes mes excuses.
J'ai un boitier orico et j'ai vu grâce aux liens que tu m'as donné, qu'aucun n'est compatible.
Merci.

dyox
Raspinaute
Messages : 864
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: problème de démarrage avec un ssd

Message par dyox » mer. 20 janv. 2021 14:33

Quand je parlais d'adaptateur, je parlais du boitier mais cela peut être seulement une prise, comme je ne le savais pas.

La compatibilité se fait avec la marque du soc qui fait la conversion SATA3 -> USB3 ; s'il y a bien les drivers présents dans le noyau linux. Je dirai qu'ils y sont tous mais certains sont plus compatibles que d'autres d'où l'intérêt de connaitre la marque / modèle de l'adapteur et comme c'est une question récurrente, j'ai mis un lien.

Je pars bien sûr du postulat que tout est bon en amont (gravure, firmware, alim...)

EDIT : Tu as réécrit un post.
Effectivement, les Orico sont à bannir.

Drum22
Messages : 19
Enregistré le : mar. 1 juin 2021 19:45

Re: problème de démarrage avec un ssd

Message par Drum22 » ven. 4 juin 2021 13:57

Bonjour,
comment connaitre les adaptateurs compatibles avec RP4 ?
A court terme, (en fonction de mes "progres"... :? ) je comptais booter sur un disque SSD (et surtout... ne plus travailler sur la SD !!)
Comme connecteur, je dispose d un
- Inateck Adaptateur USB 3.0 vers IDE/SATA, Convertisseur pour 2.5"/ 3.5" HDD/SSD Disque Dur, Un Secteur d’Alimentation 12V/2A et Un câble USB 3.0 Inclus et
- en commande : Un disque SSD Crucial 240 Go.
c est jouable ou pas ?
sinon quoi donc acheter ?
a++

Artemus24
Raspinaute
Messages : 770
Enregistré le : ven. 15 sept. 2017 19:15

Re: problème de démarrage avec un ssd

Message par Artemus24 » dim. 6 juin 2021 00:15

Salut Drum22.

Je possède ces adaptateurs "inateck" :
--> https://www.inateck.com/products/sata-t ... ded-ua1001
--> https://www.inateck.com/products/sata-t ... ssd-ua1002
et je n'ai aucun problème avec.

Je possède aussi un disque western digital green 120G SSD où se trouve buster.

C'est une solution légère que j'ai adopté pour mes raspberry, suite à une conversation dans ce forum.

@+
--> RPI4B/8GB + Argon FanHAt
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

Drum22
Messages : 19
Enregistré le : mar. 1 juin 2021 19:45

Re: problème de démarrage avec un ssd

Message par Drum22 » dim. 6 juin 2021 10:14

Merci Artemus24 pour l information sur les adaptateurs Inateck ;)
Je suis en train de voir des tutos sur "booter directement sur un SSD" (pour utiliser mon Crucial 240 Go) mais pour le debutant, ca fait pas mal flipper.
Pour certains, il faut passer en mode UnSafe ! :o
Difficile aussi de trouver "la" procedure qui permettrait le changement de support bootable. Je lis que les cartes SD "finissent mal en general" comme diraient les Rita Mitsouko :lol: :lol: et pourtant, il semblerait que le changement sur un disque soit tout de meme la solution ideale, non ?

Quant a Buster, c est le nouvel OS ? pour le debutant, c est un peu complique toutes ces versions disponibles. :?
Est ce vraiment necessaire de changer selon l axiome : " Le Mieux est l ennemi du Bien" ?

C est comme dans le choix de nouveaux logiciels ... pour un mot clef donne, le debutant se trouve ou se retrouve avec une palanquee de packages ! effarant !! ;)
bon ! je vais continuer tout doucettement mon apprentissage... le chemin va etre long je pense !! et surtout... jonche d erreurs :lol: :lol:
a++

Drum22
Messages : 19
Enregistré le : mar. 1 juin 2021 19:45

Re: problème de démarrage avec un ssd

Message par Drum22 » lun. 7 juin 2021 12:54

Drum22 a écrit :
ven. 4 juin 2021 13:57
.../...
Comme connecteur, je dispose d un
- Inateck Adaptateur USB 3.0 vers IDE/SATA, Convertisseur pour 2.5"/ 3.5" HDD/SSD Disque Dur, Un Secteur d’Alimentation 12V/2A et Un câble USB 3.0 Inclus et
- en commande : Un disque SSD Crucial 240 Go.
.../...
bonjour
je ne sais pas ou en est @Jean-Luc ;)
en tous les cas, avec les elements ci-dessus, le "passage" par SSD est super concluant !! :D
trop content ... cette micro carte SD ne m inspirait vraiment pas du tout confiance avec son p'tit air... super fragile !!! :?
a++

Répondre

Retourner vers « Raspbian »