Pygame 2 sur Raspberry Buster

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

Répondre
JfNg
Messages : 4
Enregistré le : mar. 14 déc. 2021 13:22

Pygame 2 sur Raspberry Buster

Message par JfNg » mar. 14 déc. 2021 13:25

Bonjour,

Je cherche à installer Pygame 2 sur un Raspberry Buster. J’utilise la version 5.10.11 de l’OS.

Visiblement il faut mettre à jour le SDL pour qu’il soit compatible avec Pygame 2.

Quelqu’un connaitrait-il le process de mise à jour du Raspberry pour que Pygame 2 fonctionne ?

Grand merci par avance

piper
Raspinaute
Messages : 240
Enregistré le : sam. 5 juin 2021 18:57

Re: Pygame 2 sur Raspberry Buster

Message par piper » mer. 15 déc. 2021 00:16

Bonsoir
Apparemment, sur buster pour le Pi4, il y a un paquet :

Code : Tout sélectionner

sudo apt-get install libsdl2-2.0-0

C'est en tout cas ce qui est dit ici :
https://discourse.libsdl.org/t/compile- ... 11/27221/3

Mais Pygame 2.0 support encore SDL1, en plus de SDL2. SDL1 est abandonné à partir de pygame 2.1
1 Pi 4 Emby / Samba
1 Pi4 Librelec
1 Pi3 / Hifiberry OSMC
1 Pi0 : traker GPS et acquisitions de données moteur automobile
1 Pi 2 : pilotage de serrures / RFID
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

JfNg
Messages : 4
Enregistré le : mar. 14 déc. 2021 13:22

Re: Pygame 2 sur Raspberry Buster

Message par JfNg » jeu. 16 déc. 2021 17:24

Oui, je voulais dire Pygame2 et les suivants. L'idée est d'utiliser une librairie graphique plus récente que SDL1.

Par contre, je ne suis pas sûr que libsdl2-2.0-0 suffise. Il y a pas mal de librairies intégrées à Pygame. Je voudrai être sûr d'une installation propre de Pygame2 qui charge toutes les bonnes dépendances.

Pour l'instant, en installant Pygame avec un simple "pip install --upgrade pygame" ça ne fonctionne pas. Rien ne se lance et pas de message d'erreur...

piper
Raspinaute
Messages : 240
Enregistré le : sam. 5 juin 2021 18:57

Re: Pygame 2 sur Raspberry Buster

Message par piper » lun. 20 déc. 2021 20:18

Tu as regardé si pip lance pip pour python 2.x ou pip pour phyton 3.x ?
Me suis déjà fait avoir (une appli dont les codes python contenait un entête spécifiant python3 alors que j'avais python2 par défaut et que donc pip avait installé les bibliothèques pour python2 et pas python3)
si tu lances pip --version tu le sauras

Actuellement on est dans une situation sur Linux un peu bancale :
On se retrouve avec 2 version de python : une 2.x et une 3.x
Une seule est lancée par défaut , c'est souvent python2.x quand on lance python ou pip (sauf version récente de Fedora ou là, c'est python3.x)

La faute a de très grosses différences entre python2.x et python3.x , que ne nombreuses applis sous linux sont en python que que tous n'ont pas migré leurs sources vers python3.
1 Pi 4 Emby / Samba
1 Pi4 Librelec
1 Pi3 / Hifiberry OSMC
1 Pi0 : traker GPS et acquisitions de données moteur automobile
1 Pi 2 : pilotage de serrures / RFID
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

JfNg
Messages : 4
Enregistré le : mar. 14 déc. 2021 13:22

Re: Pygame 2 sur Raspberry Buster

Message par JfNg » mar. 21 déc. 2021 18:31

Oui, je lance pip avec python3. Je fais : python3 -m pip install SomePackage
Je me suis fait avoir aussi au début.
Je vais essayer une installation de sdl2 avec apt-get dès que j'ai une minute.

JfNg
Messages : 4
Enregistré le : mar. 14 déc. 2021 13:22

Re: Pygame 2 sur Raspberry Buster

Message par JfNg » mer. 22 déc. 2021 21:24

Finalement, j'ai réussi à installer SDL2 et Pygame 2.

Mon code tourne mais il est terriblement lent. J'ai essayé de l'optimiser. Ça ne change rien. Ça ne vient pas de là. Par contre, si je reviens à Pygame 1.9.6, le jeu retrouve sa vitesse normale.

J'ai abandonné. Je pense que Pygame 2 n'est pas fait pour un Raspberry 3. :(

Répondre

Retourner vers « Raspbian »