résolution écran 2K  [RESOLU]

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
DLPrasp
Messages : 4
Enregistré le : sam. 11 janv. 2020 18:30

résolution écran 2K

Message par DLPrasp » sam. 11 janv. 2020 18:41

Bonjour,

Lorsque je connecte mon écran 2K 8,9" (caractéristiques : https://fr.aliexpress.com/item/32875066 ... 6c37RZvvA5) à mon Raspberry pi 3 en HDMI, il le détecte mais l'affichage est totalement buggé... En fait mon écran se divise en 3 parties coupées dans le sens horizontale et entre chaque partie il y a une bande large noire. Aussi l'affichage au milieu de l'écran est comme étiré. J'aimerais mettre une photo pour vous montrer mais je ne sais pas comment faire.

Le problème ne vient pas du système d'exploitation (Raspbian) car l'écran ne fonctionne sur aucun système que j'ai pu tester. Et lorsque que je connecte l'écran en hdmi à un pc l'affichage se fait correctement.

Je n'ai aucune idée de comment améliorer ceci, en avez-vous ?
Merci !

dyox
Raspinaute
Messages : 682
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: résolution écran 2K

Message par dyox » sam. 11 janv. 2020 20:19


DLPrasp
Messages : 4
Enregistré le : sam. 11 janv. 2020 18:30

Re: résolution écran 2K

Message par DLPrasp » sam. 11 janv. 2020 22:09

Bonsoir,

j'ai modifier mon fichier config.txt sur ces deux lignes :

hdmi_group=2
hdmi_mode=76

ce qui correspond à un écran 2560*1600 mais je ne trouve pas la bonne fréquence dans le tableau, mon écran fonctionne en 50Hz et le tableau va de 60Hz à 120Hz.
L’affichage est tout de même mieux, il est encore coupé mais en 2 et une petite partie est visible en bas. Seulement il reste toujours cette grosse bande noire au milieux et l'écran y est toujours étiré. De plus maintenant l'affichage tremble légèrement.

DLPrasp
Messages : 4
Enregistré le : sam. 11 janv. 2020 18:30

Re: résolution écran 2K  [RESOLU]

Message par DLPrasp » dim. 12 janv. 2020 19:44

Problème résolu !

J'ai contacté le vendeur de l'écran qui m'a fournit le fichier config.txt !

merci de votre aide

dyox
Raspinaute
Messages : 682
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: résolution écran 2K

Message par dyox » dim. 12 janv. 2020 19:48

Ok et c'est quoi dans ce cas les bons paramètres ?

DLPrasp
Messages : 4
Enregistré le : sam. 11 janv. 2020 18:30

Re: résolution écran 2K

Message par DLPrasp » dim. 12 janv. 2020 23:19

les voilà :

# For more options and information see
# http://www.raspberrypi.org/documentatio ... fig-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

hdmi_pixel_freq_limit=300000000
hdmi_timings=2560 0 123 10 50 1600 0 12 4 4 0 0 0 55 0 222183000 0
hdmi_drive=2
disable_overscan=1
max_framebuffer_width=2560
max_framebuffer_height=2560


display_rotate=0
framebuffer_width=2560
framebuffer_height=1600


# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem=128

Répondre

Retourner vers « En panne ? »