GatewayPorts plantent le service

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Avatar du membre
thierryR
Messages : 46
Enregistré le : dim. 27 déc. 2015 21:45
Localisation : Chalons en Champagne

GatewayPorts plantent le service

Message par thierryR » lun. 19 juil. 2021 18:51

Bonjour. J'ai ajouté 2 lignes qui me paraissent normale à sshd_config

Code : Tout sélectionner

GatewayPorts yes 
ClientAliveInterval 30
En voulant relancer le service j'ai cette erreur:

Code : Tout sélectionner

-- The unit ssh.service has entered the 'failed' state with result 'exit-code'.
juil. 19 18:45:28 raspi-serveur systemd[1]: Failed to start OpenBSD Secure Shell server.
-- Subject: L'unité (unit) ssh.service a échoué
-- Defined-By: systemd
-- Support: https://www.debian.org/support
Pourtant il me semble ne rien avoir fait d'anormal ? Je ne comprends pas.

EDIT: En fait c'est la 1ere ligne qui plante le bazar. (GatewayPorts yes)

dyox
Raspinaute
Messages : 882
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: GatewayPorts plantent le service

Message par dyox » lun. 19 juil. 2021 19:08

Bonjour,
C'est sshd.service pour relancer la config de sshd_config.
Sinon pas d'idées, as-tu essayé si c'est le même comportement si c'est le client qui lance ssh avec ces nouvelles options ? Regarde le man

Avatar du membre
thierryR
Messages : 46
Enregistré le : dim. 27 déc. 2015 21:45
Localisation : Chalons en Champagne

Re: GatewayPorts plantent le service

Message par thierryR » lun. 19 juil. 2021 19:51

Oui le message dans les logs est obtenu après avoir relancer le service par

Code : Tout sélectionner

sudo systemctl restart sshd.service
Heureusement pour moi, ce truc est suffisamment intelligent pour ne pas me couper la liaison SSH car je n'accède que en SSH
J'ai essayé un reboot, et j'ai perdu SSH. Donc cette commande plante le raspi.

jelopo
Raspinaute
Messages : 254
Enregistré le : mer. 11 oct. 2017 10:23

Re: GatewayPorts plantent le service

Message par jelopo » mar. 20 juil. 2021 08:10

Bonjour,

Ici un exemple d'utilisation de GatewayPorts, pour peut être éclaircir le but de son utilisation :
https://qastack.fr/ubuntu/50064/reverse-port-tunnelling

Est-ce bien dans ce cas de figure que tu souhaites l'utiliser ?

A+

Avatar du membre
thierryR
Messages : 46
Enregistré le : dim. 27 déc. 2015 21:45
Localisation : Chalons en Champagne

Re: GatewayPorts plantent le service

Message par thierryR » mar. 20 juil. 2021 11:53

Oui c'est tout à fait ça. C'est du reverse SSH.
https://routeur4g.fr/discussions/discus ... r-avec-ssh

Répondre

Retourner vers « En panne ? »