Problème synchronisation NTP Raspberry Pi

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Emil1
Messages : 7
Enregistré le : ven. 20 oct. 2017 17:30

Problème synchronisation NTP Raspberry Pi

Message par Emil1 » ven. 20 oct. 2017 17:50

Bonjour à tous,

Je rencontre des difficultés pour synchroniser mon Rasberry Pi avec NTP en automatique au démarrage du système.
J'arrive à synchroniser l'heure en manuel par contre, comme ceci :

root@raspberrypi:/home/pi# sudo ntpdate -u fr.pool.ntp.org
20 Oct 17:42:51 ntpdate[10000]: adjust time server 62.210.211.218 offset -0.001502 sec

Par contre si je redémarre mon Raspberry il a 4 jours de retard

La commande ntpq -p me renvoie ceci :
remote refid st t when poll reach delay offset jitter
==============================================================================
ns3.stoneartpro .INIT. 16 u - 1024 0 0.000 0.000 0.000
147.135.187.131 .INIT. 16 u - 1024 0 0.000 0.000 0.000
support4.russia .INIT. 16 u - 1024 0 0.000 0.000 0.000
bb8.dousse.eu .INIT. 16 u - 1024 0 0.000 0.000 0.000

=> avec ces info, on se rend conpte que la colonne refid reste en INIT => donc pas bon!

Dans mon fichier ntp.conf j'ai bien ceci pour déclaré les serveurs NTP pourtant :
# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers. Your server will
# pick a different set every time it starts up. Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
server fr.pool.ntp.org prefer
server 0.fr.pool.ntp.org iburst
server 1.fr.pool.ntp.org iburst
server 2.fr.pool.ntp.org iburst
server 3.fr.pool.ntp.org iburst


# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details. The web page <http://support.ntp.org/bin/view/Support ... strictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines. Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient




Si vous avez des pistes je suis preneur... Merci.

maxty01
Modérateur
Messages : 729
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Problème synchronisation NTP Raspberry Pi

Message par maxty01 » ven. 20 oct. 2017 20:15

Bonsoir,

Pouvez-vous vérifier que le service NTPD est bien lancé au démarrage du RPI.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Emil1
Messages : 7
Enregistré le : ven. 20 oct. 2017 17:30

Re: Problème synchronisation NTP Raspberry Pi

Message par Emil1 » ven. 20 oct. 2017 20:52

Merci pour votre réponse,
Je ne suis plus à proximité de l'appareil (ce sera pour lundi). Comment peut on vérifier que le service NTPdate se lance au démarrage. Pour info la date et l'heure qu'il me renvoie à chaque démarrage est celle à laquelle j'ai effectué la synchronisation manuelle " sudo ntpdate -u fr.pool.ntp.org".
J'ai oublié de préciser, RPI ne dispose pas de RTC. On souhaite obtenir l'heure et la date exclusivement par NTP.

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Problème synchronisation NTP Raspberry Pi

Message par dyox » ven. 20 oct. 2017 22:02

Bonsoir,

Avez-vous pensé à lancer une recherche sur ce forum (ou ailleurs) ; car il y a des réponses résolues ici concernant la recherche "ntp".

Peut-être que la pile réseau n'est pas encore établie lors de la commande automatique ntp. Il y a une option dans raspi-config dans le 1er onglet. A tester.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Emil1
Messages : 7
Enregistré le : ven. 20 oct. 2017 17:30

Re: Problème synchronisation NTP Raspberry Pi

Message par Emil1 » lun. 23 oct. 2017 10:07

Bonjour,
J'ai déjà testé beaucoup de choses inspiré d'une petite dizaine de forum et tutos, sans succès. Peut être qu'un pare feux de mon réseau ou quelque chose d'autre m’empêche cette synchronisation... Comment puis je être certain que je n'ai pas ce genre de soucis ?

maxty01
Modérateur
Messages : 729
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Problème synchronisation NTP Raspberry Pi

Message par maxty01 » lun. 23 oct. 2017 10:17

Emil1 a écrit :Bonjour,
J'ai déjà testé beaucoup de choses inspiré d'une petite dizaine de forum et tutos, sans succès. Peut être qu'un pare feux de mon réseau ou quelque chose d'autre m’empêche cette synchronisation... Comment puis je être certain que je n'ai pas ce genre de soucis ?
Bonjour,

Tout simplement car ta commande «sudo ntpdate -u fr.pool.ntp.org» se termine correctement.

Tu peux vérifier si ntpd est en fonction en utilisant l'une des commandes suivantes : «sudo service ntp status» ou «sudo systemctl status ntpd.service»

Bonne journée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Emil1
Messages : 7
Enregistré le : ven. 20 oct. 2017 17:30

Re: Problème synchronisation NTP Raspberry Pi

Message par Emil1 » lun. 23 oct. 2017 11:30

J'ai bien l'impression que c'est fonctionnel. Regardez :

root@raspberrypi:/home/pi# sudo service ntp status
● ntp.service - LSB: Start NTP daemon
Loaded: loaded (/etc/init.d/ntp)
Active: active (running) since ven. 2017-10-20 17:17:04 CEST; 2 days ago
Process: 552 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/ntp.service
└─610 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 106:111

oct. 20 17:17:04 raspberrypi ntpd[610]: proto: precision = 0.521 usec
oct. 20 17:17:04 raspberrypi ntpd[610]: Listen and drop on 0 v4wildcard 0.0....3
oct. 20 17:17:04 raspberrypi ntp[552]: Starting NTP server: ntpd.
oct. 20 17:17:04 raspberrypi ntpd[610]: Listen and drop on 1 v6wildcard :: U...3
oct. 20 17:17:04 raspberrypi ntpd[610]: Listen normally on 2 lo 127.0.0.1 UD...3
oct. 20 17:17:04 raspberrypi ntpd[610]: Listen normally on 3 lo ::1 UDP 123
oct. 20 17:17:04 raspberrypi ntpd[610]: peers refreshed
oct. 20 17:17:04 raspberrypi ntpd[610]: Listening on routing socket on fd #2...s
oct. 20 17:17:04 raspberrypi systemd[1]: Started LSB: Start NTP daemon.
oct. 23 10:38:24 raspberrypi systemd[1]: Started LSB: Start NTP daemon.
Hint: Some lines were ellipsized, use -l to show in full.
root@raspberrypi:/home/pi#



Je vais redémarrer le PI et retaper cette ligne : sudo service ntp status afin de vérifer l'action faite au boot...

Emil1
Messages : 7
Enregistré le : ven. 20 oct. 2017 17:30

Re: Problème synchronisation NTP Raspberry Pi

Message par Emil1 » lun. 23 oct. 2017 14:43

Mon problème est persistant. Voici ce que me renvoie ces commandes pour l'heure actuelle (14h40 environ) :

root@raspberrypi:/home/pi# sudo timedatectl
Local time: lun. 2017-10-23 12:35:35 CEST
Universal time: lun. 2017-10-23 10:35:35 UTC
RTC time: n/a
Time zone: Europe/Paris (CEST, +0200)
NTP enabled: yes
NTP synchronized: yes
RTC in local TZ: no
DST active: yes
Last DST change: DST began at
dim. 2017-03-26 01:59:59 CET
dim. 2017-03-26 03:00:00 CEST
Next DST change: DST ends (the clock jumps one hour backwards) at
dim. 2017-10-29 02:59:59 CEST
dim. 2017-10-29 02:00:00 CET
root@raspberrypi:/home/pi#


et toujours pas de synchro :
root@raspberrypi:/home/pi# ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
ntp.univ-angers .INIT. 16 u - 512 0 0.000 0.000 0.000
mail.mn-home.fr .INIT. 16 u - 512 0 0.000 0.000 0.000
pob01.aplu.fr .INIT. 16 u - 512 0 0.000 0.000 0.000
http://www.mindstudios .INIT. 16 u - 512 0 0.000 0.000 0.000
root@raspberrypi:/home/pi#


et aussi :

root@raspberrypi:/home/pi# service ntpd start
Failed to start ntpd.service: Unit ntpd.service failed to load: No such file or directory.
root@raspberrypi:/home/pi# ntpdate 0.fr.pool.ntp.org
23 Oct 12:42:30 ntpdate[3269]: the NTP socket is in use, exiting
root@raspberrypi:/home/pi# date
lundi 23 octobre 2017, 12:42:33 (UTC+0200)
root@raspberrypi:/home/pi#

Si je fais un PING :

root@raspberrypi:/home/pi# ping 0.fr.pool.ntp.org
PING 0.fr.pool.ntp.org (151.80.42.151) 56(84) bytes of data.
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=1 ttl=54 time=76.4 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=2 ttl=54 time=28.7 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=3 ttl=54 time=28.6 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=4 ttl=54 time=57.1 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=5 ttl=54 time=30.4 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=6 ttl=54 time=35.8 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=7 ttl=54 time=146 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=8 ttl=54 time=32.3 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=9 ttl=54 time=46.5 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=10 ttl=54 time=38.4 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=11 ttl=54 time=43.4 ms
64 bytes from mail.mcwinter.org (151.80.42.151): icmp_seq=12 ttl=54 time=33.5 ms

Je sèche ! :?

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Problème synchronisation NTP Raspberry Pi

Message par dyox » lun. 23 oct. 2017 17:02

Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Emil1
Messages : 7
Enregistré le : ven. 20 oct. 2017 17:30

Re: Problème synchronisation NTP Raspberry Pi

Message par Emil1 » lun. 23 oct. 2017 17:24

Bonjour et merci dyox,
Je viens de tester les manipulations de msthyz => sans succès pour moi.

Le symptome est légèrment différent car lorsque je fais la demande manuellement, ça marche, c'est en automatique et au boot que ça ne se lance pas :

root@raspberrypi:/home/pi# ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
tor1.wtfismyip. .INIT. 16 u - 64 0 0.000 0.000 0.000
ntp.lweber.net .INIT. 16 u - 64 0 0.000 0.000 0.000
ntp22.mailer.ph .INIT. 16 u - 64 0 0.000 0.000 0.000
server1.webster .INIT. 16 u - 64 0 0.000 0.000 0.000
root@raspberrypi:/home/pi# sudo ntpdate -u fr.pool.ntp.org
23 Oct 17:29:49 ntpdate[2140]: step time server 195.154.174.209 offset 17370.320752 sec
root@raspberrypi:/home/pi# date
lundi 23 octobre 2017, 17:29:55 (UTC+0200)
root@raspberrypi:/home/pi#


Je poursuis mes recherches...

Répondre

Retourner vers « En panne ? »