Connection refused  [RESOLU]

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

domi
Administrateur
Messages : 2826
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Connection refused

Message par domi » jeu. 28 mars 2019 21:08

Alors je reprend,

La machine "Gerard" est le client, il n'y a donc rien à faire dessus, ni a utiliser ses mots de passe.
Sur le Rpi, tu dis qu'il démarre la session tout seul sans demander de login ni mot de passe.

Un fois démarré, tu ouvres une console dessus puis tu lances la commande "who" afin de connaitre l'utilisateur qui a ouvert la session. Ce nom d'utilisateur est à utiliser dans les exemples ci-dessous ou il est notifié <user>. Les caractères "<user>" sont donc à remplacer par le nom d'utilisateur. Exemple "pi" si le "who" retourne que l'utilisateur s'appelle "pi".

Sur cette même machine, comme tu ne connais pas le mot de passe de l'utilisateur, tu fais un

Code : Tout sélectionner

sudo passwd <user>
afin de lui définir un mot de passe que tu connais.
Bien vérifier que la console n'est pas en QUERTY.

Sur "gerard", tu lances un

Code : Tout sélectionner

ssh <user>@192.168.1.87
avec le mot de passe que tu as défini sur le Rpi.
Inutile de tenter d'autre mot de passe, c'est celui-ci qu'il faut spécifier.
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

marseillois
Messages : 61
Enregistré le : ven. 10 juin 2016 14:18

Re: Connection refused

Message par marseillois » ven. 29 mars 2019 11:21

Salut domi

Avant de te répondre, j’avais bien exécuté tes suggestions

Je les refait en te détaillant les résultats :

Code : Tout sélectionner

pi@raspberrypi:~ $ who
pi tty7 2019-03-29 10:31 (:0)
pi tty1  2019-03-29 10:31
pi@raspberrypi:~ $ sudo passwd pi
Entrez le nouveau mot de passe UNIX :
Retapez le nouveau mot de passe UNIX :
passwd:password updated sucessfully
A la suite de quoi je fais un shutdown reboot
Mon rasp se relance puis : Welcome …… et s’ouvre sans login ni mot de passe

Je me place au terminal de “gerard” :

Code : Tout sélectionner

gerard@gerard-L50:~$ ssh -v pi@192.168.1.87
OpenSSH_7.4p1 Debian-10+deb9u6, OpenSSL 1.0.2r  26 Feb 2019
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.1.87 [192.168.1.87] port 22.
debug1: Connection established.
debug1: identity file /home/gerard/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.4p1 Debian-10+deb9u6
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4p1 Raspbian-10+deb9u6
debug1: match: OpenSSH_7.4p1 Raspbian-10+deb9u6 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 192.168.1.87:22 as 'pi'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:XeiaygTtIdpimaTRV0JWpAt39aKI6azXaqtjTnlaL+A
debug1: Host '192.168.1.87' is known and matches the ECDSA host key.
debug1: Found key in /home/gerard/.ssh/known_hosts:4
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/gerard/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 279
A ce stade une fenêtre s’ouvre :

Code : Tout sélectionner

“Saississez le mot de passe pour dévérrouiller la clef ….
Une application veut accéder à la clef privée gerargerard-L50 mais elle est verrouillée
Mot de passe :”
Je rentre plusieurs fois le mot de passe updaté sur rpi (plusieurs pour être sur de ne pas faire d’erreurs de frappe) mais chaque fois sans succès

Je clicque la case annuler de la fenêtre et au terminal s'ajoutent les lignes suivantes :

Code : Tout sélectionner

sign_and_send_pubkey: signing failed: agent refused operation
debug1: Trying private key: /home/gerard/.ssh/id_dsa
debug1: Trying private key: /home/gerard/.ssh/id_ecdsa
debug1: Trying private key: /home/gerard/.ssh/id_ed25519
debug1: Next authentication method: password
pi@192.168.1.87's password: 		


Je propose le mot de passe updaté sur rpi ce qui termine la commande par :

Code : Tout sélectionner

Authentication failed.
Voilà Voilà : je ne suis pas plus avancé : qu'est-ce que j'ai loupé ??

Une idée ??

Merci & à +

domi
Administrateur
Messages : 2826
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Connection refused

Message par domi » ven. 29 mars 2019 11:34

Bonjour,

Si on regarde le résultat de la connexion, tout est OK, même les clés ont été prises en compte.
Du coup, c'est bien maintenant la passphrase de ta clé qui est demandé, et non le mot de passe.
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

marseillois
Messages : 61
Enregistré le : ven. 10 juin 2016 14:18

Re: Connection refused

Message par marseillois » ven. 29 mars 2019 17:09

Salut domi

Effectivement après ma commande ssh au terminal du portable je me retrouve bien sur le rasp après avoir proposé la passphrase dans la fenêtre qui demande le mot de passe, et j’obtiens au terminal :

Code : Tout sélectionner

gerard@gerard-L50:~$ ssh -v pi@192.168.1.87
OpenSSH_7.4p1 Debian-10+deb9u6, OpenSSL 1.0.2r  26 Feb 2019
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.1.87 [192.168.1.87] port 22.
debug1: connect to address 192.168.1.87 port 22: No route to host
ssh: connect to host 192.168.1.87 port 22: No route to host
gerard@gerard-L50:~$ ssh -v pi@192.168.1.87
OpenSSH_7.4p1 Debian-10+deb9u6, OpenSSL 1.0.2r  26 Feb 2019
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.1.87 [192.168.1.87] port 22.
debug1: Connection established.
debug1: identity file /home/gerard/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/gerard/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.4p1 Debian-10+deb9u6
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4p1 Raspbian-10+deb9u6
debug1: match: OpenSSH_7.4p1 Raspbian-10+deb9u6 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 192.168.1.87:22 as 'pi'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:XeiaygTtIdpimaTRV0JWpAt39aKI6azXaqtjTnlaL+A
debug1: Host '192.168.1.87' is known and matches the ECDSA host key.
debug1: Found key in /home/gerard/.ssh/known_hosts:4
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/gerard/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug1: Authentication succeeded (publickey).
Authenticated to 192.168.1.87 ([192.168.1.87]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: network
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: Sending environment.
debug1: Sending env LC_MEASUREMENT = fr_FR.UTF-8
debug1: Sending env LC_PAPER = fr_FR.UTF-8
debug1: Sending env LC_MONETARY = fr_FR.UTF-8
debug1: Sending env LANG = fr_FR.UTF-8
debug1: Sending env LC_NUMERIC = fr_FR.UTF-8
debug1: Sending env LC_TIME = fr_FR.UTF-8
Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Mar 29 11:22:03 2019
Je peux travailler dessus

Code : Tout sélectionner

pi@raspberrypi:~ $ who
pi       tty7         2019-03-29 11:22 (:0)
pi       tty1         2019-03-29 11:22
pi       pts/0        2019-03-29 16:04 (192.168.1.97)
A toutes fins utiles je propose ci dessous les configurations SSH client et serveur telles qu’elles sont à la résolution des problèmes
Configuration client :

Code : Tout sélectionner

# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options.  For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

Host *
#   ForwardAgent no
#   ForwardX11 no
#   ForwardX11Trusted yes
#   RhostsRSAAuthentication no
#   RSAAuthentication yes
#   PasswordAuthentication yes
#   HostbasedAuthentication no
#   GSSAPIAuthentication no
#   GSSAPIDelegateCredentials no
#   GSSAPIKeyExchange no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   IdentityFile ~/.ssh/id_ecdsa
#   IdentifyFile ~/.ssh/id_ed25519
#   Port 22
#   Protocol 2
#   Cipher 3des
#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-$
#   MACs hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
#   VisualHostKey no
#   ProxyCommand ssh -q -W %h:%p gateway.example.com
#   RekeyLimit 1G 1h
    SendEnv LANG LC_*
    HashKnownHosts yes
    GSSAPIAuthentication yes
Monfichier /etc/ssh/sshd_config (le serveur)

Code : Tout sélectionner

#       $OpenBSD: sshd_config,v 1.100 2016/08/15 12:32:04 naddy Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:
#LoginGraceTime 2m
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#PubkeyAuthentication yes

# Expect .ssh/authorized_keys2 to be disregarded by default in future.
#AuthorizedKeysFile     .ssh/authorized_keys .ssh/authorized_keys2

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation sandbox
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# override default of no subsystems
Subsystem       sftp    /usr/lib/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       PermitTTY no
#       ForceCommand cvs server
Reste un problème qui me semble laisser subsister un gros risque : comme je l’ai évoqué dans mon précédent post, à l'ouverture en direct de la bête, ni login ni mot de passe NE ME SONT DEMANDÉS

pi@raspberrypi:~ $ who
pi tty7 2019-03-29 11:22 (:0)
pi tty1 2019-03-29 11:22
pi pts/0 2019-03-29 16:04 (192.168.1.97)
pi@raspberrypi:~ $ sudo passwd pi
Entrez le nouveau mot de passe UNIX :
Retapez le nouveau mot de passe UNIX :
passwd: password updated successfully

Mon écran défile sur la TV et ma session s’ouvre toujours sans me demander ni login ni mot de passe

Est-ce normal ?? Je ne comprends pas

Merci d’avance

domi
Administrateur
Messages : 2826
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Connection refused

Message par domi » ven. 29 mars 2019 17:32

L'autologin n'est fonctionnel que lorsque tu es physiquement sur le Rpi, sinon ça ne fonctionne pas.

Si tu veux changer le mode de démarrage il faut aller dans l'utilitaire

Code : Tout sélectionner

sudo raspi-config
Choisir le menu "Boot Options"
Puis "Desktop / Cli"
Puis ensuite tu as 4 choix possible de démarrage en local :
  • Console = Démarrage en mode "Console" après identification
  • Console autologin = démarage en mode "Console" avec connexion automatique sur le user "pi"
  • Desktop = Démarrage en mode "Bureau" après identification
  • Desktop autologin = démarage en mode "Bureau" avec connexion automatique sur le user "pi"
Par défaut à l'installation nous sommes dans le mode 4, c'est à toi de changer si tu le souhaites.
Mais comme je l'ai dit, c'est uniquement lorsque tu es physiquement sur le Rpi. Donc a éviter sur des machines en entreprise, mais pas dangereux pour un Raspberry à ton domicile.
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

marseillois
Messages : 61
Enregistré le : ven. 10 juin 2016 14:18

Re: Connection refused

Message par marseillois » sam. 30 mars 2019 16:57

salut domi et merci encore

Donc si je comprends bien :

Par défaut, le systeme ne prévoit pas de sécurité par mot de passe à l’ouverture, ce qui donne à penser que cette situation ne pose pas de problème au regard de la sécurité, du fait qu’on est en local et que tout accès au systeme devra se faire en sudoer ??.
Je pose simplement la question car mon but n’est pas de sombrer dans la paranoia sécuritraire .

Sinon, je crois qu’on a fait le tour de la question et dès que tu m’auras éclairé sur ce dernier point je mettrai le sujet en résolution

Je vais maintenant m’atteler à l’installation sur mon réseau d’un lecteur enregisteur d’émissions TV, sur un raspbberry Pi3 B+ : j’ai déjà repérer un tuto sur framboise qui devrait bien m’aller.
A ce propos, pourrais tu me dire sur quel forum je pourrais m’inscrire dans cette perspective ?? Débutant au début ou tout de suite en panne ?

Encore merci pour ton attention & à+, car je serai sans doute de retour sur le forum dans pas longtemps
Cordialement

domi
Administrateur
Messages : 2826
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Connection refused

Message par domi » sam. 30 mars 2019 17:15

marseillois a écrit :
sam. 30 mars 2019 16:57
Par défaut, le systeme ne prévoit pas de sécurité par mot de passe à l’ouverture, ce qui donne à penser que cette situation ne pose pas de problème au regard de la sécurité, du fait qu’on est en local et que tout accès au systeme devra se faire en sudoer ??.
Je pose simplement la question car mon but n’est pas de sombrer dans la paranoia sécuritraire .
C'est exact, la seule "non sécurité" est lorsque l'on est physiquement sur le PI, donc pas génant chez toi,mais par sécurité tu peux enlever cet type de démarrage, tel que je l'ai expliqué plus haut. Pas d'inquiétude, toutes les connexion distantes sont bien sécurisées.
marseillois a écrit :Je vais maintenant m’atteler à l’installation sur mon réseau d’un lecteur enregisteur d’émissions TV, sur un raspbberry Pi3 B+ : j’ai déjà repérer un tuto sur framboise qui devrait bien m’aller.
A ce propos, pourrais tu me dire sur quel forum je pourrais m’inscrire dans cette perspective ?? Débutant au début ou tout de suite en panne ?
Dans ce cas, nous ne sommes plus dans la catégorie débutant, ni en panne, car ce n'est pas une installation qui ne fonctionne pas. Mais dans l'installation plus spécifique à un besoin.
Tu peux donc poster soit dans "Utilisateurs avancés", ou au mieux, peut-être dans "Les applications spécialisées du Raspberry Pi". Ce n'est pas toujours simple de trouver la bonne rubrique ;)
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

marseillois
Messages : 61
Enregistré le : ven. 10 juin 2016 14:18

Re: Connection refused  [RESOLU]

Message par marseillois » sam. 30 mars 2019 22:39

Merci domi

Cordialement

Répondre

Retourner vers « En panne ? »