Démarrage sur ssd impossible

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

daniel54
Messages : 6
Enregistré le : jeu. 25 juin 2020 13:48

Démarrage sur ssd impossible

Message par daniel54 » jeu. 25 juin 2020 14:18

Bonjour
j’ai un raspberry pi3+ avec jeedom installé depuis 2ans environ,
L installation était sur une carte SD ensuite j’ai tous installé sur un disque dur SSD ,tous fonctionnait bien.Ce week end j’ai éteint mon rpi et au redémarrage il bloque sur crng init done.Si je remet ma carte SD il redémarre normalement sur la carte SD,j’ai bien "program_usb_boot_mode=1 " dans config.txt,et la commande « vcgencmd otp_dump | grep 17 » me donne bien ‹ ‹ 17:3020000a › › Le disque est bien reconnu dans le gestionnaire de fichier.l'alimentation est une 3A d'origine,
la commande sudo blkid
/dev/mmcblk0: PTUUID="000cac4a" PTTYPE="dos"
/dev/mmcblk0p1: LABEL="RECOVERY" UUID="3131-6132" TYPE="vfat" PARTUUID="000cac4a-01"
/dev/mmcblk0p5: LABEL="SETTINGS" UUID="3831bf9a-249b-4e87-bd16-113cdaa2e733" TYPE="ext4" PARTUUID="000cac4a-05"
/dev/mmcblk0p6: LABEL="boot" UUID="F302-A4CF" TYPE="vfat" PARTUUID="000cac4a-06"
/dev/mmcblk0p7: LABEL="root" UUID="792b8aa9-8aba-4c5d-a219-335646e19ac1" TYPE="ext4" PARTUUID="000cac4a-07"
/dev/sda1: LABEL="boot" UUID="AF14-47C0" TYPE="vfat" PARTUUID="ea2b7b4f-01"
/dev/sda2: LABEL="rootfs" UUID="b57a7299-0677-4dc6-b4b0-c10f107f0f6d" TYPE="ext4" PARTUUID="ea2b7b4f-02"

dans le fichier cmdline il est écrit
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

Quelqu’un aurait une idée du problème?
Merci
Daniel

daniel54
Messages : 6
Enregistré le : jeu. 25 juin 2020 13:48

Re: Démarrage sur ssd impossible

Message par daniel54 » ven. 7 août 2020 11:37

Bonjour
Je viens également de faire l’essai en branchant le disque dur sur un ub usb alimenté,mais toujours pas de démarrage vers ce disque dur pourtant le disque n’a pas de problème.Si quelqu’un avait une idée d’où je pourrais chercher ,ça serait cool
Merci

dyox
Raspinaute
Messages : 722
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Démarrage sur ssd impossible

Message par dyox » ven. 7 août 2020 12:32

Bonjour,

Il y a plusieurs solutions sur le net. Y avez-vous regardé ?

On peut avoir le fstab du ssd ?
Que disent les logs du ssd ?

Après, vous pouvez fonctionner par étape pour vous dépanner :
boot sur sd et rootfs sur ssd donc remplacez "/dev/mmcblk0p7" par "/dev/sda2" du cmdline de la sd

domi
Administrateur
Messages : 2835
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Démarrage sur ssd impossible

Message par domi » ven. 7 août 2020 13:23

Apparemment un problème avec la partition "/boot" du ssd
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

daniel54
Messages : 6
Enregistré le : jeu. 25 juin 2020 13:48

Re: Démarrage sur ssd impossible

Message par daniel54 » ven. 7 août 2020 15:54

Merci de m'aider je ram depuis plus de 2 mois
J'ai regardé plein de site pour essayer de trouver une solution, mais comme en plus je n'y connais pas grand chose voir même rien ce n'est pas facile :!:

le fstab donne ceci

proc /proc proc defaults 0 0
PARTUUID=ea2b7b4f-01 /boot vfat defaults 0 2
PARTUUID=ea2b7b4f-02 / ext4 defaults,noatime 0 1
tmpfs /tmp/jeedom tmpfs defaults,size=128M 0 0
# a swapfile is not a swap partition, no line here
# use dphys-swapfile swap[on|off] for that

daniel54
Messages : 6
Enregistré le : jeu. 25 juin 2020 13:48

Re: Démarrage sur ssd impossible

Message par daniel54 » ven. 7 août 2020 15:54

Merci de m'aider je ram depuis plus de 2 mois
J'ai regardé plein de site pour essayer de trouver une solution, mais comme en plus je n'y connais pas grand chose voir même rien ce n'est pas facile :!:

le fstab donne ceci

proc /proc proc defaults 0 0
PARTUUID=ea2b7b4f-01 /boot vfat defaults 0 2
PARTUUID=ea2b7b4f-02 / ext4 defaults,noatime 0 1
tmpfs /tmp/jeedom tmpfs defaults,size=128M 0 0
# a swapfile is not a swap partition, no line here
# use dphys-swapfile swap[on|off] for that

dyox
Raspinaute
Messages : 722
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Démarrage sur ssd impossible

Message par dyox » ven. 7 août 2020 16:04

la ligne
PARTUUID=ea2b7b4f-02 / ext4 defaults,noatime 0 1
ligne recopiée à la main ou Copiée/collée du fstab ?
Parce qu'il y a une erreur dedans

Sinon, pas de dépannage avec les infos sur le net ?

avez-vous déjà tenté ma modif du cmdline ?

daniel54
Messages : 6
Enregistré le : jeu. 25 juin 2020 13:48

Re: Démarrage sur ssd impossible

Message par daniel54 » ven. 7 août 2020 17:04

c'est un copié collé du fstab

j'ai essayé la modification du cmdline comme indiqué ,le démarrage se fait bien sur le disque dur et quand j'arrive sur ma page d'acceuil , l'ecran reste figé et la souris ne fonctionne et jeedom reste inaccessible de l'extérieur

dyox
Raspinaute
Messages : 722
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Démarrage sur ssd impossible

Message par dyox » ven. 7 août 2020 17:51

Le fstab est hors de cause, tout est bon, je me suis trompé.

Pour savoir ce qu'il y a eu, il faut vraiment sortir les logs. Comme ça, je dirais un update qui c'est mal passé. Je ne connais pas jeedom, il y a des mises à jours auto de jeedom et de l'OS ? MAJ auto et au reboot, cela plante.
Et avec les logs, si on se souvient de la date du plantage, on connait les updates.
D'ailleurs, les dates doivent être figées puisque il ne démarre plus depuis.
Regardez du côté de /var/log et plus précisément /var/log/apt/term.log si c'est un pb d'update de l'OS / paquets

C'est quoi l'OS de Jeedom ?

c'est quoi ces lignes ?
/dev/mmcblk0p1: LABEL="RECOVERY" UUID="3131-6132" TYPE="vfat" PARTUUID="000cac4a-01"
/dev/mmcblk0p5: LABEL="SETTINGS" UUID="3831bf9a-249b-4e87-bd16-113cdaa2e733" TYPE="ext4" PARTUUID="000cac4a-05"

On peut avoir le résultat de df -h ?

daniel54
Messages : 6
Enregistré le : jeu. 25 juin 2020 13:48

Re: Démarrage sur ssd impossible

Message par daniel54 » ven. 7 août 2020 18:16

le resultat de df -h

pi@raspberrypi:~ $ df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/root 28G 4,4G 22G 17% /
devtmpfs 406M 0 406M 0% /dev
tmpfs 438M 0 438M 0% /dev/shm
tmpfs 438M 6,1M 432M 2% /run
tmpfs 5,0M 4,0K 5,0M 1% /run/lock
tmpfs 438M 0 438M 0% /sys/fs/cgroup
tmpfs 128M 2,1M 126M 2% /tmp/jeedom
/dev/mmcblk0p6 68M 24M 45M 35% /boot
tmpfs 88M 4,0K 88M 1% /run/user/1000
/dev/mmcblk0p5 30M 1,6M 27M 6% /media/pi/SETTINGS
/dev/sda1 44M 40M 3,7M 92% /media/pi/boot
/dev/sda2 110G 6,1G 100G 6% /media/pi/rootfs
pi@raspberrypi:~ $

c'est quoi ces lignes ?
/dev/mmcblk0p1: LABEL="RECOVERY" UUID="3131-6132" TYPE="vfat" PARTUUID="000cac4a-01"
/dev/mmcblk0p5: LABEL="SETTINGS" UUID="3831bf9a-249b-4e87-bd16-113cdaa2e733" TYPE="ext4" PARTUUID="000cac4a-05"[/b][/i][/i][/quote]

je n'y comprends rien je ne sais pas a quoi elles correspondent
term.log
(125.36 Kio) Téléchargé 3 fois

Répondre

Retourner vers « En panne ? »