[RESOLU] Permission d'exécution sur fihier .desktop mis sur le bureau  [RESOLU]

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

Répondre
Avatar du membre
tioker
Messages : 32
Enregistré le : jeu. 9 févr. 2017 11:30
Localisation : Anjou...feu

[RESOLU] Permission d'exécution sur fihier .desktop mis sur le bureau

Message par tioker » ven. 20 déc. 2019 17:52

Bonsoir (il fait déjà nuit !).

Je migre une application shell de RPI3 vers RPI4. j'ai donc installé un nouveau Raspbian.
Autant que je m'en souvienne, les fichiers .desktop que je posais sur le bureau ne posaient pas de problème. Maintenant SI.
Image

J'ai lu les forums pour m'apercevoir qu'il suffisait que je mette les bonnes permissions comme cela (fait sous Mint):
Image

Mais cette option n’apparaît pas dans Raspbian

Image

Une idée ???
Merci
Modifié en dernier par tioker le ven. 20 déc. 2019 23:32, modifié 1 fois.

domi
Administrateur
Messages : 2789
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Permission d'exécution sur fihier .desktop mis sur le bureau

Message par domi » ven. 20 déc. 2019 18:20

Bonsoir,

N'utilisant pas d'interface graphique sous linux, je ne saurai te répondre précisément, mais tes deux copies écrans permettent les mêmes réglages.

A priori, la première te permet de configurer des droits en fonction du user (Utilisateur, groupe, et autre), puis pour chacun, lui attribuer des permissions (lecture, écriture, exécution).
La seconde semble être trié par type de droits (lecture, écriture, exécution). Pour chacun des types tu dois dire qui a le droit (tout le monde, et certainement, utilisateur, et groupe dans la liste déroulante.

En fait, la différence ne vient pas de Raspbian, mais de l'environnement graphique.
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Permission d'exécution sur fihier .desktop mis sur le bureau

Message par cbalo » ven. 20 déc. 2019 18:36

Bonjour,

Ne faisant que du shell, je ne saurai te dire pour le faire graphiquement mais je peux te dire comment faire en ligne de commande :

Si tu sais où se trouve ton fichier, tu peux ouvrir un terminal, aller dans ton répertoire (cd /nom/du/chemin)
Puis faire : sudo chmod a+x .dekstop (si .desktop est le nom du fichier)

Pour info, chmod change les permissions sur le fichier et a+x ajoute x (exécution) à a (all = tout le monde)
Et pour info, si ton nom de fichier commence par "." alors il faut le mettre, "." sert à cacher ce fichier de l'explorateur.

Avatar du membre
tioker
Messages : 32
Enregistré le : jeu. 9 févr. 2017 11:30
Localisation : Anjou...feu

Re: Permission d'exécution sur fihier .desktop mis sur le bureau

Message par tioker » ven. 20 déc. 2019 22:46

Bonsoir,

A priori ... NON NON.
Regardez bien les images; celle de Mint (la 2ème) propose de rendre le fichier exécutable (en bas), pas celle de Raspbian (la troisième).
Et j'avais déjà vérifié; sur le Raspberry tout est en accès 'rwx' pour tous; j'avais fait un chmod 777 *.desktop
En fait le Mint ne l'avait pas et en cochant la fonction exécutable, le 'x' est ajouté.

Dans mes .desktop il y a un lancement de fichiers .sh qui sont tous en rwx aussi.

Et pour abonder sur mon problème, j'ai créé un fichier Touch.desktop sur le bureau comme ça:
----------------------------
[Desktop Entry]
Name=Touch
Terminal=touch toto.txt
Terminal=true
Type=Application
----------------------------
Ben même en 777 il me pose la question et quand j’exécute il crée le fichier toto.

On parle donc bien d'une demande d'autorisation d’exécution sur un fichier qui est réputé exécutable...
Bizarre non ? Sauf si je m'embrouille....

A SUIVRE...

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Permission d'exécution sur fihier .desktop mis sur le bureau  [RESOLU]

Message par cbalo » ven. 20 déc. 2019 23:07

OK.
Donc en fait, c'est juste PacMan qui demande comment tu veux exécuter le fichier (au travers d'un terminal ou pas)
En cherchant 1 min sur google, j'ai trouvé ceci
https://www.raspberrypi.org/forums/view ... p?t=248380

Et la solution est expliquée :
Pacman
Edit
Préférence
Général
Cocher : Ne pas demander d'options au lancement d'un fichier exécutable.

mike913
Raspinaute
Messages : 161
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Permission d'exécution sur fihier .desktop mis sur le bureau

Message par mike913 » ven. 20 déc. 2019 23:10

bonjour,
c'est toi qui n'a pas bien regardé, car dans la rubrique contrôle d' accès il y a 3 possibilités:
1- voir le contenu
2- changer le contenu
3- exécuter
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Avatar du membre
tioker
Messages : 32
Enregistré le : jeu. 9 févr. 2017 11:30
Localisation : Anjou...feu

Re: Permission d'exécution sur fihier .desktop mis sur le bureau

Message par tioker » ven. 20 déc. 2019 23:29

Suite ... et fin.

C'est @cbalo qui avait la solution.
Dans le post en référence, il est dit qu'il faut Lancer l'explorateur de fichiers, et dans Edition>Préférences>Général décocher l'option Ne pas demander d'options au lancement d'un fichier exécutable.
L'explorateur de fichier par défaut de Raspbian est LXPanel du bureau LXDE, peut-être/sûrement est-ce la raison pour laquelle je ne savais pas reproduire l'erreur sous d'autres OS Linux.
En tous les cas, sauf trou de mémoire, je ne rappelle pas avoir jamais vu cette option dans les précédentes version de Raspbian que j'avais installées.

Merci @chalo.
Je clos

Répondre

Retourner vers « Raspbian »