retropie manager dans raspberry pi os lite (x64) pour raspberry pi 5 ?

Ici c'est le domaine de PiPlay (anciennement PIMAME) et des autres émulateurs de consoles

Modérateur : Francois

Répondre
big jim
Messages : 3
Enregistré le : sam. 6 avr. 2024 16:25

retropie manager dans raspberry pi os lite (x64) pour raspberry pi 5 ?

Message par big jim » mar. 7 mai 2024 22:49

bonjour, je retrouve les joies ineffables de mon enfance avec le retrogaming par le biais de ma toute nouvelle raspberry pi 5 et grâce a tout les tutoriels qu'on peut trouver un peu partout, je me dépatouille a peu prés, pourtant, deux problèmes me résistent encore...
comme pour recalbox, j'ai lu qu'un manager existait également pour retropie, j'ai également trouver une solution alternative par le biais de ce tuto : (https://github.com/NicholasBerryman/Ret ... nager-Plus), tenté avec succès de replacer python par python3 dans la ligne de commande puisque le système me le proposait tout en jugeant le premier de ces deux obsolète. un nouveau message d'erreur m'indique maintenant qu'il me manquerait des fichiers de python 2.7, je n'en sortirais pas, tout en ne sachant pas si cette démarche me permettra de toucher a mon Graal, retropie manager !

peut être l'un d'entre vous peut il m'indiquer la marche a suivre pour y avoir accès, car mon but est de pouvoir trouver les bons bios pour les émulateurs, et je trouve plus facile le coup des bios allumé en vert ou rouge pour savoir quels sont les bons, mais peut être que quelqu'un connaît un méthode moins alambiquée ?

d'avance merci !

piper
Raspinaute
Messages : 669
Enregistré le : sam. 5 juin 2021 18:57

Re: retropie manager dans raspberry pi os lite (x64) pour raspberry pi 5 ?

Message par piper » ven. 10 mai 2024 20:15

Ouille,
Python 2.7 a 16 ans ! Python 3.x est sortie il y a 14 ans !

Et entre les 2 il y a un gouffre : énormément de choses ont changé, les codes pour python 2.x ne sont sauf rares exceptions pas compatibles avec python 3.x
C'est pour cela que la migration sur les OS Linux a mis plus de 10 ans, tant il a fallut réécrire de choses.

Je suis étonné que la dernière version de Recall box utilise encore du python 2.x
Parmis mon paquet de Pi, j'ai un recall box depuis bien 10 ans, mais avec, je me contente de jouer à mes anciens jeux sur Amstrad de temps en temps

Et il y a un autre fossé (plus un gouffre cette fois-ci) entre python 3.x (x<=6) et python 3.y (y>=7)
Python 3.6 c'était il y a 8 ans, et 3.7 il y a 5 ans !
3 Pi4 : Emby / Samba , Librelec, Android TV
3 Pi3 : Hifiberry /OSMC, Games station, Samba / VPN / HotSpot Wifi
2 Pi2 : RFID, radio reveil (PiReveil)
1 Pi0 : traker GPS et acquisitions
1 Pi0 2W : tests divers
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

big jim
Messages : 3
Enregistré le : sam. 6 avr. 2024 16:25

Re: retropie manager dans raspberry pi os lite (x64) pour raspberry pi 5 ?

Message par big jim » ven. 17 mai 2024 22:48

merci de me donner de leurs nouvelles, c'est vrai qu'on entendait plus beaucoup parler d'eux en ce moment, ils se font vieux, mais pour tout te dire, c'est plutot retropie manager, que je cherchais a joindre par leurs biais, as tu également de ses nouvelles ? comment va t il ? est ce que ces vieux octets arrivent encore a faire le boulot sur ma config, ou est ce que ce projet a définitivement été mis au rebut a force de mise a jour, comme une vieille disquette 5"1/4 perdue devant un amstrad 6128 ?

piper
Raspinaute
Messages : 669
Enregistré le : sam. 5 juin 2021 18:57

Re: retropie manager dans raspberry pi os lite (x64) pour raspberry pi 5 ?

Message par piper » sam. 1 juin 2024 12:00

Recallbox continue d'évoluer, leur dernière version date de fin 2023 : il y a 6 mois environ.
Le dernier pull request date de 15 jours
Mais il est possible / probable qu'une partie s'appuie toujours sur python 2.7 : regardez motioneye : il y a 2 versions une en python 2.7 (l'officielle) et une version parallèle bien cachée pour python 3.x

Il est possible qu'il faille encore patienter pour une compatibilité complète de Recallbox avec les Pi5.
J'ai un Pi5 à la maison, il ne peut pas encore remplacer certains de mes Pi3 pour des taches spécifiques.

Quand aux amstrad 6128, désolé, mais ils n'avaient pas de lecteur de disquette 5,25 pouces ni de 3,5 pouces.
Amstrad utilisait sur les modèles CPC un format spécifique : 3 pouces pour 178ko

Les 5,25 pouces sont arrivés sur les commodores et les 1ers lecteurs 3,5 pouces sur les atari 520 et 1040ST pour 360ko puis 720ko puis 1440ko

Et les 1ers lecteurs de disquettes sont apparus sur les IBM en 1967 , le format était 8 pouces pour 99ko

Amstrad a intégré des lecteurs 5,25 pouces sur son 1er PC , le PC-1512 tournant sous MS-DOS en 1986 (ne pas confondre avec les Amstrad CPC 464, 664 et 6128 tournant sous CPM et sortis en 84-85)
3 Pi4 : Emby / Samba , Librelec, Android TV
3 Pi3 : Hifiberry /OSMC, Games station, Samba / VPN / HotSpot Wifi
2 Pi2 : RFID, radio reveil (PiReveil)
1 Pi0 : traker GPS et acquisitions
1 Pi0 2W : tests divers
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

Répondre

Retourner vers « Emulation de consoles sur Raspberry Pi »