Shield GPS : problèmes de connection

Photographie ultra-rapide, pilotage d'imprimante 3D ou de CNC, fabrication de bière.... Enfin tout ce que le Raspberry peut gérer trouvera sa place dans cette rubrique

Modérateur : Francois

Répondre
cerbere_pi
Messages : 5
Enregistré le : sam. 28 déc. 2019 18:33

Shield GPS : problèmes de connection

Message par cerbere_pi » sam. 28 déc. 2019 18:35

Bonjour,

Je travaille actuellement sur un projet où le but est de créer un système de sécurité pour voiture. Je travaille sur un Raspberry Pi Zero.
Ce système doit pouvoir géolocaliser le véhicule. Pour cela, je dispose d’un shield gps IES-SHIELD-GPS, comme sur la photo de ce lien : https://www.ecosia.org/images?q=ies+shi ... 3CF59830E5.
Je tiens juste à spécifier que c’est un projet de découverte et d’apprentissage, je suis donc totalement débutante dans ce domaine.
Mon problème concerne la connection du shield gps au Raspberry.
Je me sers du schéma suivant : https://i-sbc.com/wp-content/uploads/20 ... tartV2.pdf
Cependant, je n’arrive pas à connecter l’un de mes câbles aux ports SDA et SCL. Selon la notice, je comprends que ce sont des ports particuliers et non juste mâle ou femelle mais je ne suis pas certaine et cela me bloque pour continuer mon projet.
Pourriez-vous donc s’il vous plaît m’éclairer sur ce que sont ces ports et sur comment je dois m’y prendre pour pouvoir les connecter à mon raspberry.

Merci d’avance !
Message Modérateur :
Bonjour, je déplace ce sujet qui est loin d'être un problème de débutant
- Domi

Lodwig
Messages : 9
Enregistré le : jeu. 26 déc. 2019 19:21

Re: Shield GPS : problèmes de connection

Message par Lodwig » sam. 28 déc. 2019 19:13

Salut,

Logiquement, tu devrais avoir soit de petits pics en métal (partie mâle) soit une petite pièce en plastique permettant d'encaisser un fil (partie femelle).

Sur l'image que tu montres de ton composant GPS, ces broches ne sont pas soudées mais on peut voir les emplacements de ces ports à droite.

Tu as le choix entre souder des broches (tu auras quelque chose facilement modifiable par la suite) , soit souder les fils directement

Envoyé de mon FIG-LX1 en utilisant Tapatalk


cerbere_pi
Messages : 5
Enregistré le : sam. 28 déc. 2019 18:33

Re: Shield GPS : problèmes de connection

Message par cerbere_pi » sam. 28 déc. 2019 20:48

Merci beaucoup de votre réponse !

Juste au cas où, je viens de me rendre compte que l''image ne correspond pas exactement au composant que j'ai. En effet concernant la partie GND et VIN, les pics mâles sont bien présents (en vert) et là j'arrive donc à connecter.

Pour la partie SDA et SCL dont j'ai besoin il faudrait donc soit souder une broche ou les fils directement au niveau de la zone rouge c'est ça ?
Au début j'essayais la connection au niveau de la zone bleu mais mes fils ne pouvaient évidemment pas se connecter vu que ce ne sont pas des ports femelles.

https://drive.google.com/file/d/1JJZoGa ... sp=sharing

domi
Administrateur
Messages : 2838
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Shield GPS : problèmes de connection

Message par domi » sam. 28 déc. 2019 20:56

Bonjour, sur la zone que vous avez entourée en bleu, ce ne sont pas des pins de connexion, mais des cavaliers de configuration.
Les GPIO SDA et SCL du Raspberry Pi sont sur les broches 3 et 5
Raspberry-pi-3-GPIO_pins_v2-600x376.png
Raspberry-pi-3-GPIO_pins_v2-600x376.png (191.35 Kio) Vu 838 fois
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

Lodwig
Messages : 9
Enregistré le : jeu. 26 déc. 2019 19:21

Re: Shield GPS : problèmes de connection

Message par Lodwig » sam. 28 déc. 2019 21:26

En lisant la doc technique, les pins entourées en vert sur lesquelles tu te connectés sont utilisées pour communiquer avec d'autres pièces (et donc aussi leur fournir du courant)

Les pièces noires (entourées en bleu) sont des cavaliers permettant de configurer l'adresse sur le bus (a0 et a1) ou de générer le pull-up si aucun autre composant ne le fait sur le bus (sda et scl)

De ce que je comprends, tu dois te connecter sur les petits rond tout à l'avant de la carte (entouré de bleu pour sda et scl) marqué vcc, gnd pour l'alimentation et sda et scl pour le transfert de donnée par une soudure non fournie suivant la doc.






cerbere_pi
Messages : 5
Enregistré le : sam. 28 déc. 2019 18:33

Re: Shield GPS : problèmes de connection

Message par cerbere_pi » sam. 28 déc. 2019 22:50

Merci beaucoup pour vos réponses !
J'avais en effet lu ça dans la doc mais comme je m'y connais pas très bien j'avais peur d'avoir mal compris.

Mais du coup, j'aurais juste une dernière question. Le matériel m'a été fourni par mon école et je comptais bien avancer pendant les vacances et là ça me bloque. Est ce qu'il y a moyen facile pour pouvoir commander les broches manquantes adaptées à ce composant, est ce que vous auriez des conseils à me donner s'il vous plaît ?

Lodwig
Messages : 9
Enregistré le : jeu. 26 déc. 2019 19:21

Re: Shield GPS : problèmes de connection

Message par Lodwig » dim. 29 déc. 2019 09:02

On s'éloigne de mes compétences généralistes.

J'ai acheté un lot de barrette pin électronique de ce type (https://images.app.goo.gl/r6ic11afaVYBd97Q7) parce que c'était pas cher, probablement utile et que je passais une commande de composants généraux (Led, diode, résistance, etc)
Rétrospectivement, je me dis que j'aurais peut être dû prendre des femelles (aussi ou à la place)

Envoyé de mon FIG-LX1 en utilisant Tapatalk


cerbere_pi
Messages : 5
Enregistré le : sam. 28 déc. 2019 18:33

Re: Shield GPS : problèmes de connection

Message par cerbere_pi » mer. 1 janv. 2020 19:05

D'accord, merci pour ces conseils ! :)

Répondre

Retourner vers « Les applications spécialisées du Raspberry Pi »