on_event_start ??? [résolu]

Les applications du Raspberry Pi en contrôle d'accès, alarme et vidéosurveillance

Modérateur : Francois

Répondre
thom
Messages : 10
Enregistré le : mer. 11 nov. 2015 03:46

on_event_start ??? [résolu]

Message par thom » dim. 6 mars 2016 16:26

Bonjour,
je me bats pour activer le détecteur de mouvement dans domoticz a l'aide de motion, en suivant ce tuto https://www.domoticz.com/wiki/Camera_Se ... n_Domoticz

ce qui donne dans mon fichier motion.conf:

Code : Tout sélectionner

# Command to be executed when an event starts. (default: none)
# An event starts at first motion detected after a period of no motion defined by gap
on_event_start /usr/bin/curl -s "http://192.168.2.11:8080/json.htm?type=command&param=switchlight&idx=54&switchcmd=On"

# Command to be executed when an event ends after a period of no motion
# (default: none). The period of no motion is defined by option gap.
on_event_end /usr/bin/curl -s "http://192.168.2.11:8080/json.htm?type=command&param=switchlight&idx=54&switchcmd=Off"
et bien sur ça ne fonctionne pas, j'ai tester la commande dans un navigateur et le "device" fonctionne très bien dans domoticz.

Quelqu'un aurait une idée ?
Modifié en dernier par thom le dim. 6 mars 2016 22:08, modifié 1 fois.
Rpi 2 Raspbian, Jessie motioneye os
Rpi 2 Domoticz, Zwave, Mysensors
Rpi 3 Raspbian, Seafile server, Nas

domi
Administrateur
Messages : 2938
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: on_event_start ???

Message par domi » dim. 6 mars 2016 16:33

Bonjour,

Je n'ai pas la réponse, mais sujet intéressant, j'attend la cam IP que je viens de commander afin de l'intégrer à Domoticz.

A+
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY
Conception d'une station météo DIY, et envoi des infos à votre Domotique.

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: on_event_start ???

Message par guillaume9344 » dim. 6 mars 2016 18:40

Bonsoir,
thom a écrit :

Code : Tout sélectionner

# 
on_event_start /usr/bin/curl -s "http://192.168.2.11:8080/json.htm?type=command&param=switchlight&idx=54&switchcmd=On"
motion est il sur la même adresse IP que domotiz? Car motion utilise aussi le port 8080 pour afficher une page de configuration , donc il peut y avoir deux applis sur le même port , ça coince.

@+
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

thom
Messages : 10
Enregistré le : mer. 11 nov. 2015 03:46

Re: on_event_start ???

Message par thom » dim. 6 mars 2016 20:04

Le Live Webcam server est sur:

Code : Tout sélectionner

# The mini-http server listens to this port for requests (default: 0 = disabled)
webcam_port 8765
et HTTP Based Control sur :

Code : Tout sélectionner

# TCP/IP port for the http server to listen on (default: 0 = disabled)
control_port 8082
Mon domotiz est sur le port 8080

donc je ne devrais pas avoir de conflits ?
Rpi 2 Raspbian, Jessie motioneye os
Rpi 2 Domoticz, Zwave, Mysensors
Rpi 3 Raspbian, Seafile server, Nas

thom
Messages : 10
Enregistré le : mer. 11 nov. 2015 03:46

Re: on_event_start ??? [résolu]

Message par thom » dim. 6 mars 2016 22:10

J'ai réinstallé curl et tout est rentré dans l'ordre. J'avais installé Motioneye auparavant et j'ai du faire une mauvaise manipulation en le supprimant... :o
Rpi 2 Raspbian, Jessie motioneye os
Rpi 2 Domoticz, Zwave, Mysensors
Rpi 3 Raspbian, Seafile server, Nas

Répondre

Retourner vers « Accès, alarme et vidéosurveillance »