[Résolu] Openmediavault 4: connexion refusée

Photographie ultra-rapide, pilotage d'imprimante 3D ou de CNC, fabrication de bière.... Enfin tout ce que le Raspberry peut gérer trouvera sa place dans cette rubrique

Modérateur : Francois

cyb31
Messages : 9
Enregistré le : mer. 22 août 2018 19:52

[Résolu] Openmediavault 4: connexion refusée

Message par cyb31 » mer. 22 août 2018 20:06

Bonjour @ tous,
Depuis que je suis passé sous OpenMediaVault 4 avec mon petit Raspberry Pi 3, impossible d'accéder à l'interface WEB (problème: adresse.IP.du.Raspberry n'autorise pas la connexion) ou de me loguer en SSH (problème: access denied).
Le problème est apparu suite à une mise à jour dont je n'ai pas regardé la contenance (sans doute l'update OMV 3 vers OMV 4). En revanche, tout ce que j'avais configuré avant fonctionne. J'ai accès à Domoticz, Transmission et tous mes fichiers partagés. Je n'ai juste plus accès a l'interface WEB de OMV. Du coup, c'est plus compliqué pour le configurer!
Pour info, lorsque je repasse OMV 3 fraichement installé cela fonctionne, j'ai accès à l'interface WEB. Sur un OMV 4 tout fraichement installé, cela ne marche pas non plus.
Quelqu'un sait il pourquoi?
Dans l'espoir de trouver une réponse...
Merci d'avance
Modifié en dernier par cyb31 le jeu. 23 août 2018 20:08, modifié 1 fois.

dyox
Raspinaute
Messages : 459
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Openmediavault 4

Message par dyox » mer. 22 août 2018 21:50

Bonsoir et bienvenue,

Le problème avec l'interface web, est-ce avec Firefox ?

Le problème du ssh est qu'il faut l'activer. Je vous laisse chercher ici ou dans la documentation sur le site de la fondation, rien de bien méchant.
Débutant sous RPi / linux
[Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

cyb31
Messages : 9
Enregistré le : mer. 22 août 2018 19:52

Re: Openmediavault 4

Message par cyb31 » mer. 22 août 2018 23:43

J'utilise Chrome mais j'ai essayé avec Firefox et cela ne fonctionne pas non plus.
Pour ce qui est du SSH, pour l'activer il faut pouvoir rentrer dans la configuration d'OMV. Le soucis est que je n'y ai pas accès puisque l'interface WEB m'est refusée, OMV refuse la connexion.

dyox
Raspinaute
Messages : 459
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Openmediavault 4

Message par dyox » jeu. 23 août 2018 07:55

Bonjour,

Votre config réseau est-elle bonne ? (ping)

Avez-vous essayé les mdp par défaut ?

Avez-vous essayé d'activer le ssh en CLI ?
Débutant sous RPi / linux
[Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

cyb31
Messages : 9
Enregistré le : mer. 22 août 2018 19:52

Re: Openmediavault 4

Message par cyb31 » jeu. 23 août 2018 13:18

Je n'ai pas d'outil ou les connaissances pour vérifier mon réseau mais il à l'air OK car je viens de remettre OMV3 qui fonctionne nickel.
Enfin il fonctionnait nickel jusqu'à ce que j'établisse une connexion sécurisée en SSL (avec la création d'un certificat) mais qui au final me mettait quand même que la connexion n'était pas sécurisée (malgré l'ajout d'une exception dans Chrome). J'avais également coché "forcer la connexion en SSL".
Du coup, j'ai désactivé la connexion SSL (par contre j'ai oublié de décocher "forcer la connexion en SSL) et là... OMV n'autorise pas la connexion. J'ai le même problème qu'avec OMV4. Du coup je suppose que c'est un problème de connexion sécurisée.
Pour répondre à ta question Dyox, oui j'ai utilisé les mdp par défault (ceux donnés sur la page de téléchargement officiel d'OMV pour Raspberry). Ensuite, le SSH en CLI... késako :?:

domi
Administrateur
Messages : 2256
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Openmediavault 4

Message par domi » jeu. 23 août 2018 13:34

Bonjour,
Et en se connectant directement sur la machine ?

dyox
Raspinaute
Messages : 459
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Openmediavault 4

Message par dyox » jeu. 23 août 2018 14:19

Ensuite, le SSH en CLI... késako :?:
En ligne de commande localement je voulais dire.
Regardez https://www.raspberrypi.org/documentati ... /README.md pour l'activation.

ou un extrait de raspi-config
$ sudo service ssh start
ou
$ sudo update-rc.d ssh enable && sudo invoke-rc.d ssh start
Débutant sous RPi / linux
[Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

cyb31
Messages : 9
Enregistré le : mer. 22 août 2018 19:52

Re: Openmediavault 4

Message par cyb31 » jeu. 23 août 2018 15:50

Lorsque je branche l'écran officiel, tout se lance correctement et j'arrive sur la ligne pour se loguer. Voici ce que j'ai mis
Raspberry login: Root
Password: openmediavault
Il me demande ensuite de changer le mot de passe, chose que j'ai effectué. Puis j'ai accès aux "données" du Raspberry: adresse IP, memory usage, temp CPU,...
et j'ai la ligne "root@raspberrypi:~#"
Mais ensuite je fais quoi? je n'ai toujours pas accès à l'interface web. je désespère, toujours cette satanée fenêtre "conexion refusée"
J'ai fait une capture d'écran mais je ne trouve pas comment l'intégrer dans le post.
Est ce que cela provient de Windows?

cyb31
Messages : 9
Enregistré le : mer. 22 août 2018 19:52

Re: Openmediavault 4

Message par cyb31 » jeu. 23 août 2018 17:09

dyox a écrit :
jeu. 23 août 2018 14:19
Ensuite, le SSH en CLI... késako :?:
En ligne de commande localement je voulais dire.
Regardez https://www.raspberrypi.org/documentati ... /README.md pour l'activation.

ou un extrait de raspi-config
$ sudo service ssh start
ou
$ sudo update-rc.d ssh enable && sudo invoke-rc.d ssh start
j'ai essayé, mais toujours accès bloqué par OMV :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
Je crois que je vais définitivement repasser sur OMV3 sans connexion sécurisée... au moins ca fonctionnait!

domi
Administrateur
Messages : 2256
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Openmediavault 4

Message par domi » jeu. 23 août 2018 18:35

Bonjour,
cyb31 a écrit :
jeu. 23 août 2018 15:50
....et j'ai la ligne "root@raspberrypi:~#"
Mais ensuite je fais quoi? ...
Il y a je crois la commande

Code : Tout sélectionner

omv-firstaid
qui permet de lancer la config de openmediavault sous la console, mais pas testé, car il y a longtemps que je n'ai pas utilisé OMV.

Répondre

Retourner vers « Les applications spécialisées du Raspberry Pi »