[Résolu] Mise à jour apt-get

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

PostNoctem
Messages : 6
Enregistré le : lun. 21 mars 2016 19:38

[Résolu] Mise à jour apt-get

Message par PostNoctem » dim. 17 avr. 2016 17:38

Bonjour,
Rencontrant de nombreux problèmes étrange avec mon Raspberry, j'ai décidé de le remettre à zero.
L'installation de raspbian (jessie ou noobs) se passe bien. Dans l'ordre, je configure le raspberry dans raspi-config: vérification des partitions, changer la langue du clavier, de l'OS, changer le mot de passe admin, activer le SSH et la mise à jour dans la partie options avancées. Je redémarre le raspberry. Je fais un rpi-update. Je redemarre. C'est maintenant le tour de apt-get update, puis apt-get upgrade. Je redémarre et là c'est le drame. Soit je n'ai plus d'interface graphique (sur NOOBS) soit c'est un "kernel panic" comme le montre la photo ci-jointe.
J'ai essayé sur mon rapberry 2 et sur le 3 également.
Pour ce qui est de l'image disque, j'ai essayé les différentes versions de jessie ou noobs. J'utilise Win32DiskImager et la carte sd est reformaté avec la console windows (Diskpart -> clean -> convert mbr -> create partition primary ) puis normalement en fat32 (par défaut).
Image

Un coup de pouce serait le bienvenue, car je ne comprends vraiment pas...
Cordialement,
P.N
Modifié en dernier par PostNoctem le ven. 22 avr. 2016 00:56, modifié 1 fois.

bruno83
Messages : 72
Enregistré le : lun. 11 mai 2015 13:29

Re: Mise à jour apt-get

Message par bruno83 » dim. 17 avr. 2016 20:31

bonjour,
« pi@raspberry - $ sudo apt-get update –y && sudo apt-get dist-upgrade -y && sudo reboot »

je ferrai un dist-upgrate et as-tu stoppé tes différents serveurs exemple sudo service mysql stop avant de faire dist-upgrate
A+bruno

maxty01
Modérateur
Messages : 726
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Mise à jour apt-get

Message par maxty01 » dim. 17 avr. 2016 23:20

Bonsoir,
bruno83 a écrit :bonjour,
« pi@raspberry - $ sudo apt-get update –y && sudo apt-get dist-upgrade -y && sudo reboot »

je ferrai un dist-upgrate et as-tu stoppé tes différents serveurs exemple sudo service mysql stop avant de faire dist-upgrate
A+bruno
Alors de 1 j'utiliserai aptitude au lieu d'apt (meilleure gestion des dépendances), de 2 je ne ferai jamais un "dist-upgrade" sur un RPI (trop dangereux et pas nécessaire pour le RPI) et de 3 je ferai un rpi-update avant le reboot.

Code : Tout sélectionner

pi@raspberry ~ $ sudo aptitude update && sudo aptitude upgrade -y && sudo rpi-update && sudo reboot
Concernant les services, cela n'est pas nécessaire de les stopper, durant la mise à jour, aptitude redémarre automatiquement les serveurs/services qui dépendent des mise à jour.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

bruno83
Messages : 72
Enregistré le : lun. 11 mai 2015 13:29

Re: Mise à jour apt-get

Message par bruno83 » lun. 18 avr. 2016 00:01

je dois avoir certainement tord mais je me suis référé à cette doc (voir chapitre 6.2.3) et comme je ne suis pas un pro de linux , j’ai suivi cette consigne sans aucun écueil jusqu'à maintenant!!
https://debian-handbook.info/browse/fr- ... t-get.html

je me permets de citer l’auteur « Pour cette action, apt-get est un peu plus exigeant que aptitude ou apt parce qu'il refusera d'installer des paquets qui ne l'étaient pas préalablement. »

si non pour le serveur MySQL ne pas arrêter ce serveur lors d''une mise à jour, vous êtes sûr de le mettre en rade . Et là c’est l’expérience qui parle suite à des dizaines d’installation.
A+bruno

maxty01
Modérateur
Messages : 726
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Mise à jour apt-get

Message par maxty01 » lun. 18 avr. 2016 00:13

Bonsoir,

Ok pour la documentation Debian, c'est une bonne base.

Cependant, tu travailles avec une Raspbian (dérivée de Debian), qui possède ses propres spécificités.
Une des premières spécificités de Raspbian est d'utiliser un noyau 4.1 modifié, d'où l'utilité de la commande "rpi-update".

Concernant les différents serveurs, je vais réexpliquer que ce j'ai écrit plus haut :
Durant la mise à jour, aptitude redémarre automatiquement les serveurs/services qui dépendent des mise à jour.
Autrement dis, si après une mise à jour (généralement une Màj de library), mysql doit être redémarré, il le sera (avec ton autorisation).
De plus, après la mise jour, ton mysql sera redémarré à la suite du reboot du système (conseillé).
Maintenant, rien ne t'interdis de stopper ton mysql avant la mise à jour système.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

PostNoctem
Messages : 6
Enregistré le : lun. 21 mars 2016 19:38

Re: Mise à jour apt-get

Message par PostNoctem » lun. 18 avr. 2016 00:16

Je viens d'assayé en verifiant bien que mysql ne tourne pas. J'obtiens une erreur (voire screenshot joint) et la même chose que le screen au premier post lors du reboot.
Image

maxty01
Modérateur
Messages : 726
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Mise à jour apt-get

Message par maxty01 » lun. 18 avr. 2016 00:18

Bonsoir,

Petit rappel : ne pas utiliser la sous commande "dist-ugrade" mais "upgrade" .

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

PostNoctem
Messages : 6
Enregistré le : lun. 21 mars 2016 19:38

Re: Mise à jour apt-get

Message par PostNoctem » lun. 18 avr. 2016 00:34

J'essaye ça demain, je vous tiens au courant avec le deuxieme update avant le reboot

bruno83
Messages : 72
Enregistré le : lun. 11 mai 2015 13:29

Re: Mise à jour apt-get

Message par bruno83 » lun. 18 avr. 2016 17:12

question pourquoi pas de dist-upgrate ??
voici la doc officielle j'aimerai savoir pourquoi pas sur le pi
je cite la doc: (debian 8 jessie)
dist-upgrade
La commande dist-upgrade effectue la fonction upgrade en y
ajoutant une gestion intelligente des changements de dépendances
dans les nouvelles versions des paquets ; apt-get possède un
système « intelligent » de résolution des conflits et il essaye,
quand c'est nécessaire, de mettre à niveau les paquets les plus
importants aux dépens des paquets les moins importants. Le
fichier /etc/apt/sources.list contient une liste de sources où
récupérer les paquets désirés. Voyez aussi apt_preferences(5)
pour un mécanisme d'annulation des paramètres d'un simple
paquet.
Si non je viens de faire la mise à jour aucun soucis (j’avoue avec mes commandes habituelles :oops: :oops: ) mon uname –a me donne version 4.1.19-v7+
a+ bruno

maxty01
Modérateur
Messages : 726
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Mise à jour apt-get

Message par maxty01 » lun. 18 avr. 2016 22:32

Bonsoir bruno83,

L'utilisation de la sous commande "dist-upgrade" n'est pas utile dans le cas ou on utiliser la commande "aptitude" au lieu de "apt", car aptitude gère mieux et de base les dépendances des paquets qu'apt.
De plus la sous commande "dist-upgrade" est généralement utilisée pour mettre à jour la distribution (de Debian 7 wheezy vers Debian 8 Jessie), que je déconseille aux non initiés !

Attention, je ne dénigre absolument pas ni la distribution ni la documentation de Debian !

Par expérience avec Debian (+/- 15 ans maintenant), je n'utilise "dist-upgrade" que dans de très rare cas, généralement des mise à jour délicate qui refuse de s'installer avec un "simple" "upgrade".

Bonne nuit,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Répondre

Retourner vers « En panne ? »