[RESOLU] Probléme RPI 3b+ et pidesktop elemant14

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

[RESOLU] Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » mer. 13 juin 2018 17:57

Bonjour a tous,

j'ai fait l'acquisition d'un RPI 3B+ commandé avec le fameux boitier de chez element14.
Et j'ai le probléme suivant : un disque msata evo 840 de chez samsung est brancher sur la carte d'extention du boitier. Aucun probléme pour booter dessus.

Les choses se compliquent lors du reboot et ce malgrés la maj proposée par hoopsurfer disponible sur le lien suivant "https://translate.googleusercontent.com ... 8Xe15FD2dA" rien n'y fait ça ne reboot pas.

L'orsque que je met mon PI 3B a la place en gardant le msata aucun probléme ça reboot comme il faut.

J'ai relevé que sur le PI3 B la led rouge rreste allumée alors qu'avec le PI3B+ elle s'éteint lors de la commande de reboot.

Je n'arrive pas à trouver comment régler cela c'est déséperant.

Au passage suite aux recommandation de KUBII ou j'ai commander le matériel nous avons remplacer l'alimentation (officielle) et le PI3 b+. J'ai toujours le même probléme :shock:

Merci de votre aide.
Modifié en dernier par Major86 le sam. 7 juil. 2018 23:52, modifié 1 fois.

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Artemus24 » mer. 13 juin 2018 19:19

Salut Major86.

La led rouge, c'est PWR qui signifie POWER et donc concerne l'alimentation de votre raspberry.
Si avec votre Rpi3+, la led rouge s'éteint, vous avez un problème de puissance.
Normalement, l'alimentation de votre raspberry doit être de 5Vcc et 2.5A au maximum.
Avez-vous une autre source d'alimentation ?
Autre solution, utilisez un HUB alimenté où vous branché votre disque dur MSATA dessus.

La carte Micro SD que vous utilisez est, je suppose, configuré pour votre Rpi3.
Il existe des différences entre la Rpi3 et la Rpi3+ qui pourrait peut-être provoqué ce genre de problème.
Avez-vous fait l'installation du firmeware de Débian stretech avec votre Rpi3+ ?

@+
--> Rpi2B, Rpi3B+

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » mer. 13 juin 2018 23:24

Merci pour votre réponse.

J'ai installer stretech pour les 2 versions de mes PI et procéder a l'échange de la carte PI pour les 2 installations. J'avais déjà penser a une différence entre les deux.
Mais le résultat est le même. PI3B = voyant power allumé au reboot . PI3 B+ = voyant éteint dans les mêmes conditions.

Pour l'alimentation j'avais une AUKRU 5v 3A mais j'avais trop de low power. J'ai fait un échange auprés du distributeur et même résultat. Du coup j'ai racheté une officielle 5v1 2.5A et plus de low power sur les 2 modéles.

En ce qui concerne la carte SD j'ai une SAMSUNG 64 EVO qui ne pose aucun probléme sur les 2 configurations même au reboot. Mais pour moi le but est de m'affranchir de la carte SD.

Ce que je trouve étrange c'est que si c'était un probléme de puissance, j'aurais déjà des soucis au démarrage je pense ? Hors ce n'est pas le cas.

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Artemus24 » ven. 15 juin 2018 00:33

Salut Major86.
Major86 a écrit :J'ai installer stretch pour les 2 versions de mes PI et procéder à l'échange de la carte PI pour les 2 installations.
Vous mettez la carte micro SD, qui contient la dernière image de Stretch, dans votre Rpi3 (sans le +) et vous faites un rpi-update.
Vous mettez l'autre carte micro SD qui contient la dernière image de Stretch, dans votre Rpi3+ (avec le +) et vous faites un rpi-update.
Normalement avec cette façon de procéder, vous ne devez pas avoir de problème.

Maintenant, vous inversez vos cartes micro SD avec vos raspberry.
Pour la carte configurée avec votre Rpi3 dans le Rpi3+, cela ne doit pas fonctionner.
Pour la carte configurée avec votre Rpi3+ dans le Rpi3, cela doit fonctionner.

Je pense que la compatibilité est descendante mais pas ascendante.
En fait, votre problème se passe au boot. Je n'en sais pas plus à ce sujet.

@+
Modifié en dernier par Artemus24 le ven. 15 juin 2018 16:15, modifié 1 fois.
--> Rpi2B, Rpi3B+

Major86
Messages : 8
Enregistré le : mer. 13 juin 2018 17:43

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Major86 » ven. 15 juin 2018 07:22

Salut?

C'est bien le boot qui pose un probléme. Mais là où je ne comprend pas c'est qu'apparement le PI3B+ comprend la commande reboot pour un shutdown. Alors qu'avec le même msata (même instalation) le PI3B fait bien la différence entre un reboot et un shutdown.

C'est là que j'aimerais comprendre pourquoi ils réagissent de maniére differente et comment y remédier.

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Artemus24 » ven. 15 juin 2018 16:23

Salut major86.
Major86 a écrit :C'est là que j'aimerais comprendre pourquoi ils réagissent de manière différente et comment y remédier.
Ils réagissent de manière différente car le matériel n'est pas le même.
D'un coté, vous avez une Rpi3 (sans le +) et de l'autre une Rpi3+ (avec le plus).

Pour y remédier, vous devez avoir deux partitions de boot.
Dans le cas de la Rpi3, vous boutez sur la carte Micro SD, qui va vous monter votre partition "rootfs" du votre disque dur.
Dans le cas de la Rpi3+, vous bootez directement sur le disque dur, qui possède donc deux partitions, une Boot et une RootFS.

Pour la carte micro SD, vous avez besoin au grand maximum 100M pour installer la partition Boot. En réalité, cela tourne autour des 43M.
Une carte Micro SD de 4Go devrait largement suffire.
Vous devez posséder une clef usb pour lire vos cartes depuis votre Raspberry. Vous recopiez que la partition Boot !
Et au redémarrage de votre Rpi3, vous faites une mise à jour.

@+
Modifié en dernier par Artemus24 le sam. 16 juin 2018 02:42, modifié 1 fois.
--> Rpi2B, Rpi3B+

mike913
Raspinaute
Messages : 109
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par mike913 » ven. 15 juin 2018 22:55

Bonjour,
J' ai le même problème avec mes rpis.
1/ Avec un rpi 3 , démarré avec une carte sd , copie du système avec la commande sudo rpi-clone -f, (cela copie les 2 partions de la carte sd) je stop le rpi, j' enlève la carte et je redémarre, cela redémarre normalement je fais un reboot après et le redémarrage se passe normalement,( la lumière bleue clignote puis se rallume)
2/ avec un rpi 3 + même chose, après avoir enlevé la carte sd le démarrage s'effectue normalement , mais le problème c'est que quand on fait reboot le rpi 3+ s' arrête et ne redémarre pas (lumière bleue éteinte) il faut que j'appuie sur le bouton pour redémarrer.
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Artemus24 » sam. 16 juin 2018 16:20

Salut à tous.

Des problèmes récurrents sont liés avec la Raspberry Pi 3B+ :

1) L'éclair que l'on obtient avec l'écran arc-en-ciel, au démarrage de la raspberry.
--> https://www.framboise314.fr/wp-content/ ... errypi.pdf
--> https://code4pi.fr/2016/12/alimenter-co ... raspberry/
--> https://raspberrypi.stackexchange.com/q ... -bolt-mean

Votre Raspberry est peut-être en sous-charge électrique.
Ne mettez pas tous vos périphériques directement branchés sur les prises USB de votre Raspberry. Utilisez un hub alimenté !

Ou bien votre adaptateur n'est pas suffisamment puissant.
Il est conseillé de mettre 5Vcc / 2.5A.

2) problème avec les cartes Micro SD.
Normalement, vous devez utiliser une classe 10. Certaines cartes de classe 10, par le passé ont eu des problèmes. Les cartes SDHC nécessite un délai pour un démarrage fiable.
Voire paramétrage du "boot_delay".
--> https://elinux.org/RPiconfig#Boot

3) pas de redémarrage après un démarrage.
La solution peut éventuellement se trouver dans les fichiers logs (/var/log). Voire aussi "DMESG".

Pour redémarrer votre raspberry, vous avez soit :

Code : Tout sélectionner

sudo reboot
ou soit :

Code : Tout sélectionner

sudo shutdown -r now
ou soit encore :

Code : Tout sélectionner

sudo init 6
Personnellement, je n'utilise que le "reboot".
Pour connaitre la syntaxe exacte de la commande, faire un "man shutdown" ou un "shutdown -h".

D'après ce que j'ai pu comprendre (à prendre cela au conditionnel), il s'agit soit d'un problème de firmware et en particulier du "bootcode.bin" et du "start.elf", soit d'un bug lors de l'arrêt de la connexion Ethernet.
Comme la dernière version Raspbian Stretch date d'avril 2018, il serait bon d'attendre la prochaine afin de savoir si le problème sera résolu.

Il semble aussi que le bug soit aléatoire (le reboot), d'après ce que j'ai pu lire sur le net et se fait surtout après une nouvelle installation.
Avez-vous essayé en Wifi ?

Vu que je suis sous Rpi2, ce problème ne me concerne pas, mais m'intéresse car je vais faire l'acquisition de la Rpi3+.
Et si la Rpi3+ est bogué, je pense que je vais acheté la Rpi3.

@+
--> Rpi2B, Rpi3B+

mike913
Raspinaute
Messages : 109
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par mike913 » sam. 16 juin 2018 16:51

Bonjour
Merci de ta réponse , mais petites précisions:
1/ J'ai le boitier pidesktop je l' ai acheté pour pouvoir booter directement sur le disque msata.
2/ je n' ai donc pas de carte sd
3/ le seul périphérique branché en usb est le msata (pas d"écran) , et un ventilateur branché sur les gpio
4/ j'ai une alimentation 5V 3 ampéres

les rpi 3 et 3b+ fonctionnent correctement, la seule différence c'est que la commande sudo reboot conduit à un arrêt sur le rpi 3 b+ alors que sur le rpi3 c'est bien un reboot.

Chaque fois que je fait un reboot avec le rpi 3 b+ il faut que j'appuie sur le bouton de démarrage pour le faire repartir.
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Artemus24
Raspinaute
Messages : 212
Enregistré le : ven. 15 sept. 2017 19:15

Re: Probléme RPI 3b+ et pidesktop elemant14

Message par Artemus24 » sam. 16 juin 2018 16:56

Salut mike913.

J'ai fait une recherche sur le net pour voir ce qui est dit à ce sujet.
En ce qui concerne le reboot", cela tourne autour d'un problème de firmeware qu'il faut mettre à jour.
Mais aussi concernant un problème d'arrêt que se fait mal avec la connexion en éthernet.
D'où ma question si vous avez le même problème de redémarrage en wifi ?
A part cela, je n'en sais pas plus. Désolé. :oops:

@+
--> Rpi2B, Rpi3B+

Répondre

Retourner vers « En panne ? »