RASPBERRY PI ZERO W problème avec USB 1.1

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

dyox
Raspinaute
Messages : 536
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: RASPBERRY PI ZERO W problème avec USB 1.1

Message par dyox » ven. 24 mai 2019 08:28

En lisant le readme dans /boot/overlays, l'option dwc2 vous correspond mieux que dwc_otg
Name: dwc-otg
Info: Selects the dwc_otg USB controller driver which has fiq support. This
is the default on all except the Pi Zero which defaults to dwc2.
Load: dtoverlay=dwc-otg
Params: <None>


Name: dwc2
Info: Selects the dwc2 USB controller driver
Load: dtoverlay=dwc2,<param>=<val>
Params: dr_mode Dual role mode: "host", "peripheral" or "otg"

g-rx-fifo-size Size of rx fifo size in gadget mode

g-np-tx-fifo-size Size of non-periodic tx fifo size in gadget
mode
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

reptooyep
Messages : 11
Enregistré le : jeu. 23 mai 2019 07:39

Re: RASPBERRY PI ZERO W problème avec USB 1.1

Message par reptooyep » ven. 24 mai 2019 09:12

Oh, c'est intéressant ça,
Merci d'y avoir consacré du temps.
Du coups, si je comprend bien, il faut que je change le dt overlay pour forcer le fiq sur dwc_otg ?
Ou alors, je peux utiliser les mêmes options que dwc_otg en mettant dwc2_otg ? J'ai du mal a suivre. Il va faloir que je creuse ça.
Et au fait, il n'y a qu'un seul usb sur pi zero, c'est quoi dwc2 ?

reptooyep
Messages : 11
Enregistré le : jeu. 23 mai 2019 07:39

Re: RASPBERRY PI ZERO W problème avec USB 1.1

Message par reptooyep » sam. 25 mai 2019 00:21

Problème résolu.
J'ai fini par changer le HUB. J'en ai trouvé un tout aussi bas de gamme mais avec une vraie puce, pas un espèce de goutte de résine qui cache on ne sait quoi.
Le problème de ces manips a la c.., c'est qu'a force de dessouder les prises, les pistes se décollent.
Ce HUB fonctionne sous rpi3b, étrange.
En tout cas, le résultat est épatant. Je pense que ça vaut un instructable.
Merci encore.

Je vais installer doom et quake en plus 😁

dyox
Raspinaute
Messages : 536
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: RASPBERRY PI ZERO W problème avec USB 1.1

Message par dyox » sam. 25 mai 2019 08:23

Cool !

Pour le reste de la communauté mondiale, on pourrait avoir le modèle du nouveau hub compatible Pi Zero et la référence de la puce USB si c'est possible ? Merci pour eux.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

reptooyep
Messages : 11
Enregistré le : jeu. 23 mai 2019 07:39

Re: RASPBERRY PI ZERO W problème avec USB 1.1

Message par reptooyep » sam. 25 mai 2019 09:21

Celui qui ne fonctionne pas sur PI ZERO W en USB1.1 :
Image

Celui qui fonctionne sans souci :
Image

La puce interne de celui qui fonctionne :
Image

Répondre

Retourner vers « En panne ? »