RasPi Zero : Accès Internet très lent

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Répondre
bluesman13
Messages : 3
Enregistré le : jeu. 30 juin 2016 10:20

RasPi Zero : Accès Internet très lent

Message par bluesman13 » jeu. 30 juin 2016 10:32

Bonjour,
Je viens de démarrer un RaspBerry Pi Zero avec la dernière version de RaspBian. Tout fonctionne bien, sauf les accès à Internet qui sont très lent. J'ai fait quelques tests avec IPERF3 et CURL, voici les résultats :

LAN Tests.
DOWNLOAD (mesure en bit par seconde : environ 80 Mbit/s).
pi@raspberrypi:~ $ iperf3 -c 192.168.1.15 -i 2 -t 20
Connecting to host 192.168.1.15, port 5201
[ 4] local 192.168.1.27 port 53650 connected to 192.168.1.15 port 5201
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-20.01 sec 197 MBytes 82.6 Mbits/sec 0 sender
[ 4] 0.00-20.01 sec 197 MBytes 82.5 Mbits/sec receiver

UPLOAD (mesure en bit par seconde : environ 60 Mbit/s).
pi@raspberrypi:~ $ iperf3 -s
Server listening on 5201
[ ID] Interval Transfer Bandwidth Retr
[ 5] 0.00-20.00 sec 152 MBytes 63.6 Mbits/sec sender
[ 5] 0.00-20.00 sec 152 MBytes 63.6 Mbits/sec receiver

Internet Tests.
DOWNLOAD (mesure en octet par seconde : environ 6 Mo/s).
pi@raspberrypi:~ $ curl -o /dev/null http://ikoula-ipv4.testdebit.info/fichiers/500Mo.dat
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 476M 100 476M 0 0 5709k 0 0:01:25 0:01:25 --:--:-- 5799k

Le même test avec le même adaptateur USB Ethernet sur mon Mac est deux fois plus rapide (environ 10 Mo/s) :
mac-richard:~ richard$ curl -o /dev/null http://ikoula-ipv4.testdebit.info/fichiers/500Mo.dat
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 476M 100 476M 0 0 9.9M 0 0:00:47 0:00:47 --:--:-- 10.4M

Avez-vous déjà rencontré ce souci ?
Cordialement.
Ricardo

Raspberry Pi Zero - SD-Card Samsung 16 Gb - RaspBian Jessie (Full desktop image based on Debian Jessie) - Version:May 2016 - Release date:2016-05-27 - USB Fast Ethernet Adapter

yoshi
Raspinaute
Messages : 102
Enregistré le : sam. 29 août 2015 08:29

Re: RasPi Zero : Accès Internet très lent

Message par yoshi » jeu. 30 juin 2016 11:13

Salut,
Il faut garder en tête qu'un rpi 0 est beaucoup mon puissant qu'un mac donc il est normal que le debit est plus lent, cependant n'y a t'il pas un programme qui sature l'accès internet ?

@+
-Deux raspberry avec Cayenne pour suivre la température
-Bientôt deux arduino nano pour un drone térrestre

bluesman13
Messages : 3
Enregistré le : jeu. 30 juin 2016 10:20

Re: RasPi Zero : Accès Internet très lent

Message par bluesman13 » jeu. 30 juin 2016 11:37

Bonjour,
Merci pour votre réponse rapide.
Toutefois, je n'ai installé pour l'instant que la version standard sans aucune autre appli !
Et d'autre part, ce qui m'étonne c'est que l'accès en UPLOAD vers Internet est normal (environ 90 Mbit/s, ce qui est la limite de l'adapteur Fast Ethernet !).
En revanche, en DOWNLOAD, il ne dépasse pas les 50 Mbit/s, ce qui n'est pas normal ! C'est la seule machine sur laquelle je rencontre cette anomalie.
Ricardo.

Avatar du membre
xGunMachine
Messages : 91
Enregistré le : jeu. 2 juin 2016 19:27

Re: RasPi Zero : Accès Internet très lent

Message par xGunMachine » jeu. 30 juin 2016 13:29

Heu, je crois je vais pleurer, chez moi je suis à 500-600 ko de download.
Tu à la fibre ?
Il ne faut pas oublier que si tu passe par l'usb celui-ci est normalement limité à 20mo max (usb 2.0)


Envoyé de mon iPhone - Tapatalk
Mes projets :
NES Pi : Émulateur Raspberry pi dans un boitier NES dans sont jus
GameBoy Pi : Émulateur Raspberry pi dans un boitier GameBoy Classic

bluesman13
Messages : 3
Enregistré le : jeu. 30 juin 2016 10:20

Re: RasPi Zero : Accès Internet très lent

Message par bluesman13 » jeu. 30 juin 2016 13:47

Bonjour,
Oui j'ai la fibre, mais le débit réseau du "RaspPi Zero" est limité par l'adapteur USB2-Fast Ethernet, c'est à dire au maximum à 100 Mbit/s.
Bien sûr sur mon Mac, avec le même adaptateur, que ce soit en Download ou Upload, j'arrive presque aux valeurs maxi, mais le "RasPi Zero" bride le débit en Download à 50 Mbit/s.
Tout ça ne sont que des mesures "théoriques", car, en utilisant le Navigateur Internet de RaspBian, le débit est beaucoup plus faible !
@+

destroyedlolo
Raspinaute
Messages : 1388
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: RasPi Zero : Accès Internet très lent

Message par destroyedlolo » jeu. 30 juin 2016 16:07

Ca y est, je pleure avec mes pauvres 900kb/5Mb .... ooouuuiiiinnnnnn :(
bluesman13 a écrit : Tout ça ne sont que des mesures "théoriques", car, en utilisant le Navigateur Internet de RaspBian, le débit est beaucoup plus faible !
@+
Ca, c'est normal :
  • T'as la charge CPU due au navigateur et au protocole
  • si les fichiers temporaire sont sur SD, t'as la limite de bande passante pour cette derniere
  • si c'est sur disque, l'USB du disque et les flux réseau ce marchent dessus
Mais ca n'explique pas les perfs pourries avec iperf3 :oops:
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Avatar du membre
xGunMachine
Messages : 91
Enregistré le : jeu. 2 juin 2016 19:27

Re: RasPi Zero : Accès Internet très lent

Message par xGunMachine » jeu. 30 juin 2016 17:24

Je pourrai pas aider avec ma connexion pas moyen de savoir la bande max, il me semble que le théorique doit être divisé par environ 8 pour obtenir le réel du style 50mo de débit = 6,25mo de débit réel
Je n'en suis pas sûr quelqu'un pour confirmer ?


Envoyé de mon iPhone - Tapatalk
Mes projets :
NES Pi : Émulateur Raspberry pi dans un boitier NES dans sont jus
GameBoy Pi : Émulateur Raspberry pi dans un boitier GameBoy Classic

yoshi
Raspinaute
Messages : 102
Enregistré le : sam. 29 août 2015 08:29

Re: RasPi Zero : Accès Internet très lent

Message par yoshi » jeu. 30 juin 2016 18:16

Salut xGunMachine,
l me semble que le théorique doit être divisé par environ 8 pour obtenir le réel du style 50mo de débit = 6,25mo de débit réel
Je crois pas car je suis à 400mbit/s et pourtant je télécharge à ~70mo/s
-Deux raspberry avec Cayenne pour suivre la température
-Bientôt deux arduino nano pour un drone térrestre

Avatar du membre
xGunMachine
Messages : 91
Enregistré le : jeu. 2 juin 2016 19:27

Re: RasPi Zero : Accès Internet très lent

Message par xGunMachine » ven. 1 juil. 2016 07:37

Eh bah la tu me le confirme : 400 / 8 = 50 donc c'est à peu près ça, non ?


Envoyé de mon iPhone - Tapatalk
Mes projets :
NES Pi : Émulateur Raspberry pi dans un boitier NES dans sont jus
GameBoy Pi : Émulateur Raspberry pi dans un boitier GameBoy Classic

yoshi
Raspinaute
Messages : 102
Enregistré le : sam. 29 août 2015 08:29

Re: RasPi Zero : Accès Internet très lent

Message par yoshi » ven. 1 juil. 2016 09:53

Ah oui...
Mais fait gaffe car c'est pas toujours le cas...

Bien à toi
-Deux raspberry avec Cayenne pour suivre la température
-Bientôt deux arduino nano pour un drone térrestre

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »