[RESOLU] Clash partition SD

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

nexen
Raspinaute
Messages : 175
Enregistré le : lun. 29 sept. 2014 13:58

Re: Clash partition SD

Message par nexen » mar. 8 août 2017 16:03

as-tu essayer de la formatter bas-niveau avec SD-Format ?

rebeldu31
Raspinaute
Messages : 245
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Clash partition SD

Message par rebeldu31 » mar. 8 août 2017 16:28

nexen a écrit :as-tu essayer de la formatter bas-niveau avec SD-Format ?
Je suis en train de retenter le coup en formattant ma SD 32Go bas niveau.
Puis je descendrais la dernière image faite.
Si KO, je recommencerais depuis le début et y descendrais l'image précédente.

Y en a bien une qui va être OK !!!
:shock: :?
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : serveur web (Roundcube, Postfixadmin, Nextcloud en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

rebeldu31
Raspinaute
Messages : 245
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Clash partition SD

Message par rebeldu31 » mer. 9 août 2017 12:12

Bon ben je crois que la messe est dite !!!

Après X tentatives de formatage/descente de mon image sur ma SD 32Go, ça ne fonctionne toujours pas...
Mon RPI ne démarre pas...
Une vague impression de partition de boot non existante après le formatage...
Pour preuve : lorsque j'enlève et remets ma SD (avec son adaptateur) sur mon PC, hop petit message me demandant de la formater !!!

Et pourtant, lorsque je branche ma SD sur un RPI, elle n'est pas vide, il y a bien mon système dessus...
Bizarre !!!
:? :?
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : serveur web (Roundcube, Postfixadmin, Nextcloud en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

domi
Administrateur
Messages : 2623
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Clash partition SD

Message par domi » mer. 9 août 2017 12:43

Question peut-être idiote, mais au cas où ta carte ait des secteurs défectueux, tu as testé avec une carte neuve ?

rebeldu31
Raspinaute
Messages : 245
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Clash partition SD

Message par rebeldu31 » mer. 9 août 2017 15:44

domi a écrit :Question peut-être idiote, mais au cas où ta carte ait des secteurs défectueux, tu as testé avec une carte neuve ?
Les 2 cartes SD (16 et 32) ? Ça serait un pas de bol complet !!!

Mais j'ai peut-être une piste, je suis en train de la tester !!!
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : serveur web (Roundcube, Postfixadmin, Nextcloud en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

rebeldu31
Raspinaute
Messages : 245
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Clash partition SD

Message par rebeldu31 » mer. 9 août 2017 17:57

Bon...
La chanson de Brassens "Quand on est con, on est con", c'est pour moi !!!
:evil: :evil:

Quand je fais ma sauvegarde, je sauvegarde que le système, donc /dev/mmcblk0p2 et non la carte entière, donc pas la partition de boot /dev/mmcblk0p1.
Donc, depuis bientôt 72h j'essaie de descendre mon image de la partition système /dev/mmcblk0p2 (avec Diskimager) sur ma carte entière, SANS partition de boot !!!

QUEL C...N !!!

Donc, là voilà. De mon autre RPI j'ai descendu la partition système sauvegardée début juillet (celle de juste avant le clash ne veut pas booter) MAIS avec un dd if/off (et non Diskimager) sur /dev/sdb2 de ma carte 32Go.
Je remet la carte dans le RPI...
Je boote...
EUREKA !!! Mon RPI démarre.
Cool je me dis, je repars comme début juillet !!!

Eh ben non, que dale, makache, walou !!!

Il répond au ping... MAIS impossible de m'y connecter en ssh ou autre....
Même l'accès https (pour ma page de surveillance EZServerMonitor) est impossible...

Branché en HDMI sur un écran, le boot reste à "Reached target Paths" !!!

Donc là, coincé encore une fois !!!
GRRRRRRRRRRRRRRRRRRR
:o :o
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : serveur web (Roundcube, Postfixadmin, Nextcloud en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

dyox
Raspinaute
Messages : 564
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Clash partition SD

Message par dyox » mer. 9 août 2017 18:45

Bonsoir,

Je n'ai pas tout relu !

Si vous avez une sauvegarde récente, rien ne vous empêche de la restaurer puis de créer une partition de 70Mo en FAT32 puis d'y créer un fichier ssh (pour l'activer) en plus de recopier la partition de boot ; celle de l'iso Raspian ou une autre.
Cela devrait fonctionner.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

rebeldu31
Raspinaute
Messages : 245
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Clash partition SD

Message par rebeldu31 » mer. 9 août 2017 20:29

C'est bon !!!
:D

Enfin presque !!!

Comme j'en avais un peu marre de faire joujou avec la SD de mon téléphone, j'ai décidé de repartionner complètement ma SD 16Go avec fdisk...
J'ai donc créé la partition primaire en FAT32 et la partition secondaire. Avec LES bonnes tailles et autres...
J'ai fais un dd if/of de la sauvegarde système de début juillet sur la partition /dev/sdb2...
J'ai remis ma carte dans le RPI et j'ai démarré...
Et là, YOUPIIII....
Il a redémarré, est accessible en ssh...
Bon...
Quelques réglages et/ou corrections à faire car il aurait perdu des plumes entre temps...
Ma clé 3G connectée en USB avec des udev rules spécifiques ne fonctionne plus...
L'affichage après le boot de l'image sur mon petit écran LCD ne se fait plus...
Bref, quelques broutilles, sauf la clé 3G que j'ai besoin....
Et demain je pars en vacances... Donc ça attendra... Sauf si une lueur apparaît dans mon cerveau déconnecté !!!
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : serveur web (Roundcube, Postfixadmin, Nextcloud en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

nexen
Raspinaute
Messages : 175
Enregistré le : lun. 29 sept. 2014 13:58

Re: Clash partition SD

Message par nexen » jeu. 10 août 2017 11:57

je suis ravi que tu ai trouvé la solution

et que les petits nouveau comprennent tes erreurs pour ne pas les reproduire.

PS : Je travaille dans l'informatique ... gros systèmes ... et toutes nos procédure d'installation/configuration ont une étape Backup ... suivi de la restauration .... et oui ... car on est jamais sur de savoir restaurer.

rebeldu31
Raspinaute
Messages : 245
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Clash partition SD

Message par rebeldu31 » mar. 22 août 2017 19:05

nexen a écrit :je suis ravi que tu ai trouvé la solution

et que les petits nouveau comprennent tes erreurs pour ne pas les reproduire.

PS : Je travaille dans l'informatique ... gros systèmes ... et toutes nos procédure d'installation/configuration ont une étape Backup ... suivi de la restauration .... et oui ... car on est jamais sur de savoir restaurer.
Je suis expert sauvegarde/stockage !!!
8-)
Pi3 : envoi/réception SMS et sauvegardes
Pi3 : serveur de mail privé
Pi3 : cluster du serveur de mail (en cours)
Pi3 : serveur web (Roundcube, Postfixadmin, Nextcloud en cours)
Pi2 : tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

Répondre

Retourner vers « En panne ? »