[RESOLU]Monter un lecteur réseau au boot

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Avatar du membre
joce69740
Messages : 5
Enregistré le : lun. 2 oct. 2017 19:19

[RESOLU]Monter un lecteur réseau au boot

Message par joce69740 » lun. 9 oct. 2017 09:59

Bonjour,

Je tente de monter un 'lecteur réseau' (désolé, je viens du monde Windows) au démarrage de mon Raspberry.
J'ai ajouté cette ligne au fichier /etc/fstab:

//192.168.0.120/Backup/Raspberry /media/pi/Safe cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=100,uid=1000,_netdev 0 0

L'accès ne se monte que si je lance la commande mount -a manuellement. J'ai tenté de la mettre dans le crontab avec @reboot mais cela ne fonctionne pas.
J'ai installé Disk-Manager mais celui-ci ne voit pas le partage.

Auirez-vous une astuce pour un débutant Linux SVP ?
Modifié en dernier par joce69740 le mar. 10 oct. 2017 11:20, modifié 1 fois.

Avatar du membre
Flachy Joe
Messages : 82
Enregistré le : mar. 20 sept. 2016 22:30

Re: Monter un lecteur réseau au boot

Message par Flachy Joe » lun. 9 oct. 2017 22:47

Salut,
rajoute ,auto dans la liste d'options.
Source : https://wiki.debian-fr.xyz/Monter_un_pa ... hier_fstab

Bonne continuation

Avatar du membre
joce69740
Messages : 5
Enregistré le : lun. 2 oct. 2017 19:19

Re: Monter un lecteur réseau au boot

Message par joce69740 » mar. 10 oct. 2017 09:35

Bonjour,

Merci pour ta réponse et le tuto.
Expliqué comme cela, ça parait simple :)
J'ai modifié ma ligne dans le fichier fstab:
//192.168.0.120/Backup/Raspberry /media/pi/Safe cifs _netdev,users,auto,users,credentials=/home/pi/.smbcred 0 0
Le fichier .smbcred est bien renseigné comme dit dans le tuto
Les droits sur le fichier sont:

pi@raspberrypi:~ $ ls -l /home/pi/.smbcred
-rw-r----- 1 pi root 48 oct. 10 08:50 /home/pi/.smbcred

Dans le tuto il y a 60 et moi j'ai 48...je ne sais pas à quoi cela correspond

Si je lance sudo mount -a avec l'utilisateur pi, cela fonctionne. Mon partage est bien monté.

Par contre, au reboot, rien ne se passe.

Par contre, j'ai trouvé une sorte de log dans mon répertoire /home/pi mount.lo qui me dit ceci:

"mount error(101): Network is unreachable"

Il semblerait donc que le réseau ne soit pas encore disponible au moment où la commande s'effectue.

Une idée de comment 'attendre' la connexion avant de lancer la commande ?

destroyedlolo
Raspinaute
Messages : 1289
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Monter un lecteur réseau au boot

Message par destroyedlolo » mar. 10 oct. 2017 09:58

Salut,

Il y a de tres grande chance que le réseau ne soit lancé qu'après le montage des filesystem.

Il faut donc que tu crée un autre scripte qui dépend du réseau et qui monte ce "disque".

A+
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Avatar du membre
joce69740
Messages : 5
Enregistré le : lun. 2 oct. 2017 19:19

Re: Monter un lecteur réseau au boot

Message par joce69740 » mar. 10 oct. 2017 10:05

Mais logiquement la commande '_netdev' est là justement pour permettre d'attendre une connexion réseau valide avant d'effectuer la commande...non ?

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Monter un lecteur réseau au boot

Message par spourre » mar. 10 oct. 2017 11:02

destroyedlolo a écrit :Salut,

Il y a de tres grande chance que le réseau ne soit lancé qu'après le montage des filesystem.

Il faut donc que tu crée un autre scripte qui dépend du réseau et qui monte ce "disque".

A+
Bonjour,

Dans raspi-config, option boot, option:
B2 Wait for Network at Boot Choose whether to wait for network connection during boot

oblige à attendre l'accès réseau avant de poursuivre le boot.

Sylvain

destroyedlolo
Raspinaute
Messages : 1289
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Monter un lecteur réseau au boot

Message par destroyedlolo » mar. 10 oct. 2017 11:04

Une discussion sur le _netdev : https://unix.stackexchange.com/question ... fstab-work
En résumé : il semble être ignoré par mount.
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Avatar du membre
joce69740
Messages : 5
Enregistré le : lun. 2 oct. 2017 19:19

Re: Monter un lecteur réseau au boot

Message par joce69740 » mar. 10 oct. 2017 11:14

Yes !!! Il me semblait avoir vu cette option quelque part mais impossible de m'en souvenir.
Tout fonctionne. C'est parfait !!!
Merci à vous tous.

Répondre

Retourner vers « En panne ? »