Problème de routeur / parefeu ?

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
Felice
Messages : 8
Enregistré le : jeu. 26 oct. 2017 20:16

Problème de routeur / parefeu ?

Message par Felice » jeu. 16 nov. 2017 15:12

Bonjour,

J'ai un soucis, j'ai transféré mon site sur mon Raspberry, le site marche très bien et j’ai accès sur le Raspberry et autres matériels comme les ordinateurs.

Cependant il s'avère que le site n'est pas accessible chez les autres personnes.

Je pense qu'il y a un problème de parefeu / routeur.

Je suis chez free et j'ai ouvert le port 80 sur la bonne ip dans la section « Redirections de ports » avec :

PORT EXTERNE PROTOCOLE IP DE DESTINATION PORT INTERNE
80 TCP [ip du Rasdberry] 80

Puis j'ai redémarré la box

Que faut-il faire d'autre pour que les gens ont accès.

Parce que si j'ai bien compris il n’y a pas par défaut de pare-feu sur Raspbian, pourtant ça ne marche pas :-(.

Merci de vos retours.

Avatar du membre
Shini
Messages : 3
Enregistré le : mar. 20 sept. 2016 10:48

Re: Problème de routeur / parefeu ?

Message par Shini » jeu. 16 nov. 2017 17:26

Bonjour,

Tout d'abord, quand tu essayes d'accéder à ton site à distance, testes-tu de ton pc qui est derrière ta freebox ? Essayes-tu d'accéder à ton site avec ton IP publique ?

Cordialement,
Shini

Felice
Messages : 8
Enregistré le : jeu. 26 oct. 2017 20:16

Re: Problème de routeur / parefeu ?

Message par Felice » jeu. 16 nov. 2017 18:00

Tout d'abord merci de ta réponse Shini,

Alors oui mon PC est derrière ma freebox.

L'ip publique ? c'est laquelle ?

Il y a l'ip que j'ai configuré dans le routeur (celle que tu peux connaître via la commande iwconfig) et l'autre, dans les deux cas j'arrive à accéder au site.

De même pour le nom de domaine.

Dans le fichier « /etc/hosts », je définie le nom de domaine avec l'autre IP.

Maintenant j'avais déjà fait ça sur mon PC à l'époque et j'avais d'ailleurs le même problème, je ne sais plus comment le résoudre :-/.

Merci de ton aide.

tor_rpi
Messages : 6
Enregistré le : jeu. 16 nov. 2017 18:27

Re: Problème de routeur / parefeu ?

Message par tor_rpi » jeu. 16 nov. 2017 18:48

Salut Félice
Pour avoir l'ip 'publique' de ta freebox, va ici : https://whatismyipaddress.com

Puis depuis ton téléphone en 4G, va sur http://[TON_IP] et tu verras ton site internet, si ta redirection fonctionne.

La bise

Avatar du membre
marco123
Raspinaute
Messages : 436
Enregistré le : sam. 30 janv. 2016 07:59
Localisation : Val d'Oise

Re: Problème de routeur / parefeu ?

Message par marco123 » jeu. 16 nov. 2017 20:33

alors, oui, il faut que tu te connectes via ton ip publique ( 82..... ) et non pas via ton ip locale ( 192..... )
Ta redirection dans ta fb ne sert à rien sauf si tu es en fibre ip partagée .
Pour ton ip publique, tu peux la trouver de manière différente . question sur quant " mon ip " ... la réponse te renverra
sur un site qui te la donnera ! ( http://www.mon-ip.com/ )
Les gens n'ont qu'a la retaper pour un accès à ton site .
http://ton ip publique

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Problème de routeur / parefeu ?

Message par spourre » jeu. 16 nov. 2017 23:38

tor_rpi a écrit :Salut Félice
Pour avoir l'ip 'publique' de ta freebox, va ici : https://whatismyipaddress.com

Puis depuis ton téléphone en 4G, va sur http://[TON_IP] et tu verras ton site internet, si ta redirection fonctionne.
Ce qu'il y a de bien avec free c'est que tu disposes:

1) d'une @IP fixe gratuite (sur demande si non dégroupé) ==> pas besoin d’un DynDNS.
2) Tu peux personnaliser ton reverse DNS donc donner un nom parlant à ta machine.
3) du freeWIFI gratuit qui te donne une adresse différente que celle de ta box (HADOPI proof) donc:

Il est donc très facile d'héberger un site surtout si on lui donne une @IP fixe par la freebox (bail infini sur @MAC) et de le tester.

Sylvain

Felice
Messages : 8
Enregistré le : jeu. 26 oct. 2017 20:16

Re: Problème de routeur / parefeu ?

Message par Felice » ven. 17 nov. 2017 06:40

Merci à tous,

Finalement le problème vient de la sécurité du nom de domaine de l'hébergeur.

L'accès par l'ip fonctionnant en fait.

Répondre

Retourner vers « Utilisateurs avancés »