Port eth0 down

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Répondre
Vince34
Messages : 2
Enregistré le : mar. 21 janv. 2020 23:39

Port eth0 down

Message par Vince34 » mer. 22 janv. 2020 00:01

Coucou
Je viens de brancher mon pi4 fraîchement déballé, et il m'indique que le port eth0 est down. ( Je l'ai évidement branché sur une prise ethernet que je sais fiable)
Le port est défectueux sur la carte?il y a une manip pour check/debug ?
Merci d'avance

jordan
Messages : 1
Enregistré le : ven. 24 janv. 2020 11:20

Re: Port eth0 down

Message par jordan » ven. 24 janv. 2020 11:29

Salut,je suis moi aussi débutant,J’ai reçu mon pi4 4go il y a peu,j’ai pas mal galéré a installer quelques choses dessus mais se matin j’ai trouvé (j’essayait de booter sur l’adaptateur USB -> sd et ça ne marchait pas,une fois mise la sd dans le pi directement,magie ça a marché)

Donc j’ai eu l’écran d’accueil de raspbian buster sur ma TV,j’ai mis en français,
Je le connecte en wifi,malgré qu’un câble rj45 viable soit brancher,je faits les mise a jour,et la reboot.
La LED rouge est fixe,la verte clignote par une impulsion.

Mais j'ai le même soucis que toi...je n'arrive pas a la connecter en ethernet,je sais que le câble marche car c'est mon câble réseau de mon décodeur TV qui marche h24.
en haut a droite j'ai écrit eth0 down,et aucune led ne s'allume sur le port ethernet du pi.
Je précise que lors de mes essaie de d’installation de système il s'allumait au début mais ou bout de 2 3 essai il ne s'allume plus...

Je vois bien mon pi en wifi sur la page d'accueil de ma livebox.
Comment peut on remedier a ce problème svp?

Merci d’avance,

Jordan

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Port eth0 down

Message par cbalo » mar. 28 janv. 2020 10:05

Bonjour, eh bien, il semble que ce soit un problème courant vu le nombre de forums, et de poste qui traitent du sujet.
Mais je n'ai pas vu quelqu'un ayant trouvé la solution miracle au problème.

https://github.com/raspberrypi/linux/issues/3108#

On peut toujours vérifier 2-3 choses :
Redémarrer le switch (ou box ou routeur)
Essayer avec un port en 100mbits plutôt qu'en 1gbits.
S'assurer que le câble réseau est bien de qualité en adéquation avec la vitesse de transmission.
S'assurer que l'alim du raspberry est bien l'officielle.

Mais pour l'instant je n'ai vu personne poster LA solution miracle



Envoyé de mon SM-J710F en utilisant Tapatalk


Artemus24
Raspinaute
Messages : 595
Enregistré le : ven. 15 sept. 2017 19:15

Re: Port eth0 down

Message par Artemus24 » mer. 29 janv. 2020 07:09

Salut à tous.

D'après ce que j'ai compris, vous utilisez raspbian Buster.
Avez-vous fait le même test mais avec raspbian stretch ?
Il est possible que le problème soit lié à Buster et non au matériel.

Quel est le débit ethernet sortant de votre box ?
Votre box est-elle PoE (Power over Ethernet) ou pas ?

Si le problème vient de l'alimentation par ethernet, pourquoi ne pas se procurer ce genre de matériel :
--> https://www.amazon.fr/DSLRKIT-Active-Sp ... 01H37XQP8/

Autre idée, au démarrage, il se peut que la priorité soit donnée au WLAN et non à ETH0.
Normalment, si un câble éthernet est branché, cela doit désactivé WLAN0.

Pouvez-vous nous communiquer le :

Code : Tout sélectionner

ifconfig -a
juste après le problème que vous rencontrez ?
Y-a-t-il une adresse 169.254.x.x ?

De même, y-a-t-il un firewall qui est installé ?
Faites un :

Code : Tout sélectionner

iptables -L -vn
et donnez nous le résultat.

Il est possible que le déclenchement de la demande d'accès à l'internet se fasse alors que l'accès au réseau n'est pas encore disponible.
Voir dans "raspi-config" le paramétrage pour attendre la disponibilité du réseau.
Vince34 a écrit :il m'indique que le port eth0 est down
S'il est down, il faut relancer l'activation manuellement :

Code : Tout sélectionner

sudo ifconfig eth0 up
et voir si cela produit un résultat positif.
Si cela fonctionne en l'état, il suffit de créer un script et de l'introduire lors du redémarrage de la raspberry.

L'idée de cette commande (ifconfig eth0 up) est de redemander au dhcp server de votre box, une nouvelle attribution d'adresse IP.
Sous windows, c'est cette commande :

Code : Tout sélectionner

ipconfig /release
ipconfig /renew
La première remet à zéro l'attribution de l'adresse IPv4 (raspberry : sudo ifconfig eth0 down)
La seconde redemande à nouveau l'attribution de l'adresse IPv4 (raspberry : sudo ifconfig eth0 up)

Pour diagnostiquer le problème, vous devez installer :

Code : Tout sélectionner

sudo apt-get install ethtool
puis faire ceci :

Code : Tout sélectionner

ifconfig -a
ethtool eth0
et nous communiquer le résultat.

Avez-vous un un adaptateur USB Ethernet ?
Il est fort probable que la connexion se fasse normalement.
A tester !

Il semble que la commande suivante :

Code : Tout sélectionner

sudo mii-tool -r eth0
permet de faire fonctionne l'interface eth0.
A tester aussi !

Une solution de contournement après le démarrage de la raspberry, est de débrancher le câble éthernet puis de le rebrancher.

@ cbalo : as-tu le même problème ?

P.S.: Je n'ai pas fait les tests car je n'ai pas de RPi 4B.

@+
--> RPI4B/8GB + Argon FanHAt
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

brucine
Messages : 20
Enregistré le : mer. 22 avr. 2020 11:28

Re: Port eth0 down

Message par brucine » mer. 22 avr. 2020 11:47

Bonjour à tous,

Avant qu'un expert m'incendie, je suis un Linux nul, je n'y avais pas touché depuis un EeePC (Xandros) il y a quelques années.

Quelqu'un vient de m'offrir un Pi 4 (Kit 4GO avec boîtier alimentation préchargé Raspbian).

Je me suis contenté de monter le matériel, je n'ai rien fait, quand j'ai voulu mettre les paquetages à jour (par Add/Remove Software de l'interface LXDE ou à la ligne de commandes), je me suis fait jeter par des messages d'erreur.

Dans le même temps et sans aucun paramétrage, de mémoire, la connexion Wifi prenait systématiquement la main sur la connexion Ethernet.

De rage, je vous l'ai dit, je suis nul, j'ai formaté sur un PC Windows une carte SD 64GO avec SD Card Formatter, j'ai téléchargé Raspberry Pi Imager, bref, j'ai réinstallé à neuf.

Et là, miracle ou coïncidence, les téléchargements de paquetages fonctionnent (j'ai commencé par mettre à jour VNC Server parce que la notification nouvelle version me fatiguait) mais, en ce qui nous concerne, la connexion Ethernet fonctionne par défaut sans que j'aie rien paramétré ni dans raspi-config ni dans Network Settings: en dehors d'autres causes, il y a donc peut-être dans certains cas des paquetages foireux dans certaines installations par défaut.

Répondre

Retourner vers « Débutants »