GeoIp Update et 32 bits

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
piper
Raspinaute
Messages : 669
Enregistré le : sam. 5 juin 2021 18:57

GeoIp Update et 32 bits

Message par piper » dim. 19 mai 2024 20:08

Bonjour,
L' obsolescence programmée poursuit son avancée :
Si vous êtes utilisateurs du paquet geoip-update de Maxmind pour mettre à jour votre base de données d'ip et l'utiliser pour de la géo localisation, je viens de m'apercevoir que ce paquet n'est plus disponible pour les architectures Arm en 32 bits , mais seulement en 64 bits

Il reste possible de télécharger les sources et de les compiler mais c'est développer en Go, Go qui n'est pas installé par défaut, et pour lequel, il n'y a pas de paquet Arm 32 bits , donc il faut aussi télécharger les sources de Go et les compiler.

Bref, tout cela pour dire que si vous réinstaller/installer un OS sur un Pi, mieux vaut prendre une version 64 bits
3 Pi4 : Emby / Samba , Librelec, Android TV
3 Pi3 : Hifiberry /OSMC, Games station, Samba / VPN / HotSpot Wifi
2 Pi2 : RFID, radio reveil (PiReveil)
1 Pi0 : traker GPS et acquisitions
1 Pi0 2W : tests divers
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

destroyedlolo
Raspinaute
Messages : 1591
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: GeoIp Update et 32 bits

Message par destroyedlolo » dim. 19 mai 2024 22:06

Ou alors simplement de cross compiler non ?
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

piper
Raspinaute
Messages : 669
Enregistré le : sam. 5 juin 2021 18:57

Re: GeoIp Update et 32 bits

Message par piper » mar. 21 mai 2024 00:06

Oui, il faut installer Go pour compiler les sources de GeoIP Update
https://github.com/maxmind/geoipupdate

Et Pour installer Go, il faut récupérer ses sources et l'installer
Sinon, GeoIp Update est aussi dispo via docker mais bon.... c'était tellement plus simple avec le paquet pour aptitude

Donc, il faut passer au 64 bits si on veut continuer de l'installer via un paquet aptitude
Ou ne pas utiliser RaspiOS
3 Pi4 : Emby / Samba , Librelec, Android TV
3 Pi3 : Hifiberry /OSMC, Games station, Samba / VPN / HotSpot Wifi
2 Pi2 : RFID, radio reveil (PiReveil)
1 Pi0 : traker GPS et acquisitions
1 Pi0 2W : tests divers
5 Arduinos dont 4 nanos et 1 Mega
1 ESP32

Répondre

Retourner vers « Utilisateurs avancés »